Jump to content

RTL 8187 Wireless help please


15 posts in this topic

Recommended Posts

  • 1 month later...
  • 3 months later...

edit2: FIXED Bit more searching and i found i had to add the vendor/product id to the kext. Works fine now! yay! :(


So, cant get my belkin USB wifi to work. Chipset is RTL8187B.


Tried the following drivers, 87_Mac10.4_v1309, 87B_Mac10.4_v1117, RRTL8187B_MacOS10.4_1088. Non of which work :)




Aspire 3610 Laptop

Intel Celeron M - SSE2 Only

Intel GMA900 - working fine

Sound - dunno wat it is, working fine though

USB Ports - all working

No SATA - All IDE as its a fairly old laptop


There dosnt seem to be a problem installing the drivers. All of the driver packages i've tried install with no errors, problem is none of them seem to want to fire-up either the USB stick or the 'Realtek WLAN' app, so there isnt a new device in Network preferences or anything. Even after multiple install/reinstalls of the driver, the app still hangs and i have to force quit. The usb device still shows up in System Profiler though, so i guess its 'there'.


Tried iATKOS r3 and Uphuck 10.4.9i and no luck with either. Downloading Jas 10.4 at the mo to see if that will help.


Any ideas?





Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

Hi! I installed the realtek 8187 wifi on kalyway 10.5.2. Now it recognize the usb adaptor and I can connect to the wireless network. But still havent got internet on safari! What do I have to do now?


intel dual2core 2.66

asus p5k-e wifi ap

ati radeon hd 3600 series

Link to comment
Share on other sites

  • 6 months later...

  • Create New...