Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Shaj

Network Connection Drop & 'Self Assigned ip' Problem...Please Help :(

212 posts in this topic

Recommended Posts

I have new unusual symptoms :)

 

My mouse started behaving quite strange moment my lan drops, it first starts moving too fast and then super fast and reverse :blink::blink:

 

I'm starting to delete kext I don't think are necesary one after another to see if it helps...

Share this post


Link to post
Share on other sites

i have a broadcom 440x ethernet and found 100% working solution. No kext problems, if your machine up to 2gb ram, internet randomly droped, but 1gb ram, no drop, fast and stability. Everyone try this "maxmem=1024" boot param. and please write comments. what couse this problem ?

Share this post


Link to post
Share on other sites

I just realize that many of my networks drops are related to itunes. (When itunes is running drops are more frequent).

 

Anyone reach any solution?

 

M

Share this post


Link to post
Share on other sites

might try backing up & deleting the AppleHPET.kext from the System/Library/Extensions folder. That driver drove me and my network crazy for a few days.

 

Khan

Share this post


Link to post
Share on other sites
My solution was:

 

3. net.link.ether.inet.apple_hwchksum_rx and�net.link.ether.inet.apple_hwchksum_rx set to 0 (Disabling Apple Hardware SUM16 checksuming)

 

This definitely worked for me. Right now I have a RT8169 Gigabit PCI/PCI-X card and that stopped the drops for me. Tested transferring multiple 4+Gb files in the last hour. Funny, but chipset had nothing to do with it. I tried several different cards, broadcom, realtek, nforce and they all dropped. The only fix seemed to be cpus=1 (which disabled dual core).

 

I tried everything, cpu settings, different kexts, bios settings, etc., but this actually worked.

As a side note, you don't have to pay for some app to change the network settings, just open Terminal.app

and

 

sudo su
"Enter Password"
echo net.link.ether.inet.apple_hwcksum_rx=0 >> /etc/sysctl.conf 
echo net.link.ether.inet.apple_hwcksum_tx=0 >> /etc/sysctl.conf

After you reboot, you can verify the changes took effect with

sysctl -A net.link | grep net.link.ether.inet.apple_hwcksum
Both values should return 0

 

 

Thanks,

oceanplexian

Share this post


Link to post
Share on other sites

Just another idea.

 

I had this problem also. I could boot into OsX (tripple boot system) and have "self assigned IP". If I booted into Windows XP, I would have a "self assigned IP", but if I booted into ubuntu, no network problems at all. At first, I thought my onboard nic was dieing, but since I had perfect network in linux, this could not be the case.

 

The weirdest part about it all was that I had another PC on my network that had no problems with network at all, even if I swapped ethernet ports where the PC's connected to the router. This ruled out my routers.

 

After a {censored} ton of g-o-o-g-l-i-n-g, I found out that the cause of this elusive problem was simple. My computers, routers, xboxes (on my network), and monitors were all plugged into wall outlets that were NOT grounded and the "noise" caused my network issues. So, I ran a 3-prong extension cord from a grounded outlet in another room to a power strip in my computer room and then plugged in all 3-prong devices (computer towers and monitors) to this strip. I have not had network issues since.

Share this post


Link to post
Share on other sites

Well, unfortunately after long term testing I started to see drops again. At least infrequently (several hours) so it's not too bad.

We really need a solution to this, and by that I don't mean buying a USB dongle.

 

The outlet I'm working off isn't grounded, so I'll check back after testing with an extension cord.

 

So far, I imagine it has to do with Ethernet hardware/software check-summing. For some reason the

hardware checksum screws up (electrical noise??) and the network stack crashes. I though I disabled this, but I guess not completely.

 

New drivers don't solve the problem, I've used several cards and different driver types, it's definitely a nForce mobo/pci bus issue here.

Share this post


Link to post
Share on other sites

In the end I connected a usb ethernet to my mobo and disabled all other ethernet onboard/external cards. No problems whatsoever now with downloads and losing ip adress.

Vontrapp

Share this post


Link to post
Share on other sites
Hey Sun.

 

I tried your above method, but the network still didn't come back on. It showed 'connected' but couldn't browse internet or network.

 

 

 

Here is another funny thing though...

 

In the past few days, I've had two days when the connection was PERFECT! No drop outs at all.

 

But on BOTH these days, iChat, during conversation, had lots of static noise! After a restart the static went away but the connection dropped within minutes...

 

I just can't seem 2 understand what all this is related to...

 

I had a similar problem with Snow Leopard I have a Temporary fix don't know if it works for tiger or regular leopard. Or if it depends on your ISP.

 

Please post anything better you find in that topic.

Share this post


Link to post
Share on other sites

Another "me too" with this problem. I have a p5n32-e sli plus mobo and I couldn't get the nforce ethernet/lan drivers that came with iATKOS v7 to work. The OS would see the two network card, but it wouldn't get the connection etc. I think the icon stayed red/orange in the network panel. Anyway, I bought a Netgear GA311 (rtl8169 I think; just realized I didn't read the actual card... only read the pic of it on the box when I was at Frys). This card was detected automatically, but when I'm trying to download a 3gig file via safari/firefox, connection just stops working. Trying to renew the IP gives me a self assigned ip.. (169.254.x.x). Static ip doesn't work. I went through the permutations of 10/100/1000mbps + half/full duplex and diff ports on the switch etc., and tried to kextunload/load the driver but without success. after all that, i looked at the card and I see that all the lights are off.

 

Oh aside from the 3gig file, I was able to download firefox as well as update os to 10.5.8 + all the other updates without a problem. But the other stuff only was half a gig to a gig max.

 

Anyway, reading through the thread, its not a problem with NICs. some here are using 680i chipset mobos. Probably not chipset specific, but for those that have this issue, it persists on different NICs.

 

Hmm, I have Gigabyte EP43-UD3L that I just bought in case I had issues with this old p5n32-e sliplus. Unless someone has a working fix, or suggestions, I'll probably be replacing the mobo later on today.

Hopefully the gigabyte mobo works better.

Share this post


Link to post
Share on other sites

I'm having the same prob but changing mobo doesn't seem like a solution to me. I have dualboot and under windows my lan works fine

 

I figure it has something to do with some cache which is emtied upon reboot? Anyone an idea what cache this could be? Or any other buffering thingy...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Few more minutes to go before going live again with https://OSXLatitude.com
          So you can lock this topic again @Allan Hopefully for a bit longer than a couple of weeks this time hehe.
    • ok, I am having a weird glitch with my Primary bios after modding it myself. can I get some help getting a Clean osmosis modded (for High Sierra and beyond) Bios Image?   https://www.gigabyte.com/us/Motherboard/GA-Z87X-UD5-TH-rev-1x#support-dl   the version I have always stuck with was F4, because the F5d.  I use a custom iMac 14,2 configuration that has been stable, the issues I have with stability come from not being able to get Access to the Bios, and prior to my attempt to mod it has been stable with up to High Sierra using clover, and up to Sierra with my very very old Ozmosis 894m F4 rom. I am not opposed to installing Ozmosis on the EFI Partition, But Gigabyte locked the Bios loading .efi Files, there is no shell to Force it to load HFS+ or APFS drivers.   so what I am asking for is assistance ether unlocking a Shell for my Bios, or getting a bios with the APFS, HFS+, and Ozmosis related files in it.   thanks again for everyones assistance. HBP
    •     Install from fresh again. This time without Tony Tools, follow some guide in this topic. Install IntelHD kexts as usual in S/L/E and thats it. Everything works again, except for backlight, I never could have this work, also got heating problem and when boots apple logo dissapears from like 5 seconds and then appear the login window... Any ideas on any of this????  
    • MAld0n, I can't post a new topic on post installation forum. is it on maintenance?
      Notebook Asus X550VX i7 - 7700hq
      GTX950MX - UHD630
      A1718086 - 025510ec ALC255 that works only on VoodooHDA 
      RTL8111 LAN Hwinfo
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL   Not work:
      1. White Screen Wake up
      EDID not a asolution
      IOREG output http://www.mediafire.com/file/u7odzbaxa7bbb6a/ioregSaved.txt and EDID
      http://www.mediafire.com/file/hqlapgf4luwchdf/DisplayProductID-69c.plist Image
      https://ibb.co/faL5wx 2. Battery info status bar sometimes goes on / off like battery has off
      3. Crackle Sound using   earphone using VoodooHDA
             Still investigation using patched iomatch voodooha info.plist
             The sound card can’t be using AppleALC, no sound came out using layout 3, 13, 17, 18, 27, 28, 99
      I have your (Mald0n) DSDT   http://www.mediafire.com/file/lmp5yy65rblx9ne/DSDTtitomaldon2.dsl   I have re-patched again for FnKeys and Brighness Key http://www.mediafire.com/file/5rs93ij0wco99s6/DSDTtitomaldon2editv2.aml

       
      codec dump linux
      https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view
       
       
      latest debug
      http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip
       
      clover and kext
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL
       
    • somehow I can't post a topic using safari and Firefox on Mac. no box for inserting text, is this kind of maintenance?  


×