Jump to content

Bonjour not working


21 posts in this topic

Recommended Posts

I've installed toh (and then put it back to vanilla with pc_efi).


My networking works perfectly fine. However, Bonjour seems to be not working. I can't connect to any bonjour services (a printer I have and an itunes share). These both appear instantly on my macbook pro.


Could this be a network driver issue? Some other problem? I've got a Gigabyte GA-P35C-DS3R (with a Realtek 8111b network chipset)


Any help would be greatly appreciated as I'd like to access my music library on my WHS (which I can do from my macbook pro using firefly)





I have discovered the following two things:


1) Other computers (my macbook) CAN see the music shared ON my OSx86 box. So it's broadcasting, just not picking others up for some reason


2) Using Bonjour Browser, it's clear that my osx86 box is not seeing these services. However, and this seems pretty random, I can get it to see them (in BB) just for a handful of seconds, if I go into networking, turn off IPv6 and hit apply. That seems bizzare and completely unrelated to anything (as I have no ipv6 anything configured), and doesn't last long enough for itunes to see anything (or add any printers), but something is going on.

Link to comment
Share on other sites

Which driver do you use? I had the same issue not beeing able to "see" my mDNS stuff in the LAN, but solved it by swapping drivers (I have the GA-P35-DS3, pretty similar to your board). The "original" driver from realtek is the faulty one (at least was't working in my setup).


The driver from http://sourceforge.net/projects/realtekr1000/ works for me.





Link to comment
Share on other sites

Here is something I found ...


- Like mtrr said, it seems like there is some incompatibility between AppleRTL8169Ethernet.kext & Leopard. Replacing it with a newer version (from www.realtek.com.tw) won't help. AFP share points will pop in and out... but normally disappearing. You can work around this by using Finder->Go->Connect to Server and put something likes afp://192.168.xx.xx to get it connected.


- If you use this AppleRTL8169Ethernet driver in Tiger, it will runs perfect ! There will be no problem with both AFP and SMB.


- Swapping in DaemonES's excellent RealtekR1000 in sourceforge will solve this. It will run perfectly fine on both Tiger and Leopard.... but with some catches. Minor cosmetic problem is that it will not update the Tx/Rx counter in Network Utility. But the big thing is... it won't work across *sleep* and cable disconnect. The driver will just stop working and you have to reboot to regain network connection should that happens.


So, I'm using it and ... well... trying to read a lot of docs so I can add the power management section in. It will be hard for me but I hope I can finish it sometime & will post it here....


Or hopefully, Apple will patch this real sooner than me. :)

Link to comment
Share on other sites

Thanks to both of you for your incredibly informative posts :o


That's great to hear that the driver works, sucks that it has the sleep issue, as I was hoping to let the computer go to sleep (though I used to leave my vista box on all the time for remoting purposes).


I wish you a lot of success in fixing the power management stuff Alwayon. Albeit for completely selfish reasons. Seems so close.


In case I decide I want to do this anyways, how exactly do I go about swapping the driver? Does it have an installer?

Link to comment
Share on other sites

the sleep problem was driving me nuts as well, but you can just unload the kext and then reload it and the connectivity is restored (works for me, YMMV).


for me the last problem that needs to be resolved: shutdown/reboot



Link to comment
Share on other sites

Yes, the RealtekR1000 kext has installation package and uninstall script.

In my case, just install it and it will override the default AppleRTL8169Ethernet which is in IONetworkingFamily.kext.

I believe it will do the same for you.

In case you are wondering whether the R1000 is working or not, open "Network Utility" in Application/Utilities and

take a look at the last line, "Model : xxxx". If it is "Model : RTL8168B/8111B" and your Tx / Rx stats on the right

is completely dead ... while you are able to see share points or surfing the net, then you got it right :thumbsdown_anim:


Thanks for the tips, mtrr. I never happened to think that I can manually unload the kext as a workaround. This is

really great tips !!!


The shutdown/restart problem is the only one that's bugging me real bad too. At least I know I can do something

about this networking driver in a few days (or a week ??), but for this shutdown/restart, I am completely blind.

There is some guessing around that it has something to do with AppleACPIPlatform.kext, which source code is sadly...

not disclosed by Apple. I hope some genius around here will finally find a way to solve this.


For now, I am trying to fool myself that I am using a really great Unix minicomputer from my very old day in university.

The one that requires you to manually sync the disks, then issue a "halt" command to shut the system down.

And even the system is halted, the power will still be on.... completely by design.

It needs you to walk across the room and hit the switch yourselves. ... ha...ha..ha.. at least this makes me feel much better :thumbsdown_anim:


PS. A member named "Royston Koh" claims that he has already solved his shutdown/restart problem in




I don't know how he did it, still no answer though.

Link to comment
Share on other sites

Regarding DaemonES's driver and waking from sleep (and possibly cable disconnect) the fix is to set a static ip.

The problem is that dhcp does not renew its IP on wake from sleep.

I realize that some people don't have a choice and require dhcp for their isp's but for those that can run static, this works.



Link to comment
Share on other sites

Allright, so I decided to go for it and installed the RealtekR1000 driver.


I've rebooted, and thankfully still have network access:)


However, I'm sorry to report that not only did this fail to fix the bonjour issue, computers no longer even show up in the "shared" section in finder. I can connect to them with "connect to server", but they don't appear by default.


Guess I'm going to have to switch back. This really sucks as I was very excited about getting itunes to read my music library stored on my WHS.

Link to comment
Share on other sites

  • 1 month later...

I was having the same problem, with the same motherboard as TheDude42. The sourceforge driver solved it for me.


The installer did not work for me though, it gave me an error after rebooting, saying the extension could not be used. I then installed the .kext file "manually" using kext helper (included in the Kalyway installation) and that did the trick.


Too bad about the DHCP/sleep issue, but using a static IP is not a big problem for me.


Now that this issue is fixed absolutely everything works for me (sleep/restart/shutdown worked from the start). :)


TheDude42, are you sure the sourceforge driver is being loaded correctly? You can check in the way that Alwayon described. I doubt this can't work for you too, since we have the exact same motherboard.

Link to comment
Share on other sites



Well, had exactly the same issues with Bonjour/iTunes not recognizing my daap share (mt-daapd on my Linux VDR) on a hackintosh (a8n sli deluxe with marvell yukon NIC's), Bonjour services in my LAN simply refused to show up in bonjour browser. Neither on 10.4.11 nor on 10.5.1 they did.


However, i got around this by running apples bonjour conformance test tool which can be downloaded on the bonjour developers site (http://developer.apple.com/networking/bonjour/ConformanceTest-1_2_3.zip) with the suggested command in the readme:


./BonjourConformanceTest -I en0 -L p -M hu


after scanning, suddenly the services i wanted to connect showed up in BB... and after upgrading iTunes to 7.6 even there. Music sharing works fine within one session, now i just need to learn how to tell mt-daapd to serve my precious ogg's so that iTunes eats them... .


However, i'd really like to know whats exactly the problem.. and how to get rid of it/ enabling the share discovery via ethernet by default.





P.S.: @westwaerts: thats good info, i was thinking about setting up a cups server on my dads Linux box (nice and fast HP printer there :)) to use with my system.

Link to comment
Share on other sites

  • 2 weeks later...

For what it's worth, I just built a p35c-ds3r hacky with a dual-boot drive from a prior hacky. My internet works fine with both boot partitions, including Bonjour networking.


My Leo install is Kalyway 10.5.1


My Tiger install is Uphuck 10.4.9


The only kext I added to my old setup was nvinject 2.1 to support my nVidia 7300gs card (256mb vram)


The only thing I had to add for the new setup was AppleHDA


The only problems with my system seem to be the documented not-shutting-down problem (I'm running a Q6600, and, apparently, the last 2 cores don't shut down properly with my kernel), and the fact that I can't get a single MacOS install DVD to boot on my SATA DVD drive (Pioneer D212). Other than that, it seems fine. I only built the thing yesterday, and when I have it all sorted out, I'll blog the experience with links to proper info..


What is the name of the kext that is driving my internet on a stock Kalyway install? I'll get you folks the version number of the driver. I just have no idea what driver(s) I am looking for.


EDIT: NEVERMIND ALL THAT. Right after I initially made this post, Bonjour failed to show the Share Screen... button in my finder windows. In fact, Screen Sharing just would not run at all. I snagged the RealtekR1000.kext from my Tiger installation on another partition on the same hard drive, dropped it on Kext Helper, and had to restart, but now, Screen Sharing works just fine. I didn't remove anything; I only added the RealtekR1000.kext by Daemones (the one packaged by Neophus). Now, everything seems to be working properly. Thanks, All!

Link to comment
Share on other sites

  • 2 weeks later...

Hi everyone.


I seem to be having the same issue but have already tried most of those fixes...last one being found here:




For me, after I reboot... Bonjour works fine but after a few hours or if my DSL goes out for a few moments, Bonjour stops working properly and my logs begin to fill with errors as my computer tries to communicate with dot mac (back to my mac):




2/15/08 10:08:18 AM mDNSResponder[15] Permission denied (NOAUTH): HEATER._afpovertcp._tcp.DREZORATOR.members.mac.com.

2/15/08 10:08:18 AM mDNSResponder[15] Error -65537 for refresh of service HEATER._afpovertcp._tcp. DREZORATOR.members.mac.com.

2/15/08 10:08:58 AM mDNSResponder[15] Permission denied (NOAUTH): HEATER. DREZORATOR.members.mac.com.

2/15/08 10:08:58 AM mDNSResponder[15] hndlRecordUpdateReply: Registration of record HEATER. DREZORATOR.members.mac.com. type 28 failed with error -65537

2/15/08 10:09:04 AM mDNSResponder[15] Permission denied (NOAUTH): _kerberos. HEATER. DREZORATOR.members.mac.com.

2/15/08 10:09:04 AM mDNSResponder[15] hndlRecordUpdateReply: Registration of record _kerberos.HEAT. DREZORATOR.members.mac.com. type 16 failed with error -65537

2/15/08 10:11:27 AM mDNSResponder[15] sendChallengeResponse: 3 failed attempts for LLQ _adisk._tcp. DREZORATOR.members.mac.com.

2/15/08 10:11:27 AM mDNSResponder[15] sendChallengeResponse: 3 failed attempts for LLQ _odisk._tcp. DREZORATOR.members.mac.com.

2/15/08 10:11:33 AM mDNSResponder[15] ERROR: socket closed prematurely tcpInfo->nread = 0


Any suggestions as to why this is happening? I feel like its really an issue with the chipset itself and the kext files.


I wish there was a solution or work around to this.


Any feedback or help would be appreciated


thank you

Link to comment
Share on other sites

  • 1 month later...

My problem was sometimes my printer/iTunes share/AirTunes/other servers would appear just fine but after awhile they would disappear with no way to get them back other than rebooting, and even then that sometimes would not work. Occasionally shares would reappear but it was very random. And annoying. I'm on a Thinkpad T60p using the default 10.5.2 Atheros driver (after adding my device and vendor id). Then I read this:




I restarted Bonjour and *POOF* my shares appeared, and restarting iTunes all of its stuff appeared. Wee! Here are the exact commands to restart Bonjour:


sudo launchctl unload /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

sudo launchctl load /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist


Being that I just got an Airport Express which is very dependent on Bonjour, I found this at just the right time. Good luck!

Link to comment
Share on other sites

  • 1 month later...

Um, wow, this link appears to have done it for me! THANK YOU PEOPLE!


Sourceforge RealtekR1000


It brought my Bonjour back for iChat, iTunes...I was just trying to fix THAT problem but this also fixed the sharing between my machines which I had given up on several times last week. Holy moly.


Christmas come early.


I slept my computer and it gets back online no problem. I use a little menu bar application called "Menu Meters" to monitor my network speeds/throughput (and how hard my processors are working) and it's happily saying I'm connected at 1000Mbps. YES!


Someone had posted some Bonjour issues to an Apple Discussion board that sounded purely Appellian in nature so I think that some peoples' problem may be non-hackintosh related but 10.5.2 or .5.3 related. (the bonjour unload/load trick was one kludge those people were using).


I'm using Kaly, I can shutdown but I can't restart :) And I can either have microphone but unadjustable volumes or volume control but no microphone. So I'm feeling good!


Loving my tosh, loving this forum!


thank you!




Link to comment
Share on other sites

Hi, after doing a search on this topic I stumbled upon this thread. Just wanted to let you know, that I lost network conectivity after sleep and was looking for a solution. My install was kalyway 10.5.2, where I chose to do the RealtekR1000 kext install too.

Interesting: it was installed into the IONetworkingFamily.kext package, so was hard to detect.

Also the above hint on network utility made it clear that RealtekR1000 was active. So far no surprise, that network conectivity was dead after wake up from sleep.

But then I manually removed (to trash) the RealtekR1000 kext, and now conectivity works after wakeup !

Didnt check with bonjour though.


Also would be interested to know if there came any improvemants with the 10.5.3 update.

Link to comment
Share on other sites

ok got it running now without RealtekR1000:

just using the plain Kalway 10.5.2 Install no additional network drivers.


1) Network - options - IPv6 OFF

2) Adress network machines by their Network IP adress, in my case eg:


Now I got:

+ Wakeup after sleep, network working

+ AND afp working. Network volumes quit correctly.

+ Network Utility showing the right figures


Uff, thannks to this thread !

Link to comment
Share on other sites


  • Create New...