Jump to content
Schweppes

Problema en Leopard con Pendrive ?!?

30 posts in this topic

Recommended Posts

Alguien ha tenido el mismo problema que yo ???

 

En Tiger no tenia problemas con mi pendrive SanDisk de 2 gigas, en cambio en Leopard no lo monta en el Desktop, ni en Disk Utility....aunque si aparece conectado en System Profiler !!!

 

Si alguien tiene algun problema parecido o sabe como solucionarlo se los agradeceria !!!!

Share this post


Link to post
Share on other sites
Advertisement

¿No lo monta o no lo muestra en el "Desktop" ?

 

insértalo, ve a terminal y teclea "mount", si está montado y no lo muestra ve las prefercias del Finder con Command , (ALT , en ecaldo de PC) ahí puedes seleccionar que dispositivos o volumentes quieres ver en el "Desktop".

Share this post


Link to post
Share on other sites

No lo monta.

 

Esas opciones ya las tengo bien configuradas.

 

Solo tengo que teclear "mount" en terminal ??? no tengo que especificar nada mas?

Share this post


Link to post
Share on other sites

mount sin nada más muestra los volúmenes montados.

 

si quieres forzar que lo monte crea un folder en el Desktop y le dices en terminal:

 

mount_msdos /dev/diskXsY /Users/Desktop/folder

 

si lo monta cuando abras folder vas a ver lo que tenga el pen-drive.

 

mount_msdos es si está formateado para windows pero puede que este en NTFS y tendrías que usar mount_ntfs, mount_hfs si esta formateado con Mac OS Extended.

Share this post


Link to post
Share on other sites

Gracias por el dato Macgirl, aunque en realidad me gustaria saber si es un problema del Leopard en general o de Leopard en Hackintosh, ya que actualice a 10.5.1 y el problema no se soluciono.

 

Si a alguien mas le pasa esto que postee asi encontramos la solucion entre todos.

 

GRACIAS!

Share this post


Link to post
Share on other sites

No habá algun update de usb para leopard yo recuerdo que para tiger se ocupada un update pero no muchos lo necesitaban

Share this post


Link to post
Share on other sites

Que yo sepa no es problema de Leopars, no he leído nada al respecto, pero podrías probar los kexts de Tiger para USB a ver si con eso se soluciona.

 

Yo en 3 hacks que he ppuesto Leopard el USB ha funcionado bien, las 3 instalaciones son incluso en computadoras diferentes.

Share this post


Link to post
Share on other sites

Macgirl, lo raro es que tengo cosas USB que funcionan perfecto: Audio C-Media Headphone Set, Wacom Graphire 3 por ejemplo.

 

Lo unico que no funciono es el Pendrive... :P

 

Tal vez pruebe lo que tu dices del kext USB de Tiger a ver que pasa.

 

Gracias!

Share this post


Link to post
Share on other sites

Bien pues me uno al problema actualice a leopard 10.5.1 y ya no me aparecen hd externos es más ni siquiera el ipod me aparece intente instalar un driver genérico usb pero no funciona alguien mas a parte de Schweppes y yo han tenido ese problema??

Cabe mencionar que antes de actualizar si funcionaba el HD sin problema esta formateado en fat32 y en el arbol de dispositivos usb si aparece tengo un dispositivo ipod y otro usb to ide

 

Que podrá pasar? hay alguien más que haya instalado 10.5.1 y tiene estos problemas??

Share this post


Link to post
Share on other sites

Macgirl, probe de usar los kext de Tiger en Leopard pero no cambio nada, sigue sin funcionar.

 

Los 2 kext que use de Tiger son:

 

IOUSBFamily.kext y IOUSBMassStorageClass.kext

 

Por lo visto no soy el unico con este problema.

Mi configuracion siempre fue muy compatible con OSx86, he instalado todas las versiones de OS X y nunca he tenido problemas.

 

QUE PODRA SER ????

Share this post


Link to post
Share on other sites

No he encontrado una solución para este problema, pero probando salio lo siguiente:

 

Cuando te aparezca el bootloader de Darwin (si usas este) conecta tu pendrive y entra normalmente a leopard vas a ver que cuando cargue lo vas a ver en el escritorio, de esta manera puedes utilizarla mientras encontramos una solución razonable, ahora supongo que los otros dispositivos USB que tienes estan funcionando porque no los desconectas, intenta desconectandolos, inicia leopard y cuando cargue el escritorio conectalos para ver si mi teoria es correcta ya que supongo no van a funcionar

Yo lo estoy usando así pero el problema es con el ipod ya que lo conecto, lo monta, aparece en el escritorio pero itunes me dice que ha detectado un ipod pero no ha podido ser identificado correctamente . Desconecte y vuelva a conectar el ipod e intentelo de nuevo

Share this post


Link to post
Share on other sites

Heatz !!!

 

Tienes razon!, si inicio Leopard con el pendrive ya conectado si lo monta!

 

Tal vez esto sirve de pista para buscar una solucion, nada mejor para arreglar algo que tener bien identificados los sintomas...

Share this post


Link to post
Share on other sites

Os comento... ha ido bien siempre, pero hace unos dias que no me detecta los usbs... en ningun puerto.. me pasa lo mismo que a sweppes y heatz, sí sale en el profiler pero no en el finder, he probado montarlo y nada...

 

Asi que uno mas que se une.. lo extraño es que siempre ha ido bien..

 

por cierto... estais seguros que la actualizacion del kernel es la 10.5.1??? os explico.. jejeje

 

instale ToH leopard... y al actualizar unos kext iba genial, pero al actualizar a 10.5.1 la cosa no iba tan bien y tenia mas cuelgues al iniciar el modo grafico... asi que copie el mach_kernel y coloque la version 10.5.0 de un backup.. y ya me iba mejor...

 

tal vez sea eso.. que al actualizar el leopard con la 1051 y dejar el kernel 1050 con los kext actualizados no vayan..

 

Estos son mis mach_kernels.. mirad a ver si coinciden los tamaños no vaya a ser que tengais lo mismo que yo

9800 -rw-r--r--@ 1 root admin 5017352 9 dic 03:18 /mach_kernel (kernel 1050 parcheado para sse2)

9800 -rw-r--r--@ 1 root wheel 5017352 17 nov 20:16 /mach_kernel.1050 (idem que anterior)

9808 -rw-r--r-- 1 root wheel 5021448 17 nov 21:59 /mach_kernel.1051 (version kernel 1051 parcheada)

20896 -rw-r--r--@ 1 root wheel 10696809 10 oct 06:38 /mach_kernel.ctfsys (ni idea)

20032 -rw-r--r--@ 1 root wheel 10256044 18 nov 00:20 /mach_kernel.orig.1051 (version kernel 1051 original sin parchear)

 

otra cosa.. mi pendrive usb wifi no lo detecta... asi que problemas con el kext de usbs????

Share this post


Link to post
Share on other sites

La verdad que detecte el problema de los USB despues de haber instalado la actualizacion 10.5.1, porque antes no habia usado el pendrive con la instalacion fresca de la version 10.5 de ToH.

 

Aibarz, probaste todos los kernels tanto el de la version 10.5 como los de la version 10.5.1 y el problema sigue igual?

Share this post


Link to post
Share on other sites

Airbarz !!! gracias!!! me diste la pista justa para encontrar la solucion!

 

Resulta que tenia actualizado el Leopard a 10.5.1, pero mantenia el kernel original del DVD de ToH que es 9.0.0....me baje el kernel 9.1.0 de ToH y ahora el problema se soluciono!

 

Pienso que puede haber sido porque estaba usando el kernel 9.0.0 y el System.kext de la actualizacion 10.5.1...pero no lo se, solo es una suposicion.

 

MUCHAS GRACIAS !!!!!

Share this post


Link to post
Share on other sites

Muchas veces cuando el system.kext no coincide con la versión del kernel no monta la imágenes DMG, quiza pase algo similar con los pendrive.

Share this post


Link to post
Share on other sites

pues seré yo el obtuso que se coloco el kernel de la 1050 en un sistema actualizado a 1051 jajajaja

 

pero bueno ya esta claro que la culpa la tiene la diferencia del kernel con los kext... si no son los mismos no van (ya me vale xD)

Share this post


Link to post
Share on other sites

Hola, tengo el mismo problema, yo instale Leopard 10.5.0 con el DVD de BrazilMAC, luego instale EFI y actualice a la versión 10.5.1, como puedo saber la versión del kernel que tengo instalado?

 

Gracias

 

Saludos

Share this post


Link to post
Share on other sites

La última vez que tuve problemas con los USB descargue los controladores del sitio de desarroladores de Apple.

Aunque tenía problemas con system.kext, los controladores USB arreglaron el problema.

Share this post


Link to post
Share on other sites

Gracias macgirl, tengo instalada esta versión Darwin Kernel Version 9.0.0, de donde puedo bajar la versión kernel 9.1.0 y como hago para instalarla?

 

Gracias por la ayuda

 

 

Saludos

Share this post


Link to post
Share on other sites

Muchas gracias, yo tb tengo el mismo problema, a ver como hago para descargarme el mach_kernel de la 10.5.1, porque esto de arrancar con el USB pinchado cada vez es un latazo.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×