Jump to content

Help fix DVDPlayer App


timewise
 Share

9 posts in this topic

Recommended Posts

Hey everybody,

 

I can't get DVDPlayer, iCal or about this mac to work :D . I did fix system profiler by replacing the spplatformreporter.sreporter here http://forum.osx86scene.com/viewtopic.php?f=16&t=2240

I've also tried different applesmbios.kext and to no avail. I used the leopard flat image and replaced the kernel w/ sse2. I did a restore from tiger on a 120GB partition and went smoothly. Repaired permissions and everything except above mentioned works. When I start messing w/ the kext files I lose networking unless I boot w/ -f. I don't know what else to do. Is there any new kernels or applesmbios for sse2.

 

Thanks

Link to comment
Share on other sites

Hey everybody,

 

I can't get DVDPlayer, iCal or about this mac to work :( . I did fix system profiler by replacing the spplatformreporter.sreporter here http://forum.osx86scene.com/viewtopic.php?f=16&t=2240

I've also tried different applesmbios.kext and to no avail. I used the leopard flat image and replaced the kernel w/ sse2. I did a restore from tiger on a 120GB partition and went smoothly. Repaired permissions and everything except above mentioned works. When I start messing w/ the kext files I lose networking unless I boot w/ -f. I don't know what else to do. Is there any new kernels or applesmbios for sse2.

 

Thanks

 

Try this -> http://forum.insanelymac.com/index.php?showtopic=70155

Link to comment
Share on other sites

 

Thanks for responding ppg

 

I did try that and I was able to launch DVDPlayer and the DVD would start to play and then quit. It also gave me a report whereas before it would just crash.

 

How can I get a different applesmbios to try Or maybe I could edit v1.0.11 to work.

 

Specs from Windows system information tool

 

OS Name Microsoft Windows XP Professional

Version 5.1.2600 Service Pack 2 Build 2600

OS Manufacturer Microsoft Corporation

System Name DELL

System Manufacturer Dell Computer Corporation

System Model Dimension 8250

System Type X86-based PC

Processor x86 Family 15 Model 2 Stepping 7 GenuineIntel ~2386 Mhz

BIOS Version/Date Dell Computer Corporation A04, 1/9/2004

SMBIOS Version 2.3

Windows Directory C:\WINDOWS

System Directory C:\WINDOWS\system32

Boot Device \Device\HarddiskVolume2

Locale United States

Hardware Abstraction Layer Version = "5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)"

User Name DELL\//////

Time Zone Pacific Standard Time

Total Physical Memory 1,024.00 MB

Available Physical Memory 631.62 MB

Total Virtual Memory 2.00 GB

Available Virtual Memory 1.96 GB

Page File Space 2.40 GB

Page File C:\pagefile.sys

 

Thanks for your help.

Link to comment
Share on other sites

Also when I try to manually load v1.0.11 I get this error

 

extension /Volumes/Leopard/System/Library/Extensions/AppleSMBIOS.kext has potential problems:

Warnings

{

"Kext has a kernel dependency prior to version 6.0 and CFBundleVersion does not match executable's MODULE_VERSION" = true

}

 

kextload: extension /Volumes/Leopard/System/Library/Extensions/AppleSMBIOS.kext appears to be loadable

kextload: extension /Volumes/Leopard/System/Library/Extensions/AppleSMBIOS.kext is already loaded

 

I am running Leopard Flat Image version and I did not replace dsmos like suggested here http://forum.insanelymac.com/index.php?sho...077&hl=sse2

In tiger I did not see this kext and wonder if it is necessary. I deleted it from Leopard once and it did not seem to affect anything.Any more suggestions would be helpful.

 

Update: Replaced dsmos.kext and did not fix :) .

Link to comment
Share on other sites

Also when I try to manually load v1.0.11 I get this error

 

extension /Volumes/Leopard/System/Library/Extensions/AppleSMBIOS.kext has potential problems:

Warnings

{

"Kext has a kernel dependency prior to version 6.0 and CFBundleVersion does not match executable's MODULE_VERSION" = true

}

 

kextload: extension /Volumes/Leopard/System/Library/Extensions/AppleSMBIOS.kext appears to be loadable

kextload: extension /Volumes/Leopard/System/Library/Extensions/AppleSMBIOS.kext is already loaded

 

I am running Leopard Flat Image version and I did not replace dsmos like suggested here http://forum.insanelymac.com/index.php?sho...077&hl=sse2

In tiger I did not see this kext and wonder if it is necessary. I deleted it from Leopard once and it did not seem to affect anything.Any more suggestions would be helpful.

 

Update: Replaced dsmos.kext and did not fix :D .

 

Mine is BrazilMac's Leopard. I did not see the problem you mentioned. Sorry.

You can check these pics out. -> http://picasaweb.google.com/j3ss31963/MacOSXLeopard

Link to comment
Share on other sites

  • 2 months later...

I am having a similar issue.

 

DVDPlayer will work on DVD's, but when I open a VIDEO_TS file I get

 

2/2/08 11:27:26 PM [0x0-0x2d02d0].com.apple.DVDPlayer[5085] error: Error getting a reference to /options.

2/2/08 11:27:26 PM com.apple.launchd[121] ([0x0-0x2d02d0].com.apple.DVDPlayer[5085]) Exited with exit code: 1

 

I have not tried the applesmbios.kext changes yet.

Link to comment
Share on other sites

I am having a similar issue.

 

DVDPlayer will work on DVD's, but when I open a VIDEO_TS file I get

 

2/2/08 11:27:26 PM [0x0-0x2d02d0].com.apple.DVDPlayer[5085] error: Error getting a reference to /options.

2/2/08 11:27:26 PM com.apple.launchd[121] ([0x0-0x2d02d0].com.apple.DVDPlayer[5085]) Exited with exit code: 1

 

I have not tried the applesmbios.kext changes yet.

 

I had problems with DVDPlayer under Tiger and I found a sse2 kernel that allowed it to work properly.

My guess is it is related to sse2 kernels in Leopard.

Install Tiger and see if it works.

Link to comment
Share on other sites

  • 7 months later...

I am having a similar issue. I built a hackintosh on a bad axe 2 mobo that worked perfectly, but on my new build DVD's will play if they're in the drive, but Video_TS folders are a no go. They work in VLC but not DVD player or front row. Very frustrating! Did you ever find a fix?

 

Kalyway 10.5.2 updated to 10.5.5 (sleepkernel/vanillakernel)

Intel DG31 Mobo

2 Gig G-Skill DDR2 800 RAM

LG DVD Burner

Zotac 8800GT Video Card

WD Caviar 640 Gig HDD

Intel Core 2 2.5 Ghz

Link to comment
Share on other sites

 Share

×
×
  • Create New...