Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
enb14

Users with GMA 950 / X3100 Real Macs needed here

686 posts in this topic

Recommended Posts

Hello everyone,

Just to let you know, I have tried adding in my edid information through the Natit driver, but it kept causing kernel panics.

I didn't pursue it much further since shortly afterwards I made the breakthrough that got me proper display without the edid information. For the record, the old Tiger framebuffer gets the edid information for us and populates it in ioreg so its easy to get, but it wasn't too easy to put it back. ;)

I'll see if I can look at that again. I'm feeling a touch of a cold so I'm not working on anything tonight.

 

Paulicat

Share this post


Link to post
Share on other sites

Thanks for the hard work!

 

The glitching on my system isn't terrible except when using Java applications like Eclipse or Azureus. Now if only I wasn't developing Java code for school on a regular basis... :(

Share this post


Link to post
Share on other sites

Just to confirm...

 

I just tested the latest Natit (post 61) and still no luck with the GMA X3100 on a Dell Latitude D630.

Share this post


Link to post
Share on other sites

I tested the one for GMA950 desktops, and it works. The only problem is that it doesn't detect my monitors resolutions, it just starts @1024x768

Share this post


Link to post
Share on other sites
Thanks for the hard work!

 

The glitching on my system isn't terrible except when using Java applications like Eclipse or Azureus. Now if only I wasn't developing Java code for school on a regular basis... ;)

Which is the one of the reasons why I now have Tiger 10.4.10, Leopard 10.5 and XP all on my laptop :P

 

Java Development, Web Design etc. I like to do using Mac though due to the glitching in Leopard it's rather annoying when using CS3 (probably the application that is effected the worst by it!) so i've installed Tiger again so I can continue to use my favoritate combination - CS3 Suite, Coda and MAMP Pro. :) Also it allows me to do my Java work, either using Netbeans or BlueJ. Unfortuantely I still need to use Windows for a few things my university course requires :)

 

~mac.nub

Share this post


Link to post
Share on other sites

Look what info clockworx dugg up link post

Link wiki

 

in short, macbooks have GMA X3100 (GM965), G33 chipsets and most other socket 775 boards use GMA 3100.

GMA 3100 and GMA X3100 isn't the same

 

errandwolfe: looking at the spec of Dell Latitude D630 (max 256MB and DX9) it looks like it might be GMA 3100 and not GMA X3100, so that could be why natit doesnt work.

Share this post


Link to post
Share on other sites
Look what info clockworx dugg up link post

Link wiki

 

in short, macbooks have GMA X3100 (GM965), G33 chipsets and most other socket 775 boards use GMA 3100.

GMA 3100 and GMA X3100 isn't the same

 

errandwolfe: looking at the spec of Dell Latitude D630 (max 256MB and DX9) it looks like it might be GMA 3100 and not GMA X3100, so that could be why natit doesnt work.

Good find, Delish, and good lord why can't manufacturers, never mind suppliers, display accurate specification listings? I find that if I want accuracy I very often have to get google to translate the site in question into English, which adds another ludicrous layer. One site has a laptop listed as GMA X3100 and the next as GMA 3100. Do we really have to rely on third party applictions to tell us what we just bought!

Share this post


Link to post
Share on other sites

Has anybody got the 9A3110 (new MacBook 10.5 build) X3100 kexts to confirm if they're different versions to those shipped with 10.5 GM. It might be that these incomplete/buggy kexts are causing our glitches (which seem far less prevalent on my machine than you have described) and that the MacBook shipped with new/fixed versions.

Share this post


Link to post
Share on other sites

For the sake of documenting what progress I have made, if I F8 and type cpus=1 and if I have my laptop plugged into an external monitor... initially I got a distorted mess where the Leopard welcome introduction animation should be. I rebooted and this time it worked. I could even change screen settings and everything was animated and smooth. At a pinch I could even live with that if dual booting into Tiger would give me better than pointless Vessa graphics via the laptop's screen. I think my ACER Extensa 5620 does have the X3100 but I need to run a thirty party program under vista to find out and, I guess, to find the vender devs.

Share this post


Link to post
Share on other sites
Which is the one of the reasons why I now have Tiger 10.4.10, Leopard 10.5 and XP all on my laptop :P

 

Java Development, Web Design etc. I like to do using Mac though due to the glitching in Leopard it's rather annoying when using CS3 (probably the application that is effected the worst by it!) so i've installed Tiger again so I can continue to use my favoritate combination - CS3 Suite, Coda and MAMP Pro. :) Also it allows me to do my Java work, either using Netbeans or BlueJ. Unfortuantely I still need to use Windows for a few things my university course requires ^_^

 

~mac.nub

 

Just FYI: With the EFI patch installed on my notebook (specs in the sig) and running the stock Leo kernel and AppleIntelIntegratedFramebuffer.kext, paulicat's new Natit.kext loads and works perfectly. No tearing or artifacts of any kind.

 

Now if only speedstep worked on the stock kernel, I'd have no complaints. :D

Share this post


Link to post
Share on other sites

By the way, any laptop will have either GMA 950 (GM945/GM940 chipset) or GMA X3100 (GM965/960 chipset) - there are no 'in between' non-X 3xxx series GMAs (which are, in fact, clocked up GMA950s) on laptop chipsets. Those are part of G31 and G33 desktop chipsets.

Share this post


Link to post
Share on other sites
Look what info clockworx dugg up link post

Link wiki

 

in short, macbooks have GMA X3100 (GM965), G33 chipsets and most other socket 775 boards use GMA 3100.

GMA 3100 and GMA X3100 isn't the same

 

errandwolfe: looking at the spec of Dell Latitude D630 (max 256MB and DX9) it looks like it might be GMA 3100 and not GMA X3100, so that could be why natit doesnt work.

 

Delish, according to all the documentation I can find, the D630 DOES have the GMA X3100. See the link to the product spec page below.

 

http://www.dell.com/content/products/produ...=biz&cs=555

Share this post


Link to post
Share on other sites
Just FYI: With the EFI patch installed on my notebook (specs in the sig) and running the stock Leo kernel and AppleIntelIntegratedFramebuffer.kext, paulicat's new Natit.kext loads and works perfectly. No tearing or artifacts of any kind.

 

Now if only speedstep worked on the stock kernel, I'd have no complaints. ;)

O.o which new natit? Since you last posted there have been no revisions here. Are you're using a Dell? Your sig doesn't mention what laptop it actually is.

Share this post


Link to post
Share on other sites
Just FYI: With the EFI patch installed on my notebook (specs in the sig) and running the stock Leo kernel and AppleIntelIntegratedFramebuffer.kext, paulicat's new Natit.kext loads and works perfectly. No tearing or artifacts of any kind.

 

Now if only speedstep worked on the stock kernel, I'd have no complaints. :blink:

 

also (additional to mac.nub's question), does your display wake up from sleep ok? on my D620, currently non-efi and using the kexts from the ToH rc2 DVD along with the latest compiled speedstep kernel and appleSMBIOS from #10.5 on irc, i can sleep my laptop and wake it up, but when i wake it up the screen stays black.

 

has anyone with the 945GM mobile graphics successfully gotten sleep and waking to work (with leopard or otherwise)?

Share this post


Link to post
Share on other sites

Sziggle,

Maybe you want to start a new thread with this line of questioning. Many of us are still having problems getting basic functionality. This has been a very helpful thread along that path and I just would hate to see it getting clogged discussing more advanced features.

Share this post


Link to post
Share on other sites
Sziggle,

Maybe you want to start a new thread with this line of questioning. Many of us are still having problems getting basic functionality. This has been a very helpful thread along that path and I just would hate to see it getting clogged discussing more advanced features.

 

you're right, mea culpa.

Share this post


Link to post
Share on other sites

FYI...There are new GMA950 and GMA X3100 kexts in the new 10.5.1 release. I have not tried these yet on my Dell. Once I do, here is hoping we can finally get it working with Natit. I will report on any success or failure later. In the meantime anyone with some time, feel free to grab the update and test.

Share this post


Link to post
Share on other sites
FYI...There are new GMA950 and GMA X3100 kexts in the new 10.5.1 release. I have not tried these yet on my Dell. Once I do, here is hoping we can finally get it working with Natit. I will report on any success or failure later. In the meantime anyone with some time, feel free to grab the update and test.

 

Good luck =) I hope its gonna be goodnews!

Share this post


Link to post
Share on other sites

Well unfortunately for me at least there is no difference in the 10.5.1 and 10.5.0 kexts. I get the exact same result, (since I boot in verbose mode always), loginwindow.app starts and thats it, the gui never displays.

Share this post


Link to post
Share on other sites

Just upgraded to 10.5.1 (thanks 'PC_EFI' :P) and the kexts are indeed new.

 

AppleIntelGMAX3100 1.5.18.7 - 10.5.1

AppleIntelGMAX3100 1.5.16.0 - 10.5.0 GM

 

Haven't seen any glitching yet, so maybe they've fixed it :P

 

Also seems snappier, but that's a typical placebo from upgrading, so it's entirely possible I'm imagining it :D

 

Edit: I'm not. OGLEV benchmark scores are much improved, plus, we now have full OpenGL 1.5 compliance, plus the most part of 2.0 and 2.1 :D

Share this post


Link to post
Share on other sites

The new kexts are being loading perfectly...

Now I think all gma950 users will have no tearings problems...

Problem with resolutions were also solved!:)

 

Just use new gam950 kexts,AppleIntelIntegratedFramebuffer kext and the Natit.kext from 10.5.0 :)

Have a nice night from Greece:)

Share this post


Link to post
Share on other sites

Can anyone tell me a free program for finding my x3100 vendor/dev id? I'm running Vista and I have lost count of the number of times I have read not to use Vista to try and find your vender dev id, that you should install XP and run the old everest home edition, or is it the case that Vista's inaccurate reporting is down to people trying to run Everest or other old and non compatible system programs on it? Not sure XP would work with my 965M/Sata/GMA X3100, though?

 

The Natit.kext didn't work for me; I still have a solid blue screen on boot up, even after chown and chmod and sudo rm exensions mkext and kextcache... repaired permissions, no joy alas.

Share this post


Link to post
Share on other sites

Detox,

Do you by any chance have a Dell laptop? What hardware are you running? There appear to be quite a few of us left who are unable to use our X3100's.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×