Jump to content

[Guide] Installng JaS OSX 10.4.8 on an HP NX6110


3 posts in this topic

Recommended Posts

Installing JaS OSX 10.4.8 on an HP NX6110



• Intel Celeron M 1.4GHz (SSE2)

• 768MB DDR RAM (Comes with 256MB stock. You really will need at least 512MB)

• 160GB Western Digital Scorpio WD1600BEVE 8MB Cache (the stock 40GB Toshiba HDD will be fine*)

• Sony CRX835E CD-RW/DVD-ROM Drive

• SoundMAX Audio

• Agere modem (untested)

• Intel 915GM Graphics Chip

• Broadcom BCM4306 802.11g Wireless Adapter

• Broadcom BCM440x 10/100 LAN

• Synaptics touchpad


* but you'll need to set aside at least 10GB for OSX and any applications you want to install


This machine runs extremely quickly and is incredibly stable.



Things that don't work:



The hard disk will spin down but the CPU fans will remain active.



The scroll area on the Synaptics Touchpad will not work.


WiFi button

Pressing it can confuse the system requiring a reboot to get it working again.


Brightness controls

Fn + F9/F10 seem unable to control the brightness of the screen.


Things that do work:


Sony CRX835E CD-RW/DVD-ROM Drive

This is a rubbish drive and random accesses to small files are very slow and very choppy. Consequently it can take a long time to install OSX. It took me 45 minutes to get to the GUI part of the installation process. The drive chokes on certain brands of DVD-Rs and most brands of DVD+Rs so make sure you burn the iso to a brand that you know the drive likes. Imation and Maxell DVD-Rs work great in my experience. Unfortunately, since this is an OEM drive, Sony offers no support and no updated firmware to correct the DVD+/-R issues. HP's support site has updated firmware for the NX6110 but not for this drive.


Staple/Paperclip Trick

A problem with many HP laptops causes OSX to boot into a blue screen if a monitor is not connected to the external VGA port. To get around this bug one must use the staple/paperclip trick to make the system think a screen is connected.




Intel 915GM Graphics

Supported out of the box with CI only. Use DiaboliK's GMA900 Fixer to enable Quartz Extreme. Works brilliantly. If you want to use the laptop to watch videos or use the screensavers, you must run the GMA900 Fixer to enable QE. Otherwise you can probably get away without it. It's best to just run it.


Drives the screen in its native 1024x768@60Hz.




SoundMAX Audio

Works out of the box.


Broadcom BCM4306 802.11g Wireless Adapter

Run mcsmart's bcm43xx_enabler.sh then reboot to get it working.




Unlike in Windows where the blue WiFi LED remains solid, in OSX it will flash with activity. This is normal. No problems with unencrypted, WEP, WPA, and WPA2. Seems like the perfect card.


Broadcom BCM440x 10/100 LAN

Works with modified IONetworkingFamily.kext and a reboot.


Synaptics Touchpad

Cursor control works out of the box. Tapping must be enabled in System Preferences > Keyboard & Mouse > Trackpad.


Last updated: Saturday 03 November 2007, 22:41 GMT

Link to comment
Share on other sites

  • 4 weeks later...

What was your installation progress and all the phases? I wasn't able to get my wireless broadcom working at the first run but i did download all kinda {censored} to try first. I'm just re-installing to see what will happen with these apps you've mentioned ;)



- jani


EDIT: now when i re-installed hacintosh (JaS 10.4.8) on my nx6110 and all those drivers which are included in your post, I can see wireless internet indicator and Network pref says new device installed (Airport) but it's unable to see or connect any networks. I tried to swap device id's (en0 to en1) but didn't help. Only thing happened was that it found a new internal pci ethernet controller.


What is the devid for broadcom wireless adapter and what do I and other nx6110 users need to do in order to get this card working?


thanks alot :)


Link to comment
Share on other sites



These are the detailed steps that I took to get my Broadcom BCM4306/BCM4320 to work. If you don't have a Broadcom card, then they won't work for you.


1. I downloaded bcm43xx_enabler.sh.zip from this thread and extracted it to my desktop.

2. I ran the following commands in a terminal

cd Desktop

sudo sh bcm43xx_enabler.sh

3. I rebooted and it worked.

4. Had a play in Network Settings. Make sure AirPort is enabled.


Hope that helps ;)

Link to comment
Share on other sites


  • Create New...