Jump to content
G5rocks

Asus P5W DH Deluxe thread for 10.5.x Leo - 10.9.x Mavericks

1,494 posts in this topic

Recommended Posts

Possibly newer versions of clover have some different config file. I don't know it, I haven't upgraded clover yet. But you should be still able to download the version 980 for a start.

Share this post


Link to post
Share on other sites
Advertisement

Mavericks, thanks to Clover & its brilliant dev team,  was a straightforward install.

 

Seems to run better than earlier versions of OSX . . .  and nice to have an install with no damn faffing about with added kexts.

 

Heartening to have this quite old board doing a solid job of work again.

 

Thanks to all those who made and make Clover . . . it is *so* different now to the grim old times of [not] getting 10.4.x to work . . . . 

Share this post


Link to post
Share on other sites

 . . . now running a home-brew "Fusion Drive"  using an elderly 64GB SSD and an equally mature 1TB HDD . . .  runs fine & fast & so on but I seem to have cocked uthe Clover install to the really rather odd arrangement that makes up.the Fusion thang  . . anyone else done this & successfuly booting via Clover?

 

 . . . . .this tutorial was not that clear

Share this post


Link to post
Share on other sites

ALC882 Audio in Mavericks 10.9.4 & Yosemite 10.10.0 (14A389)

 

a: Have this section in your DSDT [replacing HDAU if present] - you will need to have added Method DTGP

 

            Device (HDEF)
{
Name (_ADR, 0x001B0000)[attachment=151689:Screen Shot 2014-10-30 at 11.35.52.jpg]
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x08)
{
"subsystem-id", 
                            Buffer (0x04)
                            {
                                0xD8, 0x81, 0x00, 0x00 //ALC882 Subsystem
                            }, 


                            "subsystem-vendor-id", 
                            Buffer (0x04)
                            {
                                0x43, 0x10, 0x00, 0x00 //ALC882 Subsystem
                            }, 


"layout-id",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
},


"PinConfigurations",
Buffer (Zero) {}


}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}

 

b: Download this superb utility, by Mirone

 

c: Follow 'patches' link at the top of above post, go to 'Desktop' & download ALC882.zip

d: If you don't already have it, download the current version of Kext Utility

e: Back up AppleHDA.kext from /S/L/E

. . . . fire up AppleHDAPatcher, point it at the ALC882 files, let it do its magic. Go to the new *.zip on your Desktop & find the new AppleHDA.kext; use Kext Utility to install, clear caches & so on; reboot . . . .

Enjoy . . . . I have checked stereo out only; works fine.


NB: before doing this, remove any previous hacked AppleHDA, VoodooHDA, any hdaenabler kexts & so on - you need to start with a clean AppleHDA.kext in S/L/E and no conflicting input re: layout-id

Share this post


Link to post
Share on other sites

P5WDH & Yosemite GM 14A389

 

post-103618-0-88685200-1414680512_thumb.jpg

 

Bless the old thing - works well in Yosemite, after tiresome struggle with graphics during install - Nv GT 640 requires web drivers.

 

Sleep/wake - tested with SSD only so far - doesn't work from deep sleep/hibernation: need [like most BIOS-PC users] to fiddle with darkwake/NeverHibernate settings; ALC882 patched AppleHDA as above works fine.

Share this post


Link to post
Share on other sites

How did you guys get sound working? This happens on yosemite:

 

I have p5w (acl882). When I try to load AppleHDA.kext built with AppleHDAPatcher I get:
The following symbols are unresolved for this kext:
kxld[com.apple.driver.AppleHDA] __ZN14DspFuncManager15totalDSPLatencyEv
kxld[com.apple.driver.AppleHDA] __ZN14DspFuncManager22getTailLengthInSamplesEv
Can't load kext com.apple.driver.AppleHDA - link failed.

 

I am using chameleon loader on usb to boot but DSDT is patched as per shoarthing's instructions. Additional boot flags:

kext-dev-mode=1 -f

Share this post


Link to post
Share on other sites

 

How did you guys get sound working? This happens on yosemite:

 

I have p5w (acl882). When I try to load AppleHDA.kext built with AppleHDAPatcher I get:

The following symbols are unresolved for this kext:

kxld[com.apple.driver.AppleHDA] __ZN14DspFuncManager15totalDSPLatencyEv

kxld[com.apple.driver.AppleHDA] __ZN14DspFuncManager22getTailLengthInSamplesEv

Can't load kext com.apple.driver.AppleHDA - link failed.

 

I am using chameleon loader on usb to boot but DSDT is patched as per shoarthing's instructions. Additional boot flags:

kext-dev-mode=1 -f

Suggest you try a known-good kext - perhaps from this thread.

Share this post


Link to post
Share on other sites

I installed the drivers and the utility loads but it tells me to enable the network connection in system settings but theres no option

. . are you installing 10.5/10.6.x, or something more recent?

Share this post


Link to post
Share on other sites

Hello People,

 

My P5KC burned last week (yes 'what the {censored}' there was fire...).

 

Now I got a P5W DH to replace it.

 

I have Snow Leopard on the machine and want to get firewire + network working. I searched already this hole thread and got a bunch of P5W.zip, etc... but it seems like, those are for Mavericks, etc.

 

Does one of you guys still have some Snow Leopard - p5w files laying around?

 

You would make my day way more uncomplicated... - Thank you very much!

Share this post


Link to post
Share on other sites

You need

Last Chameleon bootloader

Last FakeSMC you 've got from HWSensors.6.11.1328.pkg

Extra folder with all the stuff you will find in my signature

working for every system from snow to yosemite

 

for audio you must have AppleHDA patched (you will find too in Mountain_Lion_P5WDH.zip)

 

good luck

Share this post


Link to post
Share on other sites

Thanks aliab.

Thanks for your help!

 

After my system didn't start again, I thought, a cleaner solution would be to just setup a new system.

 

And now my frustration begins...

 

I tried all installations of 10.6., 10.8 and 10.9 - all failed :/

 

I use the I-boot 3.3 version and than inser the snow leopard cd.

10.6 stops at the beginning of the Snow Leopard 10.6 DVD installation routine

IMG_0111.jpg

 

 

 

I tried Cameleon with Mountain Lion and used your introductions: http://www.insanelymac.com/forum/topic/280549-asus-p5wdh-deluxe-installation-de-mountain-lion-mavericks/ . I can enter the install screen with the -x flag, but just the half of the screen is visible, what makes it kinda complicated to install ;)

 

 

Yosemite and u-nibeast 5 freezes completely after 2 seconds installation bar.

 

I setup my BIOS - like this: http://p5w-dh-deluxe-osx86.wikidot.com/bios-settings

 

:/

 

my System:

 

Asus p5w DH Deluxe (Bios: 3001)

Core 2 Quad Q9650 (3ghz)

8 GB RAM

ATI HD 5750

 

I'm really lost...

Share this post


Link to post
Share on other sites

Ohhhkay....

 

After trying to install Win 7 and / or Ubuntu... I got the feeling that something is a bit 'fishy' with my machine.... 

 

I took out 3 of my 4 RAM bars and tadaaaa..... I could install Ubuntu and than also 10.6.3

and 10.6.3 is now successfully installed. Looks like the fire took more than just my mainboard.

 

Now, further... Hope they kext juggeling will be a bit less time consuming :/

Share this post


Link to post
Share on other sites

Hi 

I've been running Yosemite on this board for a while without any issues.

Since last week I'm having issues with sleep. Meaning 1 out of 2 times my PC would not wake up anymore (halted cpu, spinning fans), an old problem that I haven't seen anymore since ML.

I think this happened after installing xcode, can't tell for sure.

I noticed that appleLPC.kext isn't loading. So my guess is that this could be the reason.
I use a custom DSDT, I've spend a day trying to find a decent patch for LPC ICH7, but without any luck.

If anyone could point me in the right direction to solving this, my eternal gratitude is yours.

I use latest clover as boot loader.

additional kexts:

AHCI_3rdparty_sata

appleACPIPlatform

ApplePS2Controller

ApplePS2Mouse

ApplePS2Keyboard

ApplePS2Trackpad

Evoreboot

fakeSMC

genericUSBXHCI

lspcidrv

Patched_10.7_AppleRTC

voodooHDA

 

my specs

P5W DH DELUXE

Q6600

Corsair 8GB DDR2 6400

 

link with my dsdt

https://www.dropbox.com/s/ruixtpej9ps8m7m/DSDT%202.aml?dl=0

 

greetings Chip

 

UPDATE:

 

I managed to get appleLPC to load with LPCinjector kext

Got rid of all unnecessary kexts, never took the time, as it seems now that I only need fakesmc and voodoo for everything to work properly with my new custom DSDT

Sleep though is still not as it should be, sometimes it works, sometime PC wakes by itself, but gets stuck in halted cpu state with spinning fans. I noticed that every 2 hours PC is woken by RTC alarm, but manages to get back to sleep after a few seconds. But on other occasions, (still haven't found exactly why and when) it gets stuck. Any pointers more then welcome.

 

 

 

 

Share this post


Link to post
Share on other sites

@Renhard45 

 

The motherboard defaults to legacy USB without proper configuration.
On my setup to achieve High-Speed USB 2.0 an edited DSDT is used.

The DSDT linked in my previous post contains the USB edits.

Mind DSDT's are very specific. I use a Q6600 CPU. Better apply the patches yourself on a fresh DSDT from your system.

There are still some old DSDT databases on the net, where you can find a specific p5w dh deluxe patch.

 

Cheers

 

 

BTW:

Do you have any issues with sleep on Yosemite? What do you use to achieve sleep?

Share this post


Link to post
Share on other sites

Does someone know the power consumption of the Mainboard itself? I would love to use it again (my mini is not powerful enough graphics wise) but with a new PSU and GPU.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×