Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Espionage724

Help! Intel High Definition Audio and Mac OS X Leopard Probelm!

Mac!  

224 members have voted

  1. 1. What Mac Are You Running?

    • Tiger
      15
    • Leopard
      206
    • Jaguar
      0
    • Panther
      0
    • Other (Classic, OS 8 or 9, etc)
      0
    • No Mac (Windows, Linux, etc)
      3
  2. 2. Legal or Hackintosh

    • Hackintosh
      210
    • Legal
      14
  3. 3. Desktop or Laptop?

    • Laptop
      148
    • Desktop
      76

17 posts in this topic

Recommended Posts

Device: Intel HDA

OS: Mac OS X Leopard

Laptop: Yes

Issue: I have Onboard Speakers and A Headphone Port. The Headphone Port Works but the Onboard speakers do not.

Other Info: Used AppleHDAPatcher (shown towards bottom.

 

Any Kext? Any Fix? Anything? I need one! :D

 

(read my last post for fix to get headphone port fix)

Share this post


Link to post
Share on other sites

in sted of bumpin use google

or you could just replace your leopard sound kext files with that of tiger

just like the update from 10.4.9 -10.4.10

Share this post


Link to post
Share on other sites

How would i replace the kexts? I used some thing on this site that just installed my drivers for my Realtek HDA on Tiger. I did this on leopard and it died lol.

Share this post


Link to post
Share on other sites

wel basic ly the asus p5w has a realtec 882 chip set so if you have it as well its just install like the guide says it you would have audio.

Share this post


Link to post
Share on other sites
wel basic ly the asus p5w has a realtec 882 chip set so if you have it as well its just install like the guide says it you would have audio.

 

do you have audio-in working as well? i have a P5W-DH and used the files from that guide, i have audio output working but no input.

Share this post


Link to post
Share on other sites
Issue: Cannot use Headphone port on front of laptop

 

I have the same problem, though I'm using Tiger 10.4.10. I think there's no way I can get my headphones working ^_^ The only thing that works are internal speakers using AppleAzaliaAudio kext, but there's no input or output. Taruga's ALC262 kext shows input and output, but there's no sound at all. I have tried several other kexts but all my tries were rather unsuccessful.

 

Is there anything I can do ?

Share this post


Link to post
Share on other sites

NVM about the question before. I HAVE FIXED IT :rolleyes:

 

AppleHDA Solution - Work in progress

http://forum.insanelymac.com/index.php?sho...9&hl=Taruga

 

Downloaded AppleHDAPatcher_v1.16

http://forum.insanelymac.com/index.php?act...st&id=11042

 

Downloaded ALC883 Linux Codec Dump

http://psykopat.free.fr/apple/AppleHDA/rea...-GA-965P-S3.txt

 

Placed The Patcher and Codec On My Desktop

Dragged The Codec On Top Of The Patcher

Waited 3 Secs

Entered My Password

Waited And Watched It Patch

Rebooted

 

Thats Exactly What I Did! And My Headphone Port Works Now :(

Share this post


Link to post
Share on other sites

ehm same as in previeus versions

so you get your old kext files from tiger and

The same AppleHDA.kext that ran on 10.4.10 for my Bad Axe 2's audio works flawlessly on Leopard.

 

well i dont have 10.5 installed but basicly we copy the old kext files

so if you put your old kext file from 10.4.10 in the root

open terminal

sudo -s

cp -R AppleHDA.kext /System/Library/Extensions

chmod -R 755 /System/Library/Extensions/AppleHDA.kext

chown -R root:wheel /System/Library/Extensions/AppleHDA.kext

and reboot

it sould work fine 2

Share this post


Link to post
Share on other sites

You hate bumpers and want me to keep it to one post? How is anyone going to find my topic then if its like 25 pages down the thing??

 

Still looking for a fix also. Please anyone?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×