Jump to content
Conroe Mac

Latest Leopard Installation Methods Information (Intel SSE3)

109 posts in this topic

Recommended Posts

Anyone know how working with:

 

GF 8800 GTS 640MB (full support?)

Gigabyte P35 DS3R / ICH9

SATA, IDE ATA drive ?

 

...

 

I've installed the Leopard flat image from Demonoid onto my Gigabyte P35-DS3R and it works perfectly. I have SATA drives and I've configured the BIOS so that SATA is seen as IDE. I can't speak about compatibility with 8800.

Share this post


Link to post
Share on other sites
Advertisement

Error while install Leo on Dell x300

 

Hi all,

 

Keep on getting this error while installing on dell x300 laptop. Patched BrazilMac.

 

Mac Framework successfully initialised using 3276buffer headers and 3276 cluster IO buffer headers.

 

The install wont go any further.

 

Any Ideas?

Share this post


Link to post
Share on other sites
Hey, thanks for the reply. Question though, I don't see the _MACOSX folder anywhere. In the downloaded patch, I have all the other folders and it is the one from 10-31.

 

Ok, followed your instructions to the T with all files on the desktop and the sh files edited and i still get file not found...Don't know what to do anymore. I also noticed that after "patching", it's unable to umount the image and it also renames my Tiger partition to the name it's supposed to give the patched dvd before renaming it to Leo-patch.dmg....

 

Any thoughts?

 

In your log , I notice

Mounting new ISO read-write...

/dev/disk4 /Volumes/Mac OS X Install DVD 1

It didn't attach your leopard.iso.cdr . That is the problem .

 

In this case , I suggest you manual create & attach leopard.iso.cdr .

In terminal type :

hdiutil convert /Users/Prince/Desktop/osx-leopard105.dmg -format UDTO -o /Users/Prince/Desktop/leopard.iso

hdiutil attach -readwrite /Users/Prince/Desktop/leopard.iso.cdr -owners on

 

If you see a volume name "Mac OS X Install DVD" is mounted , you can go on . In the script delete above lines & the line "rm -rf "$APDIR"/leopard.iso.cdr" .

So you can try the script without the need to recreate leopard.iso.cdr each time . It save much time ^^ .

 

About __MacOS , you can use tinkertool to view hidden file or use a Windows OS to check patch file .

Share this post


Link to post
Share on other sites

Thanks thehuan but I suspected that something was wrong with my tiger install. So I reinstalled on a different partition and it looks like the patch is working (doing it now...so far so good). If it doesn'y work out, I'll then try your suggestion.

 

Thanks again

 

Install Successful...took a lot of work and patching and repairing permission but it all worked out in the end..

 

Thanks once again

Share this post


Link to post
Share on other sites
Anyone got Leopard running on a BadAxe2 board yet?

 

I followed brazil's instructions, everything went well until I tried to boot Leopard. I get stuck on this error:

 

ERROR: Firewire unable to determine security-mode; defaulting to full-secure.

 

I'm not sure if thats the actual problem but thats the last line it got stuck on. Any suggestions on how to fix this?

 

 

How did you solve this problem, I have the same issue on my bad axe.

Share this post


Link to post
Share on other sites
How did you solve this problem, I have the same issue on my bad axe.

There are two things that I did:

 

1. I wasn't sure the Post Patch script from BrazilMac was doing everything correctly, so I just open the script and manually paste the commands one by one into the terminal. Basically, do a sudo -su in terminal and where it says $LEO in the script, I would change it to /Volumes/Leopard. Be sure to have your drive labeled Leopard also. And make sure the source location is correct, the path should be to the leopatch folder on your desktop.

 

For example, where it says: cp -R $PATCH/mach_kernel $LEO/mach_kernelI would change it to cp -R /Volume/Tiger/Users/xxx/Desktop/leopatch/mach_kernel /Volumes/Leopard/mach_kernelWhere xxx is the your user name in Tiger.

 

2. Go to this thread posted by svsmurf and follow the instrution to fix the boot problem: Link

I had to find the startupfiletool and place it in the /usr/bin folder in Tiger. I found it here: Link

That's all, good luck.

 

HI BebopBlues,I'm using Adobe Master Collection with Leopard without a problem. Even update to the last version available.I've used the kext for tiger. It seems to work very well with Leopard.

Thanks for the kext, it works.I ran into another problem, I just installed FCS2, and when running FinalCut, it just get stuck at the "Loading FCS Engine" splash screen. Motion and DVDSP seem to run just fine. Anyone have any idea how to fix this?

 

Edit: I fixed it. Apparently, the AppleSMBIOS.kext is the root of the problem again. I downloaded another version at demon and it works with both CS3 and FCP. I don't know what version is this kext, but getting info on it, its only 48kb versus the one sdf2002 gave me, which is 321kb. Also, the 321kb one would crash my loginwindow every time I restart. It would create these empty files inside my /system/library folder (com.apple.Components2.LocalCache.AudioComponents, com.apple.Components2.LocalCache.Components, com.apple.Components2.LocalCache.QuickTimeComponents). After replacing the kext with the 41kb version, these files no longer exist and no more restart problems.

 

I'm attaching the AppleSMBIOS.kext (41kb)

AppleSMBIOS.kext_41kb_.zip

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×