Jump to content

Extremely Slow USB Transfers


7 posts in this topic

Recommended Posts

I've searched and checked all the stickies pertaining to this issue. My USB works, as my iPod is recognized, but data transfer is incredibly slow. I read the sticky on USB, downloaded the appropriate drivers for 10.4.10, and installed them. Unfortunately, speed has not increased, and data transfer is still incredibly slow. My system profiler lists 2 used USB ports: my mouse and iPod. Both are listed as "Up to 12 MB/s", thus, not hi-speed. I would be fine with this, if my iPod actually transferred data at 12 MB/s. Instead, it feels more around 1/2 MB/s.

 

Does anyone have a solution to this, or have the same problem? Help would be greatly appreciated.

Link to comment
Share on other sites

Provide us more info.

 

For starters, be specific. I assume when you say you did "the sticky" thread, you mean the PCGenEHCI fix?

 

Is this onboard USB or a PCI based USB card?

What chipset do you have for the above?

Are there any messages in dmesg after you plug in a device?

Have you tried all USB ports?

Is this through a USB hub?

Link to comment
Share on other sites

Thank you for the response.

 

I was referring to http://forum.insanelymac.com/index.php?showtopic=21487, or the "10.4.7 USB FIXED" thread. I just found the PCGenEHCI fix, but it doesn't seem to have a link for 10.4.10. I will download the 10.4.9 version, but I will hold off on installing it.

 

This is on board USB.

I am using a NF4 chipset.

 

After I plug in a USB device, and I run sudo dmesg, there are no new messages at first. I then unplugged the USB cord from my computer, and replugged it back in. After the device showed up on my desktop, I reran dmesg. The message, "disk1s2: media is not present." came up.

 

I have tried all my USB ports.

This is not through a USB hub.

 

I read some more threads, and I checked for AppleUSBEHCI.kext, which I don't have (never deleted it, it must never have been installed in the first place?). However, all my USB works, except for two things. I had to replug in my mouse the very first time I booted OSX (not anymore), and all my USB ports are capped at 12 MB/S, or USB 1.1. I know I have USB 2.0, as my XP partition copies files to my iPod very quickly.

 

For now, I will be using USB 1.1 speeds. I may chance an installation of USBEHCI-2.7.0, which is for 10.4.9.

 

 

 

 

EDIT - I just found AppleUSBEHCI and AppleUSBOHCI in Extensions in my System Profiler. Am I to remove these? If I did, wouldn't my current USB porst cease to function?

 

By the way, I ran sudo dmesg | grep USB, and I got:

 

USB0: family specific matching fails

USB2: family specific matching fails

USBF: 30.749 AppleUSBOHCI[0x34fe000]::start OHCI controller will be unloaded across sleep

USB0: family specific matching fails

 

Thanks.

 

EDIT 2 - Issue was resolved. Thank you for your help.

Link to comment
Share on other sites

Sure guys, in the PCGenEHCI thread, a person posted links to a version of the drivers he altered for 10.4.10. Search for "PCGenEHCI", find a thread with drivers up to 10.4.9, and go to the last page of that thread. Somewhere near there, there should be links to the fixed drivers.

 

Good luck!

Link to comment
Share on other sites

 Share

×
×
  • Create New...