Jump to content

Installation of OSX not Detected!

Swami the Jerk

54 posts in this topic

Recommended Posts

hello :)

i got osx installed after a lot of struggle and waiting and formatting and everything!


but, i have a few problems...

1) i can boot only in safe mode.. why? :) if i boot in normal mode, i just reach till that blue screen.. from there it goes nowhere :( no mouse pointer as well.. just the blue screen...

2) if i go to display preferences i can change my display to 1280x1024.. but if i reboot, it comes back to 1027x768... can i make it permanent? or is it reverting back coz i did this in safe mode(the only way i can boot)

3)my chipset is intel 865G based... in windows when i install the driver for the on board audio, it comes up as soundmax.. but i dont know the actual name of the audio thing on my mobo... is the azalia common to all? anyways, i installed azalia and i got no sound :(

4)this time instead of natit i tried with titan.. no quartz :( but earlier when it was natit, i had quartz ... can i uninstall titan and install natit? how?


by the way, the installation is uphuck 10.4.9

thanks a lot in advance :)





edit :-

this problem was solved with the help of pcwiz :)

this worked 100%

the new problem is in the last post :(

Link to comment
Share on other sites


i typed -v at the boottime..

no errors were there other than that airport driver not found thingy, which normally happens...

but, as soon as the logonwindow app is launched my monitor just turned off..

and never turned on...

even in safe mode this happens..

but, during safe mode, the monitor turns back on after abt 30 seconds...

my graphics card is Nvidia Geforce 6200 256mb AGP...

the drivers i selected for my card during installation were Natit v0.1 and AGPGart v2.0

Link to comment
Share on other sites

alright! :)






now i can boot in native as well :)

but, the monitor turning off is still there... :)

but, it turns back on after abt 30 seconds.. thats kinda okie.. no probs even if it turns off.. but, what shud be causin it?

my mobo is Asus P4P800 VM which is listed in the HCL in os86project website..

and they say everything is working..

apart from this motherboard gettin turned off, i dont have audio..

anyways, am in the process of correcting it with the help of other threads..

but, can anyone please tell me why my monitor turns off as soon as the verbose mode screen displays loginwindow app started and turns back on after some time?

there is one lil problem as well.. if i take the "about this mac" i gets logged off and automatically logged back in!!! ;)

Link to comment
Share on other sites

audio problem sorted out with Macgirl's kext file :(

so as of now the problems i have are :-

1) Monitor turns off just before showin the login screen then turns back on after 30 seconds...

2) "About this Mac" will close all the open windows and docks and it feels like am gettin logged off and logged back in...

3) USB Web Cam is not recognized(IOUSBFamily has a problem enumerating a device... connected at some blah port.. some blah hub...)

Link to comment
Share on other sites

I get the monitor turning off thing with mine too, before the login screen but it only turns off for 1 or 2 seconds. The problem with yours is the Natit drivers. Reinstall and install the Titan drivers for your card instead and don't choose Natit. The Natit drivers are also the cause of your About this Mac problem. Install Titan drivers and those 2 problems should be fixed. See this post for more info:




For your webcam, its quite common to have a Webcam that doesn't work with OS X. Se on the manufacturers site if there are any drivers for OS X.


Hope this helps


Link to comment
Share on other sites

yeah, i will do that... :)

but uninstalling natit == removing the kext file from Extensions folder?

and reinstalling titan = putting the titan into the Extensions folder?

or is there an installer to do this job? :whistle:

and its a thread dedicated to my GFX card :D

thanks a lot :)

Link to comment
Share on other sites

Yeah, to uninstall Natit just remove the Natit kext(s) from the Extensions. To install Titan, get an install disc with the Titan drivers for your card on it. Then open the DVD and navigate to (inside the DVD) /System/Installation/Packages/ Find the Titan driver package for your card and double-click it to launch installer and install!

Link to comment
Share on other sites

hey, pcwiz..

you are the man! ;)

i uninstalled natit..

and reinstalled titan...

that solved all my problems..

it solved the "about this mac" crash..

it solved the system profiler crash..

it solved the "can only boot in safe mode" problem..

it solved the "monitor gettin turned off" problem...

i now have quartz.. quartz 2D... rotate... :) (where do i check to see whether i have CI..Core Image?)

dunno how to thank ya... :D


as of now i have just one problem...

if that gets solved, my osx installation can be sed to be 100% working...

"i need to get my mic working" :P


i have a doubt, when i had gone to the extensions folder, i saw a lot of ATI related kexts in there..

but, am not havin anything related to ATI..

so, why shud i have those kexts?

can i remove all the ATI stuff?

and do the "rm ATIblah.kext" ..."rm kextcache" "kextcahe -k...." ???(yea of course the complete command..)

Link to comment
Share on other sites

You're very welcome :D


Answers to your questions:


1) To check if Core Image is enabled, open System Profiler, click on Graphics/Displays (or was it Displays/Graphics?) from the left. Then check the listing next to Core Image. If it says Supported, then its working.


2) Don't delete the ATI kexts or anything in the Extensions folder unless you know what you're doing. Just leave them alone, its not going to do anything to leave them there.


For your Mic problem, I'll try to help. I need to get a couple things straight:


First of all, your Creative Soundblaster isn't supported under OS X so you probably won't be able to use that.

So, in that case, are you using your onboard AD1980 for sound input and output?

Link to comment
Share on other sites

core image, i will check as u said..

right now i am on XP...

gotta take some backups to my external HDD before i format and reinstall

today am gonna reinstall everything to my SATA as its detected now..

earlier it was not detected when i was on my VIA chipset based mobo..

so, i changed the mobo into an intel based one :)..

hope everything will work..

after all u taught me what i shud do :)


okok am not gonna delete the ATI kexts, but, i asked coz i dont have any hardware from ATI...

and i also dint choose ATI during the installation...

dunno how those kexts came!!!


yea, creative soundblaster is not even detected ;)

and yea am using the onboard AD1980 for the output...

its workin as stereo.. :)

but, the speaker cord is connected to the mic port..

only then i get the sound ;)

Link to comment
Share on other sites

Its OK to ask questions, no worries :D


For the ATI kexts, they are installed by default in every OS X installation whether your card is ATI or not. They don't have a purpose and aren't used unless you have an ATI card. But as I said, leave them alone to avoid getting into a mess :D


I'm guessing its a SoundMax AD1980 am I right? I don't know much about these cards but heres what I suggest:


Install the Azalia Audio Driver (probably on your install disc) and see if your audio works with the normal connections.


If it doesn't, see this thread:




And scroll down to the SoundMax part and follow the instructions.




Link to comment
Share on other sites

tht lil mic problem, well leave it.. its not a big issue for me, as i dont voice chat with anyone :D

so in my view my last osx installation was 100% working :)

thanks to pcwiz and insanely mac :)


now the new problem begins!!! :P

my previous installation was like...

win xp on a 140GB SATA

osx on a 200GB PATA

but, tht PATA HDD was from my bro's compy..

and now he needs it back..

i formatted it and gave it to him..

and i shrinked my winxp partition so tht i have 100GB free unallocated space for osx installation...

i used acronis disk director suite to format tht free space into a FAT32 Primary partition...

rebooted, and booted from the jas 10.4.8 DVD...

continue.. continue.. continue :P

disk utility..

selected the 100GB FAT32 partition..

erased it with OSX Journalled file system...

closed diskutility

selected that partition as my target destination...

selected the SSE3 patch...

and instaleld it..

everything went fine...

it asked for a eboot..

did tht..

but, my acronis OS selector detected only the windows boot :(


i booted into XP...

copied the chain0 into C drive and added it to the boot.ini file..


still its the same :(

what could be the problem?

nowhere it says that xp shud be on one drive and osx shud be on another..

there are a lot of people who installed xp and osx on the same drive which was partitioned into two :(

what could be the problem in my case?

pcwizzzz :(

Link to comment
Share on other sites

swami, if you wish to fully utilise your video capabilities with AGP, (re)install the latest version of AGPGart.kext (I think it's 2.0?) and set your AGP Aperture Size in your BIOS to 128MB.


for reference sake, AGPGart.kext is NOT a video driver... it just makes your hackintosh recognise it's using the AGP bus and thus allows for utilisation of 8xAGP.


it will work fine with your current titan install.




and about your latest problem:


the first thing i thought of was that you didn't set the partition scheme to MBR in your Options in the partitions tab of disk utility during your install. setting it to this should allow acronis to see your osx install.

Link to comment
Share on other sites

Why use Acronis? Since you have XP you can use the existing XP bootloader to load OS X! And you don't need to do the MBR thing. Steps:


1) Boot Windows XP

2) Get your install disc and insert it into the drive

3) Wait till XP reads the disc.

4) Copy the "chain0" file from the OS X disc root and copy it over into the C:\ drive (place it in the root of the C drive)

5) Go into Control Panel

6) Open the Folder Options applet

7) Click the View tab

8) Choose the "Show hidden files and folders" option

9) Uncheck the "Hide protected operating system files" checkbox

10) Click Apply and then OK

11) Close everything and navigate to My Computer >> C:

12) Inside C:, find the "boot.ini" file (the file name appears as "boot")

13) Open the boot.ini file using Notepad

14) Add the following line to the file:


C:\chain0="Mac OS X86"


15) Save the file (File >> Save)

16) Reboot your computer and you should get to the boot menu and you can boot OSx86!




Link to comment
Share on other sites


that problem was solved...

i removed both natit and agpgart..

then installed titan..

everything worked flawlessly




i had done this when i had installed xp on one hdd and osx on another hdd..

the chain0 methot worked..

but, this time am on a single hdd with two partitions and it was givin me a chain booting error!!!

so, i tried installing acronis, even acronis is not detecting my osx installation..

after the installation of osx it was supposed to go to the osx directly and shud have taken me to those initial setup screens..

it dint happen..

instead went to windows..

thats why i had tried with acronis..

still no luck..


right now i reinstalled windows givin it the whole 160GB

am gonna use disk director to resize the single partition and create a 100GB unaloccated space..

then am gonna format tht 100GB into a FAT32 primary partition..

then gonna use vmware this time to install, so tht i can check thru the forum :D

hope this is a correct way...

Link to comment
Share on other sites


  • Create New...