Jump to content
pakaya

Logic Studio is working in my Hackintosh!

74 posts in this topic

Recommended Posts

andrw I'm having same VRAM error too.

 

can you share how you fix it please

 

After you mount the dmg use pacifist to install rather than install the program through its own installer. Main stage and other programs might not work though.

Share this post


Link to post
Share on other sites
Advertisement

Hi I'm new here,

 

Can any of you guys direct me how I can get into this Hackintosh, I'm running Logic 5.5 on my PC right now, and really can not afford a mac at the moment ;):(:( , so this would be a good middle road till next year.

 

What I'm really after is just how to get the hackintosh and then I can get a legit version of OSX and just upgrade my copy of Logic for £179.00 :D

 

Here's my PC specs any help weel appreciated.

 

Core 2 Quad 2.4 GHZ PC / 1GB PC8000 DDR2 Ram / ASUS P5BE Plus Motherboard / Nvidia 128MB Graphics / Arctic Cooling FREEZER 7 CPU fan / FSP QUIET 400W PSU / 160GB HD / 120GB Firewire HD / 80 GB USB HD / Win XP Home SP2 (with latest updates) / EMU 1820m / M Audio Midisport 2x4 / Logic 5.5.1 / UAD 1 x2 / Battery 2 / EMU Emulator X2 / Mackie Control & XT.

Share this post


Link to post
Share on other sites

Hey all, new to the forum. Anyone gotten Logic 8 Pro to work in leopard??? I'm looking to put together a new build for the purpose of getting into logic...any advice on which OS version is most stable to install for logic pro 8 would be appreciated...

Share this post


Link to post
Share on other sites

I too would be interested to know if Logic would run in a Leopard Hackintosh.

 

Apparently, Leopard with the EFI patch on a PC _IS_ a mac - in that it thinks it's a mac and will do anything a mac does.  But still... I'd like to know.

 

 

Trying to get Leopard on my Gigabyte P35 DS3R - new SATA DVD should do the trick.  Once done I'll be giving it a go

 

 

Hey all, new to the forum. Anyone gotten Logic 8 Pro to work in leopard??? I'm looking to put together a new build for the purpose of getting into logic...any advice on which OS version is most stable to install for logic pro 8 would be appreciated...

Share this post


Link to post
Share on other sites

hi guys

 

Run smooth here, with HDSP 9632 and Leopard 10.5.1 + Vanilla + PC EFI.

The best DAW i never taste. THE SOUND IS GREAT....

 

Cheers.

Share this post


Link to post
Share on other sites

Leopard + Logic Studio + Hackintosh = All working. Works without EFI (hacked kernel) or with EFI (vanilla kernel). No difference. 10.5 or 10.5.1

Share this post


Link to post
Share on other sites

Hi Guys, i got it working on my core2duo with 10,4,9. Could somebody tell me the best kext for my realtek inbaord hd audio ? My sound isnt very good when using audio units.

 

Setup - core2duo e6600 ,1gb ram, 500gb sata, x1600 pro. everything is working fast but just seems to be a problem when using audio units i think my kext is definately causing the problem

Share this post


Link to post
Share on other sites
hi guys

 

Run smooth here, with HDSP 9632 and Leopard 10.5.1 + Vanilla + PC EFI.

The best DAW i never taste. THE SOUND IS GREAT....

 

Cheers.

 

Just having a browse. Penarol looks like we are running similar systems.

 

I thought I had posted in this thread a while back, looks like I didn't. Logic 8 is also is running great on my system in my sig.

Share this post


Link to post
Share on other sites

Hi, I have installed uphuck 10.4.9 and logic studio 8. I am running sound from Realtek AC'97.

 

All working fine - only have 512mb of ram so logic wouldnt let me install - but with a few changes to some of the install plists got over this problem. Maybe this might help with the VRAM problem??

 

I do have one problem though - logic 8 runs fine for the most part, i can run a fair few insts and plugins with no problem. However, whenever i put audio on a track i get cpu spikes. The cpu spikes happen slightly before the audio plays (buffer i guess) and constantly throughout the duration of the audio. There is a 1-2 sec gap between each cpu spike. This happens even if i load a new project and just put one audio file on one track with no processing

 

This is strange because whenever i run audio through exs/ultrabeat there is no spiking.

 

Anyone else had this problem?? my audio seems fine for everything else.. the only descrepency i can notice is that in the system profiler - under audio (built-in) it just reads no built-in audio

Share this post


Link to post
Share on other sites

One of the best things about Logic Studio is it comes with s**t loads of content, buy it or take the plunge and download all 8 (i think its 8) disks. To be honest it's cheap enough to buy and it will save you the headache of downloading, unpacking and mounting/burning! I recently bought 7.2 cause it's cheap on ebay now. I know a lot of people like to go with the latest and greatest but to be honest 7.2 is more than good enough to suit my needs :lol:

Share this post


Link to post
Share on other sites

I am running leopard 10.5 and when I go to install Logic it says "Alert! Logic installer recomends your system have 64 MB of VRAM; this system has only 0 MB of VRAM"

 

solution:install your graphic card driver and change the resolution from 1024 x 768 to another higher.

(i have the gforce 6600 gt 128mb and install the Natit.Dual.v01.kext.installer.pkg)also check this site drivers :wallbash:

 

by the way i 'm getting the error installation from logic 8 pro :please incert the audio content disk 1.Logic has 7 or 8 installation dvd?

 

thanks"

Share this post


Link to post
Share on other sites

Hello,

 

I installed Logic Pro 8, updated to 8.1, and i get some error: Logic Pro System Overload or Disk Too Slow.

 

I saw some posts on other forums saying that updating from 8, to 8.1 will fix this, but it seems like it didnt... If i run 4 audio tracks with 4 loops, it cant play for more than 2-3 seconds... (if i run the same thing in Logic Express 7, there are no problems).

 

Is anyone experiencing similar problems?

Are there any ways to fix it?

Share this post


Link to post
Share on other sites
I can confirm that installing with Pacifist is a workaround for the VRAM problem and the Quartz Extreme error.

 

Why don't people who have this error instead of trying the pacifist workaround, actually go out and buy a better graphics card (unless your using a laptop).

 

I got a Nvidia geforce 7300gt old-ish card picked it up very cheap and supports quartz extreme.

Share this post


Link to post
Share on other sites
Any solution for the VRAM error!?

 

"About this MAC" show, that my vram is about 25MB but logic isntaller says its 0MB... I have x1950 Pro and the resolution is great now but logic studio wont install...

Share this post


Link to post
Share on other sites

I got logic work on my hackintosh, but when i click 'play' and drag mixer window - it's very jerky.

If sound stopped - drag work smooth.

 

What's wrong?

 

 

p35-ds3 q6600 7600gt

Share this post


Link to post
Share on other sites

I have also logic 9 running on my hacintosh.

 

But after installing logic my sound is gone in I tunes.

 

When is start logic 9 en go to the audio options and choose "output 3-4" i hear the sound only on the left speaker and when i change it to "output 5-6" i only hear it the sound on the right speaker.

 

Does somebody have a solution for this?

 

I have a ASUS P5P800 motherboard with on an onboard AC97 soundcard.

Share this post


Link to post
Share on other sites

Logic 9.02 working flawlessly in my Hack. Im using it together with Reason via Rewire with my good old M-Audio Delta 66. No Problems at all.

Share this post


Link to post
Share on other sites
Logic 9.02 working flawlessly in my Hack. Im using it together with Reason via Rewire with my good old M-Audio Delta 66. No Problems at all.

 

I had Logic 8 running before on my Kalyway 5.2 hack but I have now decided to get Logic 9 and am having problems installing it because of this dumb error:

 

vram is less than 64

 

ALsos Logic 9 requires minimum version 10.5.6 I think which I tried and had the same problem.

 

My gpu is ATI sapphire hd4850 512MB

I'm pretty sure its compatible lol.

 

core2duo e6600

 

Abit Ab9Pro

 

I have managed to force my gpu resolution to 1280x1024 via graphics mode at startup and my gpu is recognised in profiler properly but I keep getting this error which is really annoying.

 

Anyone know a reliable way (apart from the Pacifist method) to change my vram settings properly.

 

I am running SnowLeopard 10.6.2.

 

I'll probably end up changing my soundcard as I think the delta 1010 is not compatible anymore.

Share this post


Link to post
Share on other sites

UPDATE: I have Logic Studio (Logic 9) running on my hack on Snow Leopard 6.2 finally.

 

I had to bypass the requirements checker to get it to install as my graphics card (ATI 4850) doesn't have QI/CE working yet and so it was not recognised (I was getting the 0 vram error).

If you have this problem basically unzip the setup file to your desktop and then open it and delete the requirement checking app.

Then you should be able to install no problem.

 

I should add that my M-Audio Delta1010 does work (Envy24), I can get sound in and out of it but I can hear some noise when I record through it. Its not a clean recording which is not good.

I think this is due to hacked drivers and not official ones as I'm using the Envy drivers.

I do not get this 'noise' when recording in windows so its not due to dust.

 

I also read that support for Delta series was dropped by M-Audio for OSX 6.2:

 

Link: http://www.m-audio.com/products/en_us/Delta1010.html

Official M-Audio statement: http://www.m-audio.com/index.php?do=suppor...a5d5f4ef3da6903

 

I am in the process of researching a more updated and SL6.2 compatible audio interface.

 

Can I ask what drivers you are using to get your Delta1010 to run properly and have you recently done any recording throught it. Was there any signal or static noise?

 

I run the Delta 1010 in my hack along with the Saffire Pro 10 i/o on 10.6.2 and it works very good

Share this post


Link to post
Share on other sites

Personally, i wouldn't even think about installing logic before sorting out graphics card issues and other necessary fixes, just as i wouldn't think about installing SL before checking hardware compatibility.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×