Jump to content
TheTimster

Atheros AR5006 and 5007 Working.

206 posts in this topic

Recommended Posts

Hi siachori,

I have installed Kalyway 10.5.2, iATKOS v2i, iATKOS v4i & JaS 10.5.4. All of them can't get our beloved AR5007EG wireless card recognized. Actually, AR5007EG will not going to work in any release unless we hack the hardware. However, hacking or rebranding a hardware is not an easy job. I can't find any tools that can do the job.

 

I'm right now using Linksys wireless cardbus (WPC54G ver. 3) which is working wonderfully in any OSX release so far.

I think you have read BuildSmart's post which is not really helpful. He even did not mention the name of the tools that he use to rebrand his card. So, it is totally useless.

 

kizwan

 

Hi Kizwan,

 

What drivers/kexts did you use to get the WPC45G working? I have a WPC45G Ver. 1.2 but I don't know what kexts to use (in lieu of the atheros card in my aspire 5315).

Share this post


Link to post
Share on other sites
Advertisement

Thanks for all!

 

Hi siachori,

I'm right now using Linksys wireless cardbus (WPC54G ver. 3) which is working wonderfully in any OSX release so far.

kizwan

Share this post


Link to post
Share on other sites
Hi Kizwan,

 

What drivers/kexts did you use to get the WPC45G working? I have a WPC45G Ver. 1.2 but I don't know what kexts to use (in lieu of the atheros card in my aspire 5315).

 

Hi diogan,

You have different version which is ver. 1.2 & I don't know if it has same chipset (broadcom) or not. From this website, it show that your cardbus use broadcom chipset.

 

You need to replace two kexts file, IOPCIFamily.kext & IOPCCardFamily.kext. You can get this kexts file over here:-

CardBus/PCMCIA PC Cards for Leopard

Download PCCard.10.5.2.beta3.mpkg.zip file for easy installation.

 

Always backup your current kexts before replacing them. I have to remind you that, for some machine, this kext file can cause kernel panic. That is why you need to backup your current kexts file so we can revert/restore to working condition. You also need to know your WPC54G hardware's ID. This is the list of hardware's ID that already exist in AppleAirPortBrcm4311.kext file:-

(/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AppleAirPortBrcm4311.kext/Contents/Info.plist)

<array>

<string>pci106b,4e</string>

<string>pci14e4,4311</string>

<string>pci14e4,4312</string>

<string>pci14e4,4313</string>

<string>pci14e4,4318</string>

<string>pci14e4,4319</string>

<string>pci14e4,431a</string>

<string>pci14e4,4320</string>

<string>pci14e4,4324</string>

<string>pci14e4,4325</string>

<string>pci14e4,4328</string>

<string>pci14e4,432b</string>

<string>pci14e4,432c</string>

<string>pci14e4,432d</string>

</array>

You can get your hardware's ID in windows xp or vista. Open "Device Manager", double click your device to see the "Properties". If I'm not mistaken, click on "Details" tab & choose "Hardware ID". There you can see information like this "VEN_14e4\DEV_4306". That mean your hardware's ID, for example, is "pci14e4,4306".

 

Boot with "-f" once to update your kext cache file.

 

Good luck. :P

 

kizwan

Share this post


Link to post
Share on other sites
Guest BuildSmart
I think you have read BuildSmart's post which is not really helpful. He even did not mention the name of the tools that he use to rebrand his card. So, it is totally useless.

 

kizwan

kizwan, is it my fault it is too difficult for you to figure out that only one well-known tool exists to perform the task in linux for Atheros cards?

 

The only tool to do Atheros cards in linux is ath_info and it doesn't take a rocket scientist to figure this out so saying I don't provide enough information is you whining about your lack of ability to understand what I have written.

 

The rebranding task is not for most users because they require specific and detailed instructions and the issue with that is that there are so many of those cards by so many different vendors that someone would have to write literally hundreds of the same guide with minor changes because the person performing the task doesn't know what specific hardware they actually have or the common sense to figure out what ID's they should be rebranding too because not all AR5007EG are equal and want someone to hold their hand while they do it or do it for them.

 

This requires knowledge of your actual card and the chipset contained within, one user already figured out that for his particular card he needed to use 0x1014 because he did some research so for the last few days I've had a barrage of PM's from users who can't read my signature that have either broken their card or rebranded with incorrect information and it doesn't work and no longer works in windows.

 

Bottom line, my post is informational in that it explains the approach to resolving the issue for a wide number of cards and this alone should be enough for you to start figuring out what you need for ID's and the tools to perform the task for Atheros based cards is ath_pci/ath_info which are part of the madwifi tools.

 

If you can't find the tools then you shouldn't be performing the task.

 

If you have some intelligence and are able to figure out what you need to do then in all likely hood you can probably achieve the goal with success but if you are new to linux and Mac OS X then STOP before you break something because once broken you cannot recover easily.

 

If you decide to rebrand and you do something wrong, don't blame me for your mistakes and don't ask me to help you fix your broken card, the card is broken because you did not properly prepare to achieve your goal and fixing it is a very time consuming task that cannot be explained to the point where you can fix it because you have already proven that you couldn't even perform the simple task of rebranding your card properly.

Share this post


Link to post
Share on other sites
kizwan, is it my fault it is too difficult for you to figure out that only one well-known tool exists to perform the task in linux for Atheros cards?

 

The only tool to do Atheros cards in linux is ath_info and it doesn't take a rocket scientist to figure this out so saying I don't provide enough information is you whining about your lack of ability to understand what I have written.

 

The rebranding task is not for most users because they require specific and detailed instructions and the issue with that is that there are so many of those cards by so many different vendors that someone would have to write literally hundreds of the same guide with minor changes because the person performing the task doesn't know what specific hardware they actually have or the common sense to figure out what ID's they should be rebranding too because not all AR5007EG are equal and want someone to hold their hand while they do it or do it for them.

 

This requires knowledge of your actual card and the chipset contained within, one user already figured out that for his particular card he needed to use 0x1014 because he did some research so for the last few days I've had a barrage of PM's from users who can't read my signature that have either broken their card or rebranded with incorrect information and it doesn't work and no longer works in windows.

 

Bottom line, my post is informational in that it explains the approach to resolving the issue for a wide number of cards and this alone should be enough for you to start figuring out what you need for ID's and the tools to perform the task for Atheros based cards is ath_pci/ath_info which are part of the madwifi tools.

 

If you can't find the tools then you shouldn't be performing the task.

 

If you have some intelligence and are able to figure out what you need to do then in all likely hood you can probably achieve the goal with success but if you are new to linux and Mac OS X then STOP before you break something because once broken you cannot recover easily.

 

If you decide to rebrand and you do something wrong, don't blame me for your mistakes and don't ask me to help you fix your broken card, the card is broken because you did not properly prepare to achieve your goal and fixing it is a very time consuming task that cannot be explained to the point where you can fix it because you have already proven that you couldn't even perform the simple task of rebranding your card properly.

 

 

BuildSmart,

If I'm going to figure out by my self, I will not joining this forum. How the hell I'm going to know how you do it or what tools did you use if you always use word like "google", "rebrand", "rocket scientist" or "don't ask me"? If you want to help people, just help. If not, just shut-up.

 

Why it is so wrong to provide people the right direction? All of your post is not very helpful & arrogant. People come here to get help or provide help. With that attitude, you should not be here.

Share this post


Link to post
Share on other sites
Guest BuildSmart
BuildSmart,

If I'm going to figure out by my self, I will not joining this forum. How the hell I'm going to know how you do it or what tools did you use if you always use word like "google", "rebrand", "rocket scientist" or "don't ask me"? If you want to help people, just help. If not, just shut-up.

 

Why it is so wrong to provide people the right direction? All of your post is not very helpful & arrogant. People come here to get help or provide help. With that attitude, you should not be here.

The use of google will help you figure out what ID's you are going to need for your card.

 

Rebranding is what the process is called where you change the subsystem ID's from one vendor to another.

 

You don't have to be a rocket scientist but you do have to think for yourself cause I'm not going to think for you.

 

I help who and when I feel like helping and I answer questions when I feel like answering them, I don't owe you any help, you have not asked any intelligent question that I feel warrant an answer and you call me unhelpful.

 

Generally I help those who are struggling to achieve the goal because they are making some kind of effort, you are making no effort, you want a solution handed to you which requires no intelligence on your part to execute and I can now understand why you need it to be this way.

 

When arrogant people like you screw up rebranding your card because you can't figure anything out on your own you come and {censored} to me or blame me because you don't possess the skills to help yourself and you don't even make the effort to do so.

 

I state to use the linux tools, I state to read up on it and the information I provided has helped many people but a handful {censored} because I do not provide specific details for them to accomplish it, people like you want a GUIDE that has specific instructions for the exact card you have so you can follow them verbatim and have a working solution.

 

What I do not provide is specific details to rebrand one particular card because it would be considered biased to those who have a different card so I explain the process required and leave it up to the user to do some research and figure out what they need to do for their particular card.

 

If you have a specific question then ask your question and if I am inclined to provide you with an answer I will do so but stop your bitching, I don't owe you anything or any information despite what you believe you are entitled too obtain from me.

 

All your bitching has done is made it so that I don't feel like offering any further information or assistance to anyone with this chipset and this is my choice so, if anyone wants to {censored} now, they can {censored} to you for screwing up any chance that I might provide more specific details or information by responding to questions to aid them in resolving their wifi issue with this chipset.

Share this post


Link to post
Share on other sites
The use of google will help you figure out what ID's you are going to need for your card.

 

Rebranding is what the process is called where you change the subsystem ID's from one vendor to another.

 

You don't have to be a rocket scientist but you do have to think for yourself cause I'm not going to think for you.

 

I help who and when I feel like helping and I answer questions when I feel like answering them, I don't owe you any help, you have not asked any intelligent question that I feel warrant an answer and you call me unhelpful.

 

Generally I help those who are struggling to achieve the goal because they are making some kind of effort, you are making no effort, you want a solution handed to you which requires no intelligence on your part to execute and I can now understand why you need it to be this way.

 

When arrogant people like you screw up rebranding your card because you can't figure anything out on your own you come and {censored} to me or blame me because you don't possess the skills to help yourself and you don't even make the effort to do so.

 

I state to use the linux tools, I state to read up on it and the information I provided has helped many people but a handful {censored} because I do not provide specific details for them to accomplish it, people like you want a GUIDE that has specific instructions for the exact card you have so you can follow them verbatim and have a working solution.

 

What I do not provide is specific details to rebrand one particular card because it would be considered biased to those who have a different card so I explain the process required and leave it up to the user to do some research and figure out what they need to do for their particular card.

 

If you have a specific question then ask your question and if I am inclined to provide you with an answer I will do so but stop your bitching, I don't owe you anything or any information despite what you believe you are entitled too obtain from me.

 

All your bitching has done is made it so that I don't feel like offering any further information or assistance to anyone with this chipset and this is my choice so, if anyone wants to {censored} now, they can {censored} to you for screwing up any chance that I might provide more specific details or information by responding to questions to aid them in resolving their wifi issue with this chipset.

 

Obviously you are not intelligent after all. You just like to bitching to any one that you don't like. I don't owe you anything too. So, you can go away. You are not deserve to be here. I know now that you are too stupid that your stupidity blind you to see the bigger picture.

 

You can go away now. :thumbsdown_anim:

Share this post


Link to post
Share on other sites
Hi diogan,

You have different version which is ver. 1.2 & I don't know if it has same chipset (broadcom) or not. From this website, it show that your cardbus use broadcom chipset.

 

You need to replace two kexts file, IOPCIFamily.kext & IOPCCardFamily.kext. You can get this kexts file over here:-

CardBus/PCMCIA PC Cards for Leopard

Download PCCard.10.5.2.beta3.mpkg.zip file for easy installation.

 

I installed it successfully, and my device ID was already in the list. Nothing happens though; in fact there is no information in network preferences at all (LAN is also not working). Hmm... The card doesn't seem like it's getting power or anything... the neither of the LEDs on the top are lit.

 

Oh, I should mention that this is an Acer Aspire 5315 laptop, if that matters.

Share this post


Link to post
Share on other sites
I installed it successfully, and my device ID was already in the list. Nothing happens though; in fact there is no information in network preferences at all (LAN is also not working). Hmm... The card doesn't seem like it's getting power or anything... the neither of the LEDs on the top are lit.

 

Oh, I should mention that this is an Acer Aspire 5315 laptop, if that matters.

 

Hi,

Can you post your dmesg under single user mode. Boot with -s. Ooh yes....can you post at this thread: CardBus/PCMCIA PC Cards for Leopard because it is not related in this thread. Please post your laptop full specification & which OSX release did you installed. Thank you. ;)

 

kizwan

Share this post


Link to post
Share on other sites
Hi,

Can you post your dmesg under single user mode. Boot with -s. Ooh yes....can you post at this thread: CardBus/PCMCIA PC Cards for Leopard because it is not related in this thread. Please post your laptop full specification & which OSX release did you installed. Thank you. :)

 

kizwan

 

My Laptop:

 

Acer Aspire 5315

LAN: Broadcom Netlink Fast Ethernet

WLAN: Atheros AR5007EG

OSX: Leo4All v2, upgraded with JaS 10.5.3 updater.

 

I'll ran dmesg but it didn't find any relevant hardware that I could see. Something about the kernel dependency, a change made to the PCI configuration, and then a little bit about the hard disks I believe.

Share this post


Link to post
Share on other sites
Guest BuildSmart
Obviously you are not intelligent after all. You just like to bitching to any one that you don't like. I don't owe you anything too. So, you can go away. You are not deserve to be here. I know now that you are too stupid that your stupidity blind you to see the bigger picture.

 

You can go away now. ;)

You are the one that is bitching, you are the one that can't figure it out and you are the one who has not asked any intelligent questions.

 

I can go away?

I don't deserve to be here?

I am too stupid?

I don't see the bigger picture?

 

Oh please enlighten me on this bigger picture you speak of

Share this post


Link to post
Share on other sites
The use of google will help you figure out what ID's you are going to need for your card.

 

Rebranding is what the process is called where you change the subsystem ID's from one vendor to another.

 

This is the first time I've tried installing OSx86 on a machine that I didn't build from the ground up for compatibility, so I haven't had to deal with complex hardware issues yet.

 

Have you heard of anyone successfully rebranding an AR5007EG (14E4:1713)? I haven't found anything with that particular card via google, and I am loathe to potentially kill my wireless card by accident (especially since it's the computer my daughter uses for school).

Share this post


Link to post
Share on other sites

I read some dude wanted to rebuild a bios - after changing the osys to get 5007EG working.

 

Yes, phoenix bios editor does allow to compile a new bios image after a change - I did successfully hack my hp dv9850 phoenix bios and put it back together again - successfully..

 

If there is any need for help regarding this - I may be of assistance.

 

change the darn osys value - send me a zip of the files and Ill compile it.

 

 

Also notice: When u decompress the bios with phoenix bios editor there is a temp directory

inside programs phoenix bios editor - here lies all the modules that make up the bios file.

modify the value in the correct file - then compile the bios - easy as hell.

 

I dont exactly remember who wanted to do this - but it was some pages earlier in this thread.

 

I just read all of this {censored} to figure out what to do to my 5007EG - gonna try sum {censored} tonight and see what I come up with.

 

Running osx 10.5.4 on acer aspire one - with all things working except wlan

 

even webcam works nicely in photobooth. no issues

 

regards,

 

aRt

Share this post


Link to post
Share on other sites
I read some dude wanted to rebuild a bios - after changing the osys to get 5007EG working.

 

Yes, phoenix bios editor does allow to compile a new bios image after a change - I did successfully hack my hp dv9850 phoenix bios and put it back together again - successfully..

 

If there is any need for help regarding this - I may be of assistance.

 

change the darn osys value - send me a zip of the files and Ill compile it.

Also notice: When u decompress the bios with phoenix bios editor there is a temp directory

inside programs phoenix bios editor - here lies all the modules that make up the bios file.

modify the value in the correct file - then compile the bios - easy as hell.

 

I dont exactly remember who wanted to do this - but it was some pages earlier in this thread.

 

I just read all of this {censored} to figure out what to do to my 5007EG - gonna try sum {censored} tonight and see what I come up with.

 

Running osx 10.5.4 on acer aspire one - with all things working except wlan

 

even webcam works nicely in photobooth. no issues

 

regards,

 

aRt

 

This sounds promising, although I think most people would be a little nervous about potentially bricking their BIOS. Also, would this affect it in windows? I have an acer aspire 5315 and my daughter uses it for homework (she hates using windows, which is why I put Leopard on it).

Share this post


Link to post
Share on other sites

Hi Presko!

 

Can you help me to apply mad wifi patch?

 

the 5007 is now suported by madwifi i know that im not discovering the hot water or the wheel but may be some of the coders haven`t noticed that:

from the madwifi project :

Atheros AR5007EG

Chipset: AR2425 / AR5007EG

URL: http://atheros.com/pt/AR5007EG.htm

Supports: 802.11b 802.11g

Interface: PCI-Express x1

Device Information: Ethernet controller: Atheros Communications, Inc. Unknown device 001c (rev 01),Subsystem: AMBIT Microsystem Corp. Unknown device 3065

Notes: not supported by HAL as of 2007.04.28 - resturns Hal status 13

Notes: Suported by ndiswrapper with windows driver, but some user reports crash problems

Notes: Instructions about how to use the windows driver + ndiswrapper

Notes: works fine with ndiswrapper, using old drivers, search ubuntu forums

Notes: Sometimes erroneously reported as an AR5006EG by lspci

Notes: Works perfectly with latest madwifi snapshot and this patch --> http://madwifi.org/ticket/1679 <-

Notes: This patch is tested and working on:

Notes: Acer Aspire 5315, Acer Aspire 5613WLMi, Toshiba Satellite A210, LG E500 and more (post your models here)

Notes: How-to compile madwifi and the patch

 

 

I think that now when its suported from the MadWifi someone colud try to think out a solution

Share this post


Link to post
Share on other sites

:censored2:

i had trouble make my card working on linux

the madwifi patch was wery slow and ndiswrapper... well how to tell ... sucks (but worked)

 

then i found that madwifi made a new driver called ath5k who didn't need hal...

and i found a dev version wo worked like hell (on linux off course)

 

 

is it so complicated to convert a linux driver on mac ?!?

Share this post


Link to post
Share on other sites

Instead of bitching around with each other, why don't we be of good help to each other by providing details for our atheros card. there are a lot of people depending on this forum to have their respective cards to work. We need solutions for our atheros cards and no another problem from people whom we thought could hold the solution.

Share this post


Link to post
Share on other sites

I'm stuck with a AR5BMB5 Atheros card... I have little use for osx without this working. I'm happy to commit many hours to this, but I'm not sure what to try anymore. I have installed the 5008 Atheros driver, but doesn't seem to have changed anything.

 

*** Edit ***

I'm not sure why when I re-ran the installer (hence already installed stuff was marked as "upgrade") and selected the 5008 driver it didn't seem to work whereas when I reformatted and reinstalled it did.

 

The following post contains potentially helpful info on this.

Share this post


Link to post
Share on other sites

Okay, that wasn't THAT hard to get working. The jist is I needed to install the Atheros Drivers (5008) from the iATKOS installer.. That got my wireless pretty much entirely working - except that it wouldn't connect to WPA networks.. For that, you can just manually run:

 

networksetup -setairportnetwork "(network ssid)" "(network password)"

 

After that, I wrote a tiny script to auto run the above on boot as I usually will use my laptop at home on the same network. Not sure if I'll have too much pain when I go around.

 

 

Well, I guess I've found "a" solution... I guess this is reasonably graceful all things considered. Related posts below:

 

http://www.insanelymac.com/lofiversion/index.php/t40317.html

 

http://forum.insanelymac.com/index.php?sho...mp;&do=findComment&comment=894948

Share this post


Link to post
Share on other sites
Obviously you are not intelligent after all. You just like to bitching to any one that you don't like. I don't owe you anything too. So, you can go away. You are not deserve to be here. I know now that you are too stupid that your stupidity blind you to see the bigger picture.

 

You can go away now. :shock:

 

Sounds like you're having a nice little temper tantrum over there. Isn't there a minimum age requirement to post on these forums? ha ha ha, I suppose not.

 

I appreciate you're frustrated - this is hard stuff to figure out and I totally feel your pain as I'm a noob with this {censored} too. But freaking out and being overly rude like that doesn't help anyone. BuildSmart was trying to give you the means to solve problems for yourself - if he tried to actually just do the work for you, it'd be a poor use of his time as he wouldn't be able to help as many people! :)

 

Take care Kizwan - I hope you've had more luck getting this going lately.

Share this post


Link to post
Share on other sites
thanx my Atheros 5006eg is working !

 

 

Felipe

 

What did you do?

I've got Atheros 5006EG on my Sattelite m305d with Leo4All v.4 dist but I coudn't activate it

 

 

AirPort in network connections is showed but when I press Turn On AirPort button nothing happens.

Share this post


Link to post
Share on other sites

i'll try this and report if its working THANK THANK U GUYS U DUNNO HOW MUCH I WAS LOOKING FORWARD TO THAT! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×