Jump to content
JSR

Cubase for Mac Os

25 posts in this topic

Recommended Posts

Hi

 

I'm looking for a working Cubase H2O version for Mac os (better is SX3 :D )

Do you know if it exists?

Do you know any other program for mac os like cubase?

 

TNX

Share this post


Link to post
Share on other sites
Advertisement

have you tried logic? i've been using that for about a month now, switched from cubase and had no problems. but if you're looking for free i don't think you're gonna be able to get the pro version. not 100% on that though. hope this helps.

Share this post


Link to post
Share on other sites

Well... as for H2O and a recent version of Cubase on OSX, I suppose you shouldn't hold your breath, mate. According to the nfo on their last SX for Win, SX3 took them thousands of hours and they stated it would be their last release.

 

I'm an old Cubaser (since 1990) and I currently run CB4 (legit of course :thumbsup_anim:) on a hack and a MacBook. I can also run SX3 with the same dongle.

 

As I don't have the time, the patience and the geekdom to take all the Windows hassles I'm quite happy with this OSX setup, even if there are more AU plugins than VST that work properly. Anyway, it was the most rewarding $800 I ever spent on software so far.

 

Logic Express is...errr... okay... but Cubase leaves it far behind in many fields. Not a fair comparison anyway.

I can't speak for Logic Pro but I reckon it's a bit pricey for what the specs have to offer.

Share this post


Link to post
Share on other sites
Hi

 

I'm looking for a working Cubase H2O version for Mac os (better is SX3 :unsure: )

Do you know if it exists?

Do you know any other program for mac os like cubase?

 

TNX

 

I have made install of Steinberg Cubase SX v3.1.1.944 via Crossover 7.1.0, full working with SyncroSoft Emu.

If anyone want I can explain more how to do it.

Share this post


Link to post
Share on other sites

Yep, I'd like to hear the whole story! :)

It would help someone who'll be having the same question later! :unsure:

Share this post


Link to post
Share on other sites
Yep, I'd like to hear the whole story! :)

It would help someone who'll be having the same question later! ;)

 

Yes, I too would love to hear the details of Cubase SX3 running under Crossover. Do you get acceptable performance? Were there any tricky bits to the install?

Share this post


Link to post
Share on other sites

First of all I have iATKOS 10.5.5 upgraded to 10.5.6

Also have Crossover 7.1 (7.1.0) runing.

I made this success because I have problem with VISTA also with Syncro driver, so I found way.

Download Steinberg.Cubase.SX.v3.1.1.944-H2O (VISTA 64bit FIXED) torrent.

There are two folders Steinberg.Cubase.SX.v3.1.1.944-H2O and CUBASE SX3 VISTA64BIT FIX.

First run setup.exe from Steinberg.Cubase.SX.v3.1.1.944-H2O with Crossover installer

Installation of Syncro will fail, but contionue with installation of Cubase.

After it's done go to MANAGE BOTTLES in Crossover, select bottle where you have install Cubase, go on "Advance" tab and click OPEN C: DRIVE IN FINDER.

Go to Program Files > Syncrosoft > POS > H2O , copy the "cledx.sys" and "oem736.inf" from "Syncro TruEmu Team H2O" there.

Than go back to C: root , and go windows > system32 and copy "synsoacc.dll" from "UnSyncrosoft" there.

 

That is all, it work fine for me, I hope it will work for you all.

 

:(:D:D:D:D:D:D:D:D

Share this post


Link to post
Share on other sites
First of all I have iATKOS 10.5.5 upgraded to 10.5.6

Also have Crossover 7.1 (7.1.0) runing.

I made this success because I have problem with VISTA also with Syncro driver, so I found way.

Download Steinberg.Cubase.SX.v3.1.1.944-H2O (VISTA 64bit FIXED) torrent.

There are two folders Steinberg.Cubase.SX.v3.1.1.944-H2O and CUBASE SX3 VISTA64BIT FIX.

First run setup.exe from Steinberg.Cubase.SX.v3.1.1.944-H2O with Crossover installer

Installation of Syncro will fail, but contionue with installation of Cubase.

After it's done go to MANAGE BOTTLES in Crossover, select bottle where you have install Cubase, go on "Advance" tab and click OPEN C: DRIVE IN FINDER.

Go to Program Files > Syncrosoft > POS > H2O , copy the "cledx.sys" and "oem736.inf" from "Syncro TruEmu Team H2O" there.

Than go back to C: root , and go windows > system32 and copy "synsoacc.dll" from "UnSyncrosoft" there.

 

That is all, it work fine for me, I hope it will work for you all.

 

:wacko::(:D:D:D:D:D:D:D

 

Thanks for this info. Following your instructions I also got Cubase to run but the latency using the coreAudio of my MacBook Pro makes it impossible to record and ridiculously tedious to even edit. I've been looking into wine ASIO options which have helped some but latency is still a major issue. I think in the end I'll just spend the money on Cubase 5 once the first few rounds of updates are done. <sigh>

Share this post


Link to post
Share on other sites
Thanks for this info. Following your instructions I also got Cubase to run but the latency using the coreAudio of my MacBook Pro makes it impossible to record and ridiculously tedious to even edit. I've been looking into wine ASIO options which have helped some but latency is still a major issue. I think in the end I'll just spend the money on Cubase 5 once the first few rounds of updates are done. <sigh>

 

I have onboard audio on asus p5k-e, it had big latency on start when but when I change buffer size (devices> device setup> asio multimedia driver> control panel> advanced options) to "512" it is much better to work.

:(

Share this post


Link to post
Share on other sites

SWEET !!

 

Going to try with Nuendo and report back...

 

Now, if I were able to get some plugs I cant live without, it would mean the absolute end of Windcrapows for me...

 

Is there a way to get PC vst's onto Mac ?

Share this post


Link to post
Share on other sites

Using Nuendo #3.02.623

 

So far so good, except;

 

I do not have a folder called "Syncro TruEmu Team H2O" ... in;

 

Applications - Crossover - SyncrosoftEmu (all it has inside is) = Readme + Syncro TruEmu Team H20.exe

 

I have the files you mention in both Program Files > Syncrosoft > POS > H2O and windows > system32;

 

but I do NOT have the destination folders called "UnSyncrosoft" and "Syncro TruEmu Team H2O"

 

Am I missing something here? If its the other way around, I already have the files in the correct place, but when trying to launch, the protection gives error and quits program.

 

Could you give me a hand? I am SOOOO hoping to getting this up and running...

 

Could you zip up and post these files so I can try and copy over the ones I have?

 

Thanks a gzillion!!! :(

Share this post


Link to post
Share on other sites

No... for that I've my studio...

 

But for my own late night compo's and fun, I'd really love NOT to have to reboot into xp.

 

Plus, 'tis the fun of conquering the untamed territory that makes want to try... great learning experience.

 

Furthermore, what dictates latency is the audio driver, for that I've got my FF800 which is superb! Give me a couple of instruments and I am go...

 

And PT8 runs like a charm, and I am giving it a go, now that midi seems to rock...

 

Someone once said to me ... "You do not seriously expect a PC to run OSx like a Mac, do you?"

Share this post


Link to post
Share on other sites
Using Nuendo #3.02.623

 

So far so good, except;

 

I do not have a folder called "Syncro TruEmu Team H2O" ... in;

 

Applications - Crossover - SyncrosoftEmu (all it has inside is) = Readme + Syncro TruEmu Team H20.exe

 

I have the files you mention in both Program Files > Syncrosoft > POS > H2O and windows > system32;

 

but I do NOT have the destination folders called "UnSyncrosoft" and "Syncro TruEmu Team H2O"

 

Am I missing something here? If its the other way around, I already have the files in the correct place, but when trying to launch, the protection gives error and quits program.

 

Could you give me a hand? I am SOOOO hoping to getting this up and running...

 

Could you zip up and post these files so I can try and copy over the ones I have?

 

Thanks a gzillion!!! :wub:

 

I will download Nuendo 3.02.623 and see what I can do, give me some time please :D

Share this post


Link to post
Share on other sites
Marcetin ... :D

 

:D

 

YOU ROCK !!! :)

 

That is so cool of you!

 

Thanks !

 

 

Ok cool thanks... I just made it... after few hours of trying.. and few instalation I made it... but ... one problem is I dont know how.. hahahahahhahahahahahahhaa... I must write this .. becouse it happend just one minute ago :D:D:D:D:D:D:D:D:D....

I am laughing at myself!!!! :D:D:D:D:D:D

Dont wory.. give me some more time... ;)

 

Ok cool thanks... I just made it... after few hours of trying.. and few instalation I made it... but ... one problem is I dont know how.. hahahahahhahahahahahahhaa... I must write this .. becouse it happend just one minute ago :D :D:D:D:D:D:D:D:D....

I am laughing at myself!!!! :D :D:D:D:D:D

Dont wory.. give me some more time... ;)

 

Hey hey hey!!!!

 

I just realise how i made it..

First download Steinberg.Nuendo.v3.2-H2O

http://www.demonoid.com/files/details/1024570/3650843/

 

Start install but be sure to do it in new Crossover's "Bottle", call it "Nuendo" ;)

 

Install will fail part with Syncro but all will go well till end as it was for Cubase SX3

 

Now open "Nuendo" bottle and use files from Cubase SX3 install, do as you do fro Cubase:

click OPEN C: DRIVE IN FINDER.

Go to Program Files > Syncrosoft > POS > H2O , copy the "cledx.sys" and "oem736.inf" from "Syncro TruEmu Team H2O" there.

Than go back to C: root , and go windows > system32 and copy "synsoacc.dll" from "UnSyncrosoft" there.

 

It is just that easy!!!!!

 

I lose few hours trying some other stuff but this work on first for me!!!!

 

:D:D:D:D:D:D:D:D:D:D:D:D:D

 

ALL BEST!!!!!!!

Share this post


Link to post
Share on other sites

Hey!!

 

Ok, so I have to download Cubase SX and install first...

 

Off to the demon, here I go...

 

UPDATE:

 

Marcetin... I dont get it... I downloaded Cubase, exact version you have. Installed it, syncrosoft install fails. Files are created, everything seems ok.

 

Its this part I dont get !

 

"Go to Program Files > Syncrosoft > POS > H2O , copy the "cledx.sys" and "oem736.inf" from "Syncro TruEmu Team H2O" there.

Than go back to C: root , and go windows > system32 and copy "synsoacc.dll" from "UnSyncrosoft" there."

 

I dont have any folders called "Syncro TruEmu Team H20" nor "Unsyncrosoft" - where are they?

 

Could you please zip these files and post them here?

Share this post


Link to post
Share on other sites
Hey!!

 

Ok, so I have to download Cubase SX and install first...

 

Off to the demon, here I go...

 

UPDATE:

 

Marcetin... I dont get it... I downloaded Cubase, exact version you have. Installed it, syncrosoft install fails. Files are created, everything seems ok.

 

Its this part I dont get !

 

"Go to Program Files > Syncrosoft > POS > H2O , copy the "cledx.sys" and "oem736.inf" from "Syncro TruEmu Team H2O" there.

Than go back to C: root , and go windows > system32 and copy "synsoacc.dll" from "UnSyncrosoft" there."

 

I dont have any folders called "Syncro TruEmu Team H20" nor "Unsyncrosoft" - where are they?

 

Could you please zip these files and post them here?

 

 

That are files from Cubase SX 3 install folder that I earlyer explain how to do it, but ok here they are:

CUBASE_SX3_VISTA64BIT_FIX.zip

Share this post


Link to post
Share on other sites

:thumbsup_anim:

 

Bingo ! It worked like a charm!

 

Thanks!

 

Now, for the second challenge... how to get Nundo/Cubase to grab your audiocard?

 

I kind of didi it but I'm running further tests. First set up my Fireface 800 as system's audio device in prefernces, because

in Nuendo it only seems to find the ASIO drivers. But when I try to touch the settings it's been crashing...

 

Appart from that, its all there, plugins and all.

Share this post


Link to post
Share on other sites
you cannot be serious about audio production running cubase on a virtualization layer.... ;)
True that, imo.

Share this post


Link to post
Share on other sites

This "fix" is not stable. In fact it is a useless workaround.

 

Try loading a previous project and watch the system crash. Try changing asio setting and watch it crash.

 

derr.......

 

Let me know if you have been usuing this flawlessly for more than 5 mins!

 

Stick with verison 2 IMO

 

Cheers,

 

HC

 

ps i am a legit cubase 4 user

Share this post


Link to post
Share on other sites

Running Cubase on OSX with Crossover it's like driving a Porsche with Vespa engine in a forest.

Share this post


Link to post
Share on other sites
Running Cubase on OSX with Crossover it's like driving a Porsche with Vespa engine in a forest.

 

I know this post is a bit old but has anybody tried running nuendo 4 or cubase 5 via crossover 9 on mac?

 

Regards,

Ashish

Share this post


Link to post
Share on other sites
I know this post is a bit old but has anybody tried running nuendo 4 or cubase 5 via crossover 9 on mac?

 

Regards,

Ashish

 

 

everybody wants to have a mac to run logic...

 

anyway you can install windows on mac then use cubase 5.1.2 but that is stupid in my opinion.

 

or you can use the "Steinberg Cubase AI v4.5.2.274 UB" its a light dongle free version that comes with yamaha products

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×