Jump to content
InsanelyMac Forum
jcruzlara

iTunes Error (-50) when trying up authorize

Recommended Posts

I've tried reinstalling iTunes, deleting the iTunes the folder in Music, signing in and out on the store, different user and nothing works, I've also upgraded to 7.3 but no go. iTunes doesn't let me authorize my computer, I already authorized my laptop running windows and iTunes 7.3 to see if it was an Apple store problem but the laptop got authorized just fine. I'm getting really extremely mad at it and I've even thought of installing windows on it. Has anyone else run into this problem? Please help! none of my purchased music synchronizes to my iPod.

post-7931-1183340799_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

I am having the exact same problem. What version of OS X are you running? This problem began for me after I attempted an upgrade to 10.4.10.

Share this post


Link to post
Share on other sites

I have 10.4.9, I used the uphuck dvd. I haven't tried to upgrade to 10.4.10, I had 10.4.8 before, and iTunes worked great on that. I've also noticed that for some reason the system all of a sudden slows down and all the programs stop responding.

Share this post


Link to post
Share on other sites

I had this problem after installing Forcedeth.kext for ethernet. I had to go to /Library/Preferences/SystemConfiguration and open up NetworkInterfaces.plist. Change it so that your ethernet is en0 and your airport wireless is en1. Save it and reboot. See if that fixes the problem. :hysterical:

 

If that doesn't work, just delete NetworkInterfaces.plist and reboot. After you reboot, go to the Network pane in System Preferences and it will say it found a new network interface. Click apply and wait a few seconds. You should be good to go. :)

Share this post


Link to post
Share on other sites

That worked!!!!!!!!!! :lol: It was a bit tricky, it kept setting itself back to en2 but I figured it out you're supposed to change IOInterfaceUnit as well not just the part that saiys en0. Thanks a lot.

Share this post


Link to post
Share on other sites

Hello,

 

I'm having exactly the same issues, but I don't really know what I'm supposed to change after opening the plist up... I'm using a broadcom gigabit ethernet card on my pci bus for my connection and I have no idea what to change... It was working up until recently, seemed to go titsup when I upgraded iTunes :-(

 

any ideas...

 

thanks

 

Rick

Share this post


Link to post
Share on other sites

I had the same problem, made a backup of my plist file and changed the Physical NIC to en0 and the wireless to en1 and Itunes authorized my machine perfectly...

 

Just thought I'd let people know if they have the issue after upgrading to itunes 7+

Share this post


Link to post
Share on other sites

this is still the awesome tip of the day!~

Fixed my Can't authorise apps for iphone problem, theres a list of unsolved problems on the apple forums on this very subject…

Kenny

Share this post


Link to post
Share on other sites
I had this problem after installing Forcedeth.kext for ethernet. I had to go to /Library/Preferences/SystemConfiguration and open up NetworkInterfaces.plist. Change it so that your ethernet is en0 and your airport wireless is en1. Save it and reboot. See if that fixes the problem. :D

 

If that doesn't work, just delete NetworkInterfaces.plist and reboot. After you reboot, go to the Network pane in System Preferences and it will say it found a new network interface. Click apply and wait a few seconds. You should be good to go. ;)

 

Thanks!

Share this post


Link to post
Share on other sites
I had this problem after installing Forcedeth.kext for ethernet. I had to go to /Library/Preferences/SystemConfiguration and open up NetworkInterfaces.plist. Change it so that your ethernet is en0 and your airport wireless is en1. Save it and reboot. See if that fixes the problem. :D

 

If that doesn't work, just delete NetworkInterfaces.plist and reboot. After you reboot, go to the Network pane in System Preferences and it will say it found a new network interface. Click apply and wait a few seconds. You should be good to go. :)

 

This totally worked, it also fixed my Time machine.

 

Thanks so much...

Share this post


Link to post
Share on other sites

This was huge!

 

I kept getting prompted to authorize when trying to sync. The Error (-50) when I tried to authorize. I had recently updated the bios and done a bunch of fiddling with my USB wifi dongle. Removing the NetworkInterfaces.plist solved it for me. Thank you!

Share this post


Link to post
Share on other sites
I had this problem after installing Forcedeth.kext for ethernet. I had to go to /Library/Preferences/SystemConfiguration and open up NetworkInterfaces.plist. Change it so that your ethernet is en0 and your airport wireless is en1. Save it and reboot. See if that fixes the problem. :D

 

If that doesn't work, just delete NetworkInterfaces.plist and reboot. After you reboot, go to the Network pane in System Preferences and it will say it found a new network interface. Click apply and wait a few seconds. You should be good to go. :)

 

Great Answer !!!! I had this problem after upgrading my motherboard and RealtekR1000 kext. Deleting the .plist worked for me.

Share this post


Link to post
Share on other sites
I had this problem after installing Forcedeth.kext for ethernet. I had to go to /Library/Preferences/SystemConfiguration and open up NetworkInterfaces.plist. Change it so that your ethernet is en0 and your airport wireless is en1. Save it and reboot. See if that fixes the problem. ;)

 

If that doesn't work, just delete NetworkInterfaces.plist and reboot. After you reboot, go to the Network pane in System Preferences and it will say it found a new network interface. Click apply and wait a few seconds. You should be good to go. :D

 

 

 

Thank You sooo much! easy as pie for a fix thats been driving me nuts for so long!

Share this post


Link to post
Share on other sites
I had this problem after installing Forcedeth.kext for ethernet. I had to go to /Library/Preferences/SystemConfiguration and open up NetworkInterfaces.plist. Change it so that your ethernet is en0 and your airport wireless is en1. Save it and reboot. See if that fixes the problem. :(

 

If that doesn't work, just delete NetworkInterfaces.plist and reboot. After you reboot, go to the Network pane in System Preferences and it will say it found a new network interface. Click apply and wait a few seconds. You should be good to go. :(

 

 

Bumping this as it solved the problem for me too, I deleted the NetworkInterfaces.plist as I had old Bluetooth and other entries causing problems, deleted rebooted and Boom! as SJs would say.

 

Why this isn't even suggested on the Apple site I have no idea. :)

Share this post


Link to post
Share on other sites

Is this alright ??? :wacko:

 




Interfaces


		BSD Name
		en0
		IOBuiltin

		IOInterfaceType
		6
		IOInterfaceUnit
		0
		IOMACAddress

		AFD8qHM4

		IOPathMatch
		IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/P0P1@1E/IOPCI2PCIBridge/ethernet@2/com_apple_driver_RTL8139/IOEthernetInterface
		SCNetworkInterfaceType
		Ethernet


		BSD Name
		en1
		IOBuiltin

		IOInterfaceType
		6
		IOInterfaceUnit
		1
		IOMACAddress

		ABxCAAAI

		IOPathMatch
		IOService:/IOResources/com_parallels_kext_prl_vnic_bus/com_parallels_kext_prl_vnic_device_nub_0/com_parallels_kext_prl_vnic_device_0/com_parallels_kext_prl_vnic_device_interface
		SCNetworkInterfaceType
		Ethernet


		BSD Name
		en2
		IOBuiltin

		IOInterfaceType
		6
		IOInterfaceUnit
		2
		IOMACAddress

		ABxCAAAJ

		IOPathMatch
		IOService:/IOResources/com_parallels_kext_prl_vnic_bus/com_parallels_kext_prl_vnic_device_nub_1/com_parallels_kext_prl_vnic_device_1/com_parallels_kext_prl_vnic_device_interface
		SCNetworkInterfaceType
		Ethernet


		Active

		BSD Name
		en3
		IOBuiltin

		IOInterfaceType
		6
		IOInterfaceUnit
		3
		IOMACAddress

		AB/GOE8H

		IOPathMatch
		IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/P0P9@1C,5/IOPCI2PCIBridge/ethernet@0/yukonosx/IOEthernetInterface
		SCNetworkInterfaceType
		Ethernet




 

Getting the same itunes error on my hack - though no problems on an XP laptop.

 

...never mind :P ...just deleted the /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist and able to sync my ipod, download purchases from the store etc... /

Thanks for the tips!

Edited by starship-Insanity

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×