Jump to content

Messed up my partition table.


5 posts in this topic

Recommended Posts

I've first installed WinXP on my first partition and the MacOSX on my second partition planning to use the "F8" key for dual-booting.

Working very well.

Fell in Love with MacOSX and tried to boot my winxp partition in Parallels, but no success.

Installed a new WinXP on a viritual disk in Parallels and found that WinXP is {censored} and that i Want MacOSX all the way.


Rebooted my computer with macosx installdisk, entered diskutil and formatted my winxp-partition.

System says: ....something....boot.plist is missing, I pressed F8 and managed to boot up my OSX partition.


Started Fdisk and made my osx-partition active and rewrote the mbr.


Error-text is gone, but system does not boot at all. (Just a "_" blinking in the corner)


Booted with my install-cd and hammered on my F8 key, managed to boot my computer into macosx.


What should i do to make my computer to boot normally without my install-cd?

Link to comment
Share on other sites

Get a partition manager and make sure that partition on that HDD that OSx86 is installed is set to bootable. All that blinking line means is that your BIOS cannot find a bootable operating system and is searching your cd drive/network for what the hell to do.


Maybe this will help.

Link to comment
Share on other sites

Ok i got an idea, I just took a class about Operating Systems in general and I remember something about the architecture of a hard disk and how it works with an Operating System. There are a set of files or minifiles or firmware or something stupid at the beginning of a hard disk that tells the computer what to look for in the sense of an operating system.


It sounds like you over wrote that, but I maybe wrong and I did not pay attention to closely in that class anyways (it was an easy A, thats all I cared about).


If I was you I would try this:


Boot into your OSx86 using your install DVD and downloaded Carbon Copy Cloner.


Completely Clone your system to another HDD, and wipe the original HDD Clean.


You can then boot into your OSx86 on the other HDD and use it from there, and then if you wanted too, you could clone it back with Carbon Copy Cloner to the original HDD.


That may fix the problem.

Link to comment
Share on other sites

ok... i've solved it....


I used the Carbon Copy Cloner to clone my install-partition to the other empty partition.

rebooted the computer and booted my machine with the bootcd.

Started terminal, made my first partition bootable with fdisk, rewrote the mbr.

Then I started the installprocess as usual, but WITHOUT formatting the destination partition (I've kept a copy of my installation there).


The installation installed everything from scratch, but kept all my installed programs and configurations. I had only to tell what keyboard I'm using, country etc. etc. the usual stuff.

Then I'm in and everything is back to normal =)


I'll might do an image of my install to have something to backup from :thumbsdown_anim:

Link to comment
Share on other sites


  • Create New...