Jump to content

How to Quint Boot?

12 posts in this topic

Recommended Posts

Hi everybody,


I want to quint boot Vista, Server 2003 (XP-like), OSX, Kubuntu, and Gentoo. System specs are in my sig. I would like to use GRUB as my bootloader, and load Gentoo last, as it will be the platform I learn Linux on. (I figure it has extensive documentation and it requires lots of configuration, so its a good learning OS.) I've been searching around on this forum for guides on how to quint boot, but I was unable to find anything. I found some quad boot, so I'll probably follow those.


Here is how much space on a 150 gb WD Raptor hard drive that I will be allocating to each OS:

Vista - 45 gb

Server 2003 - 30 gb

OSX (JaS 10.4.8) - 20 gb

Kubuntu - 15 gb - 2gb swap, 13 for Kubuntu

Gentoo - 40 gb - 2gb swap, 38 for the rest

(note these are in gb and not GiB, I'll do the conversions on install)


I would like to allocate more to Vista and Gentoo, so any suggestions on how I can do the division is appreciated. How those commenting on how I will swap files, NTFS 3g has been moving along quite nicely and i have the other 7 hard drives, one of which is fat32 to move stuff around.


I will be disconnecting my other hard drives for the time being to avoid any accidental overwriting. I will also disconnect the Hauppage WinTV 1600 card.


From my reading, it seems the general order is this:

1. Gparted create: 2 NTFS primary partition (for Vista and Server 2003), 1 Fat32 primary (for osx), 1 extended partition with 2 logical partions of ext3 (i think, linux noob here)

2. Install Server 2003

3. Gparted hide Server 2003 partition, set as boot to Vista partition

3. Install Vista

4. Gparted, unhide Server 2003, unboot Vista

5. OSX

6. Kubuntu

7. Configure GRUB


I plan to install Gentoo at a much later date, one to two months when I have time to learn how to configure and compile it properly.


Can anybody point me towards a guide for quint boot, or perhaps offer any tips?


Right now I am looking at these two guides: http://wiki.osx86project.org/wiki/index.php/Quad_booting and http://forum.insanelymac.com/index.php?showtopic=49318

Link to comment
Share on other sites

Looks ok.


Problems in multi-boot can come from various sources:

  • Multi-windows: it's important to hide previous windows installs when installing a next (winnt-like) one, otherwise the boot files will go in the previous active partition. I see you've already seen to that detail, good.
  • With osx/vista there's the problem where vista messes with the mbr, of course... see devilhood's thread , that might help.
  • With a drive with already existing OSes, one might tend to install osx on a partition after the extended, or in a logical partition. But I see again you've done your work and planned it the right way.

Apart from the above, once the osx/vista problem is fixed (if need be), the rest of the (Linux) installations will go along well, in any number of installs, and GRUB is quite adequate to the task for quad, quint, hexaboot (?), etc.


Here's a guy with more than 100 boot items with GRUB:

A grub menu booting 100+ systems of Dos, Windows, Linux, BSD and Solaris

Link to comment
Share on other sites

Seems to me that the 100+ guy uses grub in a separate partition, while both of the quad-boot guides I mentioned use the bootloader of whatever OS they installed last. Which method is better (will generate a greater chance of success)?


If I go with the separate partition, does grub want to be in a primary or logical partition? If it is primary, then it would seem I am out of primary partitions (from what I've read, max you can have on one hdd is 3 primary + 1extended, or 4 primary)

Link to comment
Share on other sites

The link to the guy with 100+ items in grub was only to put a smile... he had to work a lot to resolve problems.


The first stage of grub is taking charge of the mbr. The rest can go elsewhere. See quick explanation.


But yes, only 4 primary partitions on a disk (MBR type), and one of them can be of a special type, "Extended" (which can't be made active), which can contain many "logical" partitions. The linux distros can easily go in logicals.

But if you have other drives, of course why not use them: the closer to the beginning of the drive, the faster the access time for the os'es.

Keep your Windows' in the master drive though; otherwise, you'd have to use mapping in the grub menu.lst to simulate secondary drives as being first drive.


[uncertain portion edited out]


Anyway... since you only plan to use grub/linux in the end (which is ok), your real problem (if any) is with the first big three, vista/w2k3/osx, in their own primary partitions. If you finish with osx, and you don't get the hfs+ error problem (or you solve it with one of the guides here at InsMac), you'll be booting all three with darwin's bootloader. Once you've checked that all three boot/work ok, the next step with kubuntu shouldn't be a problem. The only real problem here is with vista, which was a bit more problematic than win2k/xp after an osx install.

Gentoo later could go on another drive, or another logical partition.

Do note that (if I'm not mistaken) Gentoo can use the same swap as Kubuntu.

Link to comment
Share on other sites

Installed 2k3, Vista without any issues, then got to the Mac OS X (JaS) install, and got a "Still waiting for root device" error. Seems the issue is my WD Raptor SATA drive and my SATA DVDROM, combined with my nforce650i based motherboard.


I saw that some people had success installing using the Tubgirl iso and the "VMWare method", but I'm not sure how this works. VMWare is a emulation thing inside a currently running OS, so how can I move the VMWare image to something outside the OS?


I also suppose a second IDE drive might work, but I'm out of IDE slots so I want to avoid that. If I get another drive, I'll need another PCI controller card for IDE, and I'm not sure how that works out with OSX86. I also read that a SATA controller works, so If I need to get another drive, I'll pick up the working SATA controller.


Also I've heard of people adding the device id to some kext file... what is this? It seems that it is something you do after the OSX install. Is there anyway I can access it before the install?



I'm thinking of just getting another IDE drive (my current IDE drives are full), sticking the new drive onto Primary Master, and putting the drive it displaces onto a controller card which has been known to work with OSX (according to this thread), the BYTECC BT-PESAPA


What I need to know now is if my SATA DVD drive is also playing a role in this.

Link to comment
Share on other sites

I got my PATA stuff. I'm using [JaS 10.4.8 AMD-Intel-SSE2-SSE3 with PPF1 & PPF2.iso + JaS.10.4.9.Combo.Update.Intel.SSE3.zip] from the green demon.


The installer GUI booted properly. I did the Disk Utility thing, and then installed. The computer restarted, so I removed the DVD from the drive and allowed the computer to boot. Upon boot, a Apple logo shows, and this thing under it churns for a minute or two. Then I hit a Kernel Panic.


I'm not sure on how to get more information about this Kernel Panic, if anybody could tell me that would be great and I think it would aid with debugging.



F8 saves the day. Anyways, booted up in -v mode, lots of scrolling text until the boot hangs at this message:


Jun 15 16:47:28 localhost /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow: Login Window Application Started
Link to comment
Share on other sites

I didn't use much the JaS release, so others should come in to help, or you could search "Login Window Application Started" (with the quotes) with the search engine (or google on insanelymac domain).

For example, one of the search led to this thread: LoginWindow doesn't start...


So at first look it might be some problem with one of the selection (driver/kext) you chose when you picked out which package to install, here the graphics card package... But it could be something else too.


So, to get help from people with knowledge about the JaS version, it would be good for you to post what packages you have selected in the customized install: any ati/nvidia graphics package? etc...

That way they could pinpoint which one could be causing a conflict/bug/whatever.

Link to comment
Share on other sites

After looking through the forums on the issue, seems it could be solved by moving the GeForce.kext to another directory to "disable" it. I did that, then hit a ACPI error which resulted in a panic. Disabling ACPI in bios did not help. Looking through forums, I found that uphuck's 1.3 release had a kext that could disable all the ACPI functions, so I downloaded that and installed, disabling the ACPI functions. That worked, and then I got a kernel panic after mDNSResponder starting. Then I disabled my LAN controller through BIOS, it got past the mDNSResponder stuff, and got another error:


-1) Cannot use ATS Persistent Store - switching to old FODB cache code


Any ideas? (Then I reenabled the LAN, and I get past the mDNSResponder stuff, and get the above error.)




Used the following Install options:

10.4.9 Intel

Kernel--Intel SSE3 -2



Patches--Remove CPUPowerManagement kext

Patches--Remove Thermal kexts

Patches--Verbose Mode

Drivers--VGA Drivers--nVidia--Natit 0.1

Drivers--VGA Drivers--nVidia--Natit 0.2

Drivers--VGA Drivers--nVidia--Titan


Drivers--nForce SATA


Drivers--Azalia Audio


Thanks in advance.



After I restart a couple times, I get a couple different error messages:

-1) Cannot use ATS Persistent Store - switching to old FODB cache code

then hangs

Login Window Application Started

then hangs

kextd[25]: 0 cached, 371 uncached personalities to catalog

then panics with

panic(cpu 0 caller 0x00134ED7): clear_wait_internal: deadlock: thread=0x330d900, wq=0x4c0a50, cpu=0

and a ton of debugger stuff

Link to comment
Share on other sites

Select only one among natit 0.1, 0.2 and titan; or not at all if you want to explore if they cause a problem (it can be installed later).

It may not be the cause of your problem, but at least it's something to avoid (chosing all 3) if there's a next time.


Beyond that, can't help much more, sorry.


Except maybe a suggestion: this is obviously, as it is now, purely an OSX-related problem, but the title of your thread still is about quint-boot, which may not attract much help. So maybe it would be better to seek help in a new thread, with new appropriate title, to tackle this particular problem, giving anew the particular details you gave here about your OSX install. You might get more help.


The OSX Installation subforum would be a good place.

Link to comment
Share on other sites


  • Create New...