Jump to content

Dual booting XP/OSX using NT bootloader thru VMWare

8 posts in this topic

Recommended Posts



I have a ThinkPad R60 laptop: Intel Centrino Duo T2400 @ 1.83 GHz (SSE3 :)); 768 MB DDR2 RAM; Intel 945GM (950) integrated :boxing: graphics chipset; 60 GB SATA HDD. (If any other specs are need, just ask.) Using a 10.4.8 image with PPF1 and PPF2 applied (pre-patched), and has the custom files for AMD, etc. (which I don't need).


It has a BIOS password so I can't enable booting from anything other than the HD. So, it can ONLY boot from hard drive, and I can't install other operating systems by booting from them directly. I have sucessfully installed Ubuntu using Wubi (http://www.cutlersoftware.com/ubuntusetup/wubi/en-US/index.html) which shows up in the NT (Windows) bootloader (through an entry in boot.ini).


I have successfully run OSx86 in a VMWare virtual machine. Now, I was wondering if it was possible to use the chain0 method that I have read about to add either the virtual disk file or a separate logical or primary partition to boot.ini. I have tried using a separate primary partition (8 GB, created with no File System using Acronis Disk Director Suite) in VMWare, but the Disk Utility will not allow me to partition it with HFS+, which I understand chain0 needs to find. The drive is greyed out, and clicking on it does not reveal a Partition tab. It is independent and persistent in VMWare settings. I have posted a screen shot:




I basically want to have an entry "Mac OS x86" using chain0 (or another method) in my boot.ini that I can run to boot into OS X.


Thanks for taking the time to read my post. Apologies if it was too long. If you need any other details please tell me. Any help or tips would be greatly appreciated. Thanks :)


Some pages I have referred to so far:





Link to comment
Share on other sites

OK, I seem to have made a little progress. Using the information in http://forum.insanelymac.com/index.php?showtopic=9260 I have managed to convince ^_^ OS X installer to use my 8GB partition (Primary) to install OS X 10.4.8. It is now installing, but I might need help with chain0 and getting it to boot with the Windows boot loader (or maybe I can use Acronis OS Selector).


Any comments or tips?

Link to comment
Share on other sites

OK, now I have a problem :(. The install completed, asked to restart, so I did, and now VMWare is showing it hanging on the grey (gray) screen with the darker grey Apple logo... anybody know what's wrong?



OK, I should just read more before I post. Comment 41 at http://wiki.osx86project.org/wiki/index.php/Vmware_how_to helped me out (although that's pretty random... these guides really need organization). Now it has a loading thing... I anticipate more problems, and still don't know how to boot it from the boot loader... so any help would be appreciated.


Thanks :)



Also, I tried (using MacDrive) copying chain0 from the OS X install disc (JaS 10.4.8 AMD/Intel PPF1 & PPF2) to C:, and added in boot.ini: C:\chain0="Mac OS x86". However, when I select Mac OS x86 in the boot menu, it simply flashes and returns to the boot menu. Please help. Thanks.


[still need chain0 help]

Edited by mujahid7ia
Link to comment
Share on other sites

I think I may have found the problem. The page on the OSx86 wiki about chain0 said:


Additional experiences:


If it's still not working, make sure your Mac OS X partition (af) is not UNDER an extended partition. It also has to be a PRIMARY partition. While chain0's source code indicates support for extended/logical partitions, experiences obviously show a different picture.


You can verify this by booting a Linux LiveCD and typing "sudo fdisk /dev/hda" or this sequence in Windows XP's shell:


select disk 0

list partition


Acronis Disk Director Suite tells me that the partition is primary. Partition Magic says the same thing. However, look at the diskpart results:


DISKPART> list partition

 Partition ###  Type              Size     Offset
 -------------  ----------------  -------  -------
 Partition 1    Primary             48 GB    32 KB
 Partition 2    Unknown              8 GB    48 GB


Any ideas???

Link to comment
Share on other sites

lol, yeah


I actually tried that and it worked... should have updated the thread.


Anyway, I also have ethernet and audio working as well. Still no wireless, but it's Intel 3945ABG so I'm not too hopeful. Thanks for the advice :pirate2:

Link to comment
Share on other sites

  • 2 weeks later...

I have the same problem with dual booting (WinXp & MacOsX Tiger) on my PC.

I think I have correctly made partitions but it cannot boot.

 - install WinXP on my first partition (primary). This partition becomes active

 - install Mac Os X on my second partition (logical). Partition becomes Bootable, 

irst partition becomes inactive

 - make first partition active

 - Booting to Windows, copy Chain0 to the root of drive C.


After this my laptop can boot both MacOsX and WinXP.

The problem with my PC.

Link to comment
Share on other sites


  • Create New...