Jump to content

help - Hangs on BSD root


6 posts in this topic

Recommended Posts

Can you tell me how to change the following which you mentioned in other threads Oracle:


Try to install on an IDE HDD or test an external USB one.

Use PS/2 Key and Mouse.

Disable SMART.

Set Boot order.

Unplug unnessasery devices.

Use your Drive master and your dvd slave.

If not run installation first time hit F8 and then -v to see spesific errors.

(your disk it is better to be "disk0s1")



1. I dont have an IDE HDD. All I have are SATA.

2. I do have PS/2 Keyboard and Mouse.

3. What is SMART and where do I disable it in the BIOS ?

4. My boot order is CDROM then HDD

5. Theres a page in BIOS where I can change things to primary masters and slave. Is that what your talking about or are you talking about changing jumpers?



It just sits at the black screen with BSD root: disk2s3, major 14, minor 5



I have a:

AMD Athlon 64 3500+ Manchester 2.2GHz Socket 939 Processor Model ADA3500CGBOX

MSI K8N Neo4-F Socket 939 NVIDIA nForce4 ATX AMD Motherboard

APEVIA ATX-CW500WP4 ATX 500W Power Supply

Kingston ValueRAM 2GB (2 x 1GB) 184-Pin DDR SDRAM DDR 400 (PC 3200)

2x Western Digital Caviar SE16 WD2500KS 250GB 7200 RPM SATA 3.0Gb/s Hard Drive

SAMSUNG 731BF Black 17" 2 ms (GTG) DVI LCD Monitor

Link to comment
Share on other sites

EDIT: Still stuck on BSD root....


How do I change it so it reads disk0s1 ?


I've been reading the wiki and searchiong the forums and google for about 2 hours and havent found anything yet, so any help would be appreciated.


I'm trying both 10.4.9 and 10.4.8, both same problem.

Link to comment
Share on other sites

I'm in a similar situation. With one DVD drive I get read errors, and with the other I get the BSD root issue. I've tried the rd=diskx0x with many combinations, and none really work.


I'm going to try messing around with some mobo settings. My setup is similar. It's an ASUS M2NPV-VM (AM2 socket) with nForce 430 chipset. If I was to bet, I would say the nForce 430 is the problem.


I have I sata drive which I unplugged to try and rule that out, and the only thing I've accomplished is the computer taking an HOUR to get from boot to the installation screen background with the colored pinwheel going. I ended up shutting down, figuring that if the bootup was that painfully hellish, installation would be pointless.

Link to comment
Share on other sites

I have the same Motherboard... Well, one solution to get past the BSD Root, is to place 1GB of RAM only on one slot... NO DUAL CHANNEL. When I did this I got past the BSD Root point, but then again there are more problems. I'm waiting for your feedback to check this a bit further.

Link to comment
Share on other sites

Here are 2 basic steps for those who have the "MSI K8N Neo4-F" AMD Motherboard.


1) Try to install MacOS-X on an IDE Hard Disk. (SATA will not work after installation without any patch, hint: nForce4 - bikedude).

2) Make sure you got a Single Channel RAM installed to get past the "BSD Root" problem. Do not enable Dual Channel for now, try to add the extra RAM after MacOS-X installation.


My installation worked, I'm trying to fix my ATi X800 GTO PCIe, and then I will try out the "nForce4 - bikedude" patch to use SATA.

Link to comment
Share on other sites

  • 3 years later...

I know this is an old thread, but I am having the same issue with Snow Leopard.


I have a K8V SE Deluxe motherboard with a VIA chipset. I installed from a retail 10.6.0 install DVD using the Nawcom Mod CD 0.3.1. I can boot from the CD and then install Snow Leopard 10.6.0. The mod CD installed the ATA kext and the 10.0.0 legacy kernel so that I should be able to boot from the hard drive.


The legacy kernel does not boot, however, I did find a kernel that does boot, but it gets stuck at:


BSD root: disk0s1, major 14, minor 1


I tried turning off Legacy USB Support and I got one step further. Now it gets stuck at the next line:


USBMSC Identifier (non-unique): 00000000000000000000W 0x13fd 0x1040 0x106


I also tried using only a single stick of 512 MB ram to ensure that Dual Channel was not enabled. No difference.


Anyone have any ideas how I can boot my system?

Link to comment
Share on other sites


  • Create New...