Jump to content

Darned if the Realtek ALC850 just won't work


2 posts in this topic

Recommended Posts

I bought an MSI 945GZM3-L motherboard, (http://www.newegg.com/Product/Product.asp?Item=N82E16813130085), network works, sata works, video works, usb works, but it has the Realtek ALC850 soundcard, and I just can't get it to work! I've tried about 10 tutorial threads, and nothing seems to get it started!

 

I know my Device ID and Vendor ID, and I've done kext editing of the appleac97audio.kext, but nothing ever seems to work.

 

Finally I thought I had the answer-- my Info.plist file did not have a section for the Intel ICH7 southbridge, so I ADDED one with with the correct Vendor ID and Hardware ID, still, whenever I try to kextload appleAC97AudioIntelICH.kext, I get the error message that it isn't authentic.

 

Does this mean I have the wrong kext file? Has anybody here used this motherboard, or this sound card? If it makes a difference, I'm using JaS 10.4.8 + the 10.4.9 upgrade.

 

If I just need to buy another motherboard I will, but everything else works fine on this board.

Link to comment
Share on other sites

Hey, I found the solution.

 

DON'T add an entirely new section in AppleAC97AudioIntel.kext's info.plist file for ICH7.

 

Instead, add your device ID under the <key>NVIDIA AC97 Audio</key> section.

 

Even if you don't have an NFORCE chipset, (which I don't), this worked for me.

 

In other words, follow this guide to the letter --> http://wiki.osx86project.org/wiki/index.php/Audio

 

...and don't change things just because you think you know better :)

Link to comment
Share on other sites

 Share

×
×
  • Create New...