Jump to content

HFS+ Partition Error & Grub

3 posts in this topic

Recommended Posts

Hey guys I've seen lots of posts about this but none of the solutions work out for me, hopefully we can get this taken care of and help others answer as well.


I have Windows installed on a Raid0 and on an IDE drive I have Grub & Ubuntu installed. I have Grub booting either Windows XP or Ubuntu no problem it works fine. I have added another partition to the IDE drive after the linux and the swap and put the "tiger-86-flat.img" on it. I can mount the partition, view all the OSX files, write, etc... I cannot get Grub to boot OSX. I know it is the correct partition so there's no worries there. I get:


HFS+ Partition Error


Here is my menu.lst for OSX


title OSX

rootnoverify (hd0,2)


chainloader +1


I have also tried:


title OSX

root (hd0,2)


chainloader --force +1


The partition is active and primary so I am lost. Plz help if anyone knows thank you.

Link to comment
Share on other sites

Does anyone have any ideas?


Probably have no ideas that you haven't already tried. I have not installed osx using an image. I installed with the installer from a jas disk and use grub too (with ubuntu and windows). Anyways, have you seen this:




At the end they mention using lilo instead of grub to fix the HFS+ Partition Error. No idea why that helps.


They also seem to have different entries in their menu.lst so that is probably easier to try messing with then changing to lilo:


title OSX86

chainloader (hd0,0)/chain0



This sounds important too. I'd check this first - the bit about setting the partition type:


"In my case it worked by running fdisk under Linux and then to change the partition type to af - (this wasn't set)"



Other than that, It might be worth checking out some other install guides to see if they have anything relevant:



good luck


Link to comment
Share on other sites


  • Create New...