Jump to content

PCI detection issues on 10.4.8 and Abit K8T800 Pro

8 posts in this topic

Recommended Posts

Could anyone suggest why the system profiler says "This computer does not appear to have any PCI cards installed."? I was under the impression that even if it couldn't identify PCI devices, it would show them. I have onboard PCI sound and network devices which are enabled in BIOS but not appearing.


It only occured to me after I realised I had been following installation guides to the letter for the Intel Pro 100 network thing I had stuffed into the system for the last build I used (10.4.6, which I recall worked instantly with that card, native) and also for the Via Rhine networking adapter which is built into my motheredboard, to no avail.


I would love to get this networked, but if I install the drivers, nothing changes, and no PCI devices are found! Has anyone else had this problem?



Abit Av8 motherboard

- AMD Athlon 64 3200+ Winchester

- VIA K8T800 Pro chipset

- 128MB Geforce 6800 AGP graphics card (works just fine with Quartz, btw)


I find it odd that the ATA controller - a PCI device? - would function like it does if the system couldn't detect PCI devices, so have I missed the plot completely or are PCI devices really meant to be listed in the Profiler??? Cheers! :) (would any {censored} from the Console help? Kinda hard to get on here since the damn thing won't network.... a lot of rubbish about "library extensions xxxxx.kext/blah/blah doesn't contain code for the architecture specified;" though..)



A friend using the same motherboard is having the same problem! No PCI devices found.


The above makes me think it's not due to kext file permissions or general installation problems... even from the OS X installer (when booted from disc) PCI devices are not found. Since the 10.4.6 build worked ok I tried overwriting some of the kext files in System/Library/Extensions with ones from the older build, and as expected wound up with a broken OS X install. I figured replacing any kext referring to PCI in its name (IOPCIFamily, I think?) and the AppleVIA and AppleVIAATA kexts (since my mobo is VIA chipset based) would bbe something along the lines of what needed to be done. It's quite obvious I have no idea what I'm doing, isn't it? ;)

Link to comment
Share on other sites

I too have installed 10.4.8 onto an Abit motherboard (AW8-Max). Everything is sweet except for the PCI cards. The PCI slots are not functioning at all.


Could anyone assist with this one as I will fork out £125 on an Asus board otherwise.


I am as fresh as a daisy to Macs and Hackingtoshes, so instructions for a simpleton would be appreciated :)

Link to comment
Share on other sites

  • 8 months later...

It´s not a problemm, it's a known issue, System Profiler does not report PCI devices even on some real Macs.


If you want to see PCI devices even that they have no driver use DPCI Manager.

Link to comment
Share on other sites


  • Create New...