Jump to content
DsurioN

Run AppleTV on your intel mac - uses local media or acts as a standalone appleTV, can QUIT

223 posts in this topic

Recommended Posts

Guest h2a

i'm still waiting for volume control and then this would be perfect. until i have volume contol with the apple remote, i can't bother with AppleTV as a substitute for FrontRow

Share this post


Link to post
Share on other sites
Advertisement

My keyboard works with IRKeyboardEmu.kext by b.holland but for some reason if i press Up on my keyboard, the kext thinks it has been pressed 5 or 6 times. So it is impossible to actually navigate the menus, anyone else have this problem?

Share this post


Link to post
Share on other sites

Followed all the instructions. I see that intro video. Then the screen goes blank for a few seconds then it loads the OSX Finder. Anyone know whats happening?

Note this on a Hackintosh

Share this post


Link to post
Share on other sites

Mine is running fine. I use RemoteBuddy with Keyspan RF remote for Frontrow.

 

Volume works just fine (if u want to disable the fact that it changes with the up/down keys, remove RCD.app from /system/library/coreservices)

And set the REMOTE BUDDY to respond to UP(or Donw) key held to Volume UP/DOwn

Share this post


Link to post
Share on other sites

Hay,

 

I have Apple TV installed on my External Harddrive....On startup I entered the OSX and when I pushed my remote to startup the Apple TV I worked fine...

But heres the problem...when i wanted to play music Apple TV asked to connect whit ITunes.

So I quited ATV and opend Itunes, putted in my right screen. opend ATV again on my left screen.

In Itunes,ATV connected but I had to give in a code in Itunes.

But i couldnt switch to Itunes to put in the number...

 

Any help?

 

Thanx in advance!

Share this post


Link to post
Share on other sites

I don't get one thing, If i put mac os x on my apple tv, can i replace that front row with this, or is this only for intel macs

Share this post


Link to post
Share on other sites
hi!

 

i tried everything like describe, but Front Row.app always crashes for me on a 20" intel iMac. here is hwat i get:

 

EXC_BAD_ACCESS (0x0001)

KERN_PROTECTION_FAILURE (0x0002) at 0x000007f0

 

Thread 0 Crashed:

0 0x1000 + 201158

1 -[bRMediaHost addMediaProvider:] + 138

2 0x1000 + 33227

3 0x1000 + 27006

4 0x1000 + 21589

5 0x1000 + 21043

6 0x1000 + 18932

7 0x1000 + 1512278

8 0x1000 + 1512061

 

console.log:

Mar 31 12:33:33 iMac FrontRow[393]: Message Handler Installation Failed: bootstrap_check_in(): 0x44c: Bootstrap not privileged\n

Mar 31 12:33:33 iMac FrontRow[393]: No matching IR micro server found.

Mar 31 12:33:33 iMac FrontRow[393]: VERS: failed to get ImageVersion for display

Mar 31 12:33:33 iMac FrontRow[393]: VERS: failed to get BootImageVersion for display

Mar 31 12:33:33 iMac /System/Library/PrivateFrameworks/BackRow.framework/Resources/SettingsHelper: Failed to setuid

Mar 31 12:33:33 iMac FrontRow[393]: Settings helper failed: status 100

Mar 31 12:33:33 iMac /System/Library/PrivateFrameworks/BackRow.framework/Resources/SettingsHelper: Failed to setuid

Mar 31 12:33:33 iMac FrontRow[393]: Settings helper failed: status 100

Mar 31 12:33:34 iMac FrontRow[393]: VERS: failed to get ImageValid for display

Mar 31 12:33:35 iMac FrontRow[393]: Message Handler Installation Failed: service port is NULL\n

Mar 31 12:33:36 iMac crashdump[397]: Front Row crashed

Mar 31 12:33:36 iMac crashdump[397]: crash report written to: /Users/rl/Library/Logs/CrashReporter/Front Row.crash.log

 

 

 

anyone has any thoughst on why this might be? sounds like many folks here have run this on 20" iMac without trouble?

 

thanks!

 

Im getting exactly the same on a 1.83Ghz CD MacBook running 10.4.10. Strangely it works fine on my Hackintosh, but as I have no IR I can't control it....

 

My keyboard works with IRKeyboardEmu.kext by b.holland but for some reason if i press Up on my keyboard, the kext thinks it has been pressed 5 or 6 times. So it is impossible to actually navigate the menus, anyone else have this problem?

 

I get this as well as the volume changing, but I presume bootsee's suggestion would fix this.

Share this post


Link to post
Share on other sites

Updating to 1.1 question:

 

I grabbed the Apple TV 1.1 installer from the interwebs. Do I just run it on my mac mini (currently running aTV 1.0) or are there some steps I must take? ;)

 

Thank you :P

Share this post


Link to post
Share on other sites

I have a question on installing the original Front Row app again

I've tried to put the backup of the original back into the /System/Library/CoreServices/ directory

and there I have to click Authenticate, Replace, and give my password. But then i get an error messages that tells me that it can't complete the operation because I don't have enough rights...

Wo now i don't have any front row when i press my menu button on the remote...

 

what can I do about it?

thanx!!!

Share this post


Link to post
Share on other sites

is there a way of docking the front row by anychance also anyway of changing the resolution and also is there a way to use my mac book using the mini dvi to vga to put the front row on the second screen ?

Share this post


Link to post
Share on other sites

Just found this. It looks like it is only running on Tiger. But what is so intriguing about it is that this might somehow allow us to use Nvidia GPU decoding of h264 which is what the @tv uses. I will look into it further, but I hope this re-ignites the initiative.

Share this post


Link to post
Share on other sites

I'm not sure if this guy did this on a mac or a hack. I haven't yet looked into the discussion on the IRC. I'll see what I can find out.

Share this post


Link to post
Share on other sites

Need some help, hopefully this thread still gets checked

 

I've tried for the last 2 days to get AppleTV to work on my Mac Mini running Leopard 10.5

 

I get as far as the sceen going black right after I push the menu button on my remote or double click the Front Row Icon in Applications. It stays black for a few seconds before bringing me back to the dashboard.

 

Any ideas???

 

Thanks

Share this post


Link to post
Share on other sites
Need some help, hopefully this thread still gets checked

 

I've tried for the last 2 days to get AppleTV to work on my Mac Mini running Leopard 10.5

 

I get as far as the sceen going black right after I push the menu button on my remote or double click the Front Row Icon in Applications. It stays black for a few seconds before bringing me back to the dashboard.

 

Any ideas???

 

Thanks

It doesn't work on leopard... only on tiger.

Share this post


Link to post
Share on other sites

Does anyone still happen to have that patched Finder executable, ATV4mac or the BackRow Installer?
It's nowhere to be found on the internet.

I'm trying to patch together a virtual AppleTV to act as an iTunes Server, actually syncing the physical audio files.
To my knowledge, the 1st gen AppleTV was the only device that ever did this without user interaction.

Why hasn't anyone tried this?

Any help is appreciated!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×