Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Soündless

Running aTV OS on Intel Macs

Recommended Posts

I am sure people have done it, but i am having some problems. i restored the image to a 1gb flash drive, booted, and i got the shiney apple logo, then it restarted to 10.4.9. is anyone sucsessfuly running this on thier intel mac?

Share this post


Link to post
Share on other sites
Advertisement

Same as you, man.

Share this post


Link to post
Share on other sites
Same as you, man.

 

same here on the hack situation :unsure: just minus the apple logo.....

 

and who said it couldnt be done......

Share this post


Link to post
Share on other sites

I replaced the kernel to the 10.4.9 one and got the same thing.

Share this post


Link to post
Share on other sites

i'll have to get a hold of that because my mbp came with 10.4.8 you can boot into single user mode on the apple tv? what can you edit there that you cant edit in os x?

Share this post


Link to post
Share on other sites

Im downloading the 10.4.7 combo pack for Intel right now, when its done I'll send mach_kernel etc. to my iMac for storage. If someone has a permanent storage solution I can give you access to download it :rolleyes:.

Share this post


Link to post
Share on other sites
Im downloading the 10.4.7 combo pack for Intel right now, when its done I'll send mach_kernel etc. to my iMac for storage. If someone has a permanent storage solution I can give you access to download it :).

 

Drop it off to something like zshare...

Share this post


Link to post
Share on other sites

I'd like to call attention to this Demonoid torrent: MOD EDIT. DO NOT LINK TO COPYRIGHTED FILES. Thank you. :thumbsup_anim:

 

Scroll down to the comment made by the user "XianLi".

 

Ok, i've found the problem.

 

/System/Library/CoreServices/Setup Assistant.app

/System/Library/CoreServices/Finder.app

 

Both apps are checking the hardware name and won't start until we found a hack.

 

I've been able to boot the AppleTV OSX system on my Mac mini with a 10.4.8 Finder.

 

Does this mean anything?

Share this post


Link to post
Share on other sites

It explains why even after being able to Boot ATV on my MBP I get an immediate restart after the kernel has loaded. (Not Kernel Panic, an actual restart)

 

I knew to try to strip out the Finder.app for the time being, but I did not think about Setup Assistant.app.

Share this post


Link to post
Share on other sites

I only quickly browsed through finder.app for any references to a device name and was unable to find any. It may be that finder.app is handing the task over to backrow or other frameworks.

Otherwise, some serious hacking is needed.

Share this post


Link to post
Share on other sites

reading /etc/rc was interesting. Its very short and seems to have a only a few functions. Specifically I found these.

 

#!/bin/sh

 

# Script to prepare root device

 

function die () {

echo "$@"

sleep 10

bless --device `redirect --recovery` --setBoot --nextonly

reboot

}

 

function mount() {

if [ "$1" = "-uw" -o "$1" = "-vat" ]; then

echo "Skipping $@"

return 0

else

/sbin/mount "$@"

fi

}

 

It looks like if something doesnt want to work, it kills the operating system. I think thats why it reboots when trying to load a non-standard kernel. So wait, why doesnt someone try removing the die function and boot if off an Intel Mac?

Share this post


Link to post
Share on other sites
Im downloading the 10.4.7 combo pack for Intel right now, when its done I'll send mach_kernel etc. to my iMac for storage. If someone has a permanent storage solution I can give you access to download it :rolleyes: .

 

as semthex says : its not a base on 10.4.7! and the mach_kernel is different!

its based on 10.4.8 with a few modifications.

 

and the aTV kernel is 8.8.2 (12mb big)

 

sorry to dissapoint you all

-DiaboliK

 

as for the watchdog it is set to intel's ich7/m lpc controllers :wacko:

 

also did you find the aTV signal plugin which i think has something to do with watchdog, but im not sure so dont quote me on it.

Share this post


Link to post
Share on other sites

As far as I can tell ITVSignal is used by the NowPlaying.qtz file to grab track info; or at least, thats what Quartz Composer tells me has failed to load when I try opening NowPlaying.qtz on my iMac.

 

I've been trying to get it to work, basing my actions on the idea that ITVSignal.plugin is a quartz composer patch (I'm probably wrong mind, I am quite the noob at this sort of stuff) but I don't know enough to go about trying to bundle the xml inside ITVSignal.plugin into a new QC patch, or to get QC to see ITVSignal as it stands. I could modify an existing quartz composer plugin I guess, but I don't know if I want to risk making bits of QC stop working..

Share this post


Link to post
Share on other sites
as semthex says : its not a base on 10.4.7! and the mach_kernel is different!

its based on 10.4.8 with a few modifications.

 

and the aTV kernel is 8.8.2 (12mb big)

 

sorry to dissapoint you all

-DiaboliK

 

as for the watchdog it is set to intel's ich7/m lpc controllers :star_smile:

 

also did you find the aTV signal plugin which i think has something to do with watchdog, but im not sure so dont quote me on it.

 

Alright thanks for the info :whistle:. Once I grab the full image and toss it on my external drive I'll work with it more.

Share this post


Link to post
Share on other sites

I've been trying a bunch of ways of combining the image from the AppleTV and a full OS X install to try to get it booting on my mac mini.

 

Since I figured it was reasonably related to OSX86 in general, I threw up a page on the wiki (a user sub-page to be specific) here to keep track of what I've done and share it.

 

Maybe we should try to coordinate our efforts in one place, something like that, so we aren't duplicating a lot of effort?

Share this post


Link to post
Share on other sites

I installed it on my macbook and messed with some of the kexts. I now get this error

 

-sh-2.05b# csrhidtransitiondriver: :stop

IObluetoothhcicontroller: :start idle timer stopped

Share this post


Link to post
Share on other sites

i got the bluetooth thing when my mbp stopped installation in the middle of an update

 

my disk utility is dead again after 2 hours of work :) so i will be trying to fix that, then i can restore the image, then i can try to mess around with stuff

Share this post


Link to post
Share on other sites

dead link.

it turns out that the disk utility wasnt dead, it was the apple tv .dmg, so i am downloading th one off demon again because it worked

Share this post


Link to post
Share on other sites

Hi I'm new here. I just found this video on digg, maybe this is what asap18 is referring to:

 

 

Doesn't show a lot, but seems interesting.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×