Jump to content
InsanelyMac Forum
Sign in to follow this  
lord123

X1700 kernel panic | Screenshot inside!

Recommended Posts

Hi folks,

 

im trying to get my X1700 working with Diabolik's method but i get always a kernel panic in AtiRadeonX1000.kext! I have ATINDRV 10.4.5 and IONDRVSupport 10.4.5 in my extensions...also i have Mobility.kext and Atiradeonx1000.kext! Without Atiradeonx1000.kext MacOs boots and shows that X1700 is found, but no kext loaded for it(no CI/QE). With AtiRadeonX1000.kext i get a kernel panic!

 

I just added Dev and Ven Id to Atiradeonx1000.kext!

 

Screenshot

 

dsc00153iu0.jpg

 

Thank you for helping,

Greetings, lord

Share this post


Link to post
Share on other sites
Advertisement
Hi folks,

 

im trying to get my X1700 working with Diabolik's method but i get always a kernel panic in AtiRadeonX1000.kext! I have ATINDRV 10.4.5 and IONDRVSupport 10.4.5 in my extensions...also i have Mobility.kext and Atiradeonx1000.kext! Without Atiradeonx1000.kext MacOs boots and shows that X1700 is found, but no kext loaded for it(no CI/QE). With AtiRadeonX1000.kext i get a kernel panic!

 

I just added Dev and Ven Id to Atiradeonx1000.kext!

 

Screenshot

 

dsc00153iu0.jpg

 

Thank you for helping,

Greetings, lord

 

 

yeap that's what happening on mine to ... but thanks to DiaboliK i do not lose the hope. He made for me some kext's to try ... as soon that i get to my mac box ... do few tests ... i'l reply if there is some positive results.

 

All the best

Share this post


Link to post
Share on other sites

Hi all,

 

Just las night i had some time to do a test with the DiaboliK kext ... so ... To make the long story shorter:

 

Installed the JaS SSE3 intel combo update to 10.4.9 with the new kernel.

Used AtiRadeonx1000.kext edited for me by DiaboliK and get the kernel panic but with the difference from the last kernel (8.8.1) like this:

 

Kernel 8.8.1

the panic:

com.apple.iokit.iopcifamily

com.apple.iokit.iographicsfamily

com.apple.iokit.iondrvsupport

 

Kernel 8.9.1

the panic:

com.apple.iokit.iographicsfamily

com.apple.iokit.iondrvsupport

 

I belive we are close to the Valhalladay ...

 

I'l do another test using the iographicsfamily and iondrvsupport from 10.4.7 and post some results.

 

 

Thanks DiaboliK for your work !

Share this post


Link to post
Share on other sites

I'll try tomorrow... standby.

 

I can *also* try with the [potentially updated] 10.4.10 kexts.... I doubt they're different but you never know!

*EDIT: 10.4.10 ATIRadeonX1000.kext still crashes but it is updated*

Share this post


Link to post
Share on other sites

Did anybody ever manage to get x1700 working ? Not sure even for x1600,x1700 post (bigest one).

 

Thanks for help.

Share this post


Link to post
Share on other sites
Did anybody ever manage to get x1700 working ? Not sure even for x1600,x1700 post (bigest one).

 

Thanks for help.

 

 

Later i'll post here some detalied how to for those with Mobility x1700 ... only res change ... internal LCD and external VGA

Check on the last pages !

 

 

All best

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×