Jump to content



9 posts in this topic

Recommended Posts

I did the whole single user passwd curtis thing, seemed like it changed it fine. But whenever I try to use su and it asks for my password, it rejects it saying "su: Sorry"


Why?! I know my password, but it's not accepting it. What gives?




Link to comment
Share on other sites

didn't work  :P  are u sure that is the pass for curtis?... i know that deadmoo uses it... i can't install that patch so i can't use itunes... help!!!


Here's what I did:


Boot into single user mode (-s at the darwin prompt)

type sh /etc/rc


type passwd root

enter password


type reboot



then su will use that password. worked for me...

Link to comment
Share on other sites

An alternative would be to start in single user mode (F8, the -s ) then enter the following commands:


/sbin/fsck -fy

/sbin/mount -uw /

mv /var/db/netinfo/local.nidb /var/db/netinfo/local.old

rm /var/db/.AppleSetupDone


Then restart and it will go through the Apple setup,

after you log in, go into the netinfo manager select security and

select authenticate and enter the user name and password you

setup for yourself in the apple setup. The go back into security

and choose enable root user. It will tell you the root user password is

blank and will prompt you to enter one.



It worked for me!

Link to comment
Share on other sites

You are talking about the root password right?


IIRC the root account is not enabled by default



1) Open /Applications/Utilities/Net Info Manager


2) Then Authenticate (Menu -> Security -> Authenticate or Click the lock at the bottom of the window) The password you use must be a admin password


3) Next Click the Menu Security -> Enable root user


It will ask you to choose a password… Make sure the password is a good password ;-)





Edit: Sorry, emo12, I didn't see the last of your post

Link to comment
Share on other sites


  • Create New...