Jump to content
InsanelyMac Forum
Prasys

HowTo - SSE3 Kernel with Sleep + SpeedStep

Recommended Posts

Hi Paulicat

I tried the command sysctl -a | grep curfreq and sysctl -a | grep throttle

 

all gave me error message saying

 

"kern.exec: unknown type returned"

 

Is there anything I haven't done to enable this two command?

Share this post


Link to post
Share on other sites
Advertisement
Hi Paulicat

I tried the command sysctl -a | grep curfreq and sysctl -a | grep throttle

 

all gave me error message saying

 

"kern.exec: unknown type returned"

 

Is there anything I haven't done to enable this two command?

 

That means that CPUThrottle was not loaded correctly. If it did, you would get something.

Edited by ppan76

Share this post


Link to post
Share on other sites

Thanks Ppan76, then how can I load it?

But as I remember ACPIcputhrottle.kext is conflicting with 10.4.8 kernel right?

 

 

That means that CPUThrottle was not loaded correctly. If it did, you would get something.

Share this post


Link to post
Share on other sites

ok guys, this: "kern.exec: unknown type returned" is an error returned by ALL osx boxes. Its not from or related to my kernel mods.

 

Once Okik and I get our changes together, we'll have a solid kext.

Edited by paulicat

Share this post


Link to post
Share on other sites

Thanks Paulicat!, hope OKik and you can solve it

 

Ppan76, may be you are right

I try to kextload ACPICPUthrottle and it says

 

kextload: extension ACPICPUThrottle.kext appears to be valid

kextload: kmod_control/start failed for com.OSx86Project.kext.ACPICPUThrottle; destroying kmod

 

 

 

That means that CPUThrottle was not loaded correctly. If it did, you would get something.

Share this post


Link to post
Share on other sites
kextload: extension ACPICPUThrottle.kext appears to be valid

kextload: kmod_control/start failed for com.OSx86Project.kext.ACPICPUThrottle; destroying kmod

 

Thats the error i was getting, try loading it again, i.e: do it three times in one go. Or try the kext from my pkg

Share this post


Link to post
Share on other sites

Thanks Okik

here is my system log after I tried few mor times

Feb 23 00:04:52 chaocolates-computer kernel[0]: ACPI CPU Throttle loaded

Feb 23 00:04:52 chaocolates-computer kernel[0]: ACPICPUThrottle: Adding CPU0

Feb 23 00:04:52 chaocolates-computer kernel[0]: ACPICPUThrottle: Failed with code -536870212

Feb 23 00:04:52 chaocolates-computer kernel[0]: ACPICPUThrottle: Adding CPU1

Feb 23 00:04:52 chaocolates-computer kernel[0]: ACPICPUThrottle: Failed with code -536870212

Feb 23 00:04:52 chaocolates-computer kernel[0]: ACPICPUThrottle: Adding CPU2

Feb 23 00:04:52 chaocolates-computer kernel[0]: ACPICPUThrottle: Failed with code -536870212

Feb 23 00:04:52 chaocolates-computer kernel[0]: ACPICPUThrottle: Adding CPU3

Feb 23 00:04:52 chaocolates-computer kernel[0]: ACPICPUThrottle: Failed with code -536870212

Feb 23 00:04:52 chaocolates-computer kernel[0]: ACPICPUThrottle: No valid CPUs returned by ACPI! It's possible your BIOS does not think your system should be throttled and therefore did not return any available power states, or maybe your CPU only supports one other power state than maximum which is below 1Ghz!

 

 

 

I actually use your kext,

The CPU throttle doesn't work either, report frequency of zero and all option are blank

 

just for your reference.

my CPU is pentium D 945 dual core at 3.4G support EIST S3 T1M and in windows with CPU right mark utiliy I can set 7 VIP/PID from 12X (2.4G) to 17x (3.4G)

so I don't quite understand why it says my CPU doesn't support power state or max lower than 1G

 

 

 

btw

one more thing I found is that after install your pkg, I cannot try paulicat's pkg again.

Ppan76 seems able to do it, I wondering how? (go to back up kernel, delete /Library/Startupitems and delete the cpu throttle from application folder?)

 

 

Thats the error i was getting, try loading it again, i.e: do it three times in one go. Or try the kext from my pkg

Share this post


Link to post
Share on other sites
one more thing I found is that after install your pkg, I cannot try paulicat's pkg again.

Ppan76 seems able to do it, I wondering how? (go to back up kernel, delete /Library/Startupitems and delete the cpu throttle from application folder?)

 

 

The way I do is start macosx on single user mode (-s).

Then delete the CPUThrottle Kext from the \Library\StartupItems and copy my mach_kernel back.

After that you can install whatever packages you need as many times as you want to test.

Share this post


Link to post
Share on other sites
To Control the frequency use the included CPU Throttler app in my installer, you can either set it to dynamic or manual, (dynamic changes your frequency according to your cpu load, and manual lets you set it youself). Also, Bresinks temperature montior is weird on my computer,. When i had old 10.4.4 SMBios installed i always got temp raitngs of 45C (where it should be) using new paulicats smbios i get ratings of 52C (so most likely just a 10C bias), just keep that in mind.

 

 

I just realized there was a CPU Throttler Application Installed. I just launched it and tried changing the settings. Nothing happends when I change the CPU Speed or load or save a profile. Nothing happends.

 

Also when the appication is open. I cannot run Activity Monitor, Terminal and checking System Profiler don't return all the parameters.

 

Thanks.

Edited by ppan76

Share this post


Link to post
Share on other sites

Hello,

 

I've been testing all the flavours of this patch and I've been unable to get through the login window. I get a coreservicesd crash (the login windows does not apperar and the screen remains blue).

I tested it on a Vaio SZ1M laptop, 1.6 Dual Core Intel CPU.

 

Right now I'm stuck with the latest Paulicat Patch as I tried to boot the mach_kernel.bak but I get a kernel Panic as soons as it tries to load the CPUthrottler startup item.

 

Tried to boot with -s (single mode) but the filesystem is mounted as read only, does anybody know how to remove the StartupItems in single mode?

 

I'll reinstall the system and try again to see if the coreservicesd crash is due to another kext incompatibility.

 

I've managed to make everything working on this laptop (except wireless, dual nvidia/intel support and SpeedStep/Sleep) so drop me a line for help if you have a Vaio.

 

thanks for your work.

Edited by jordi V

Share this post


Link to post
Share on other sites

Simple fix for anyone testing.

Boot in -s mode

fsck -fy

mount -uw /

rm -fr /Library/StartupItems/ACPICPUThrottle

 

Reboot.

 

Remember guys, my kernel mod is the only one supporting speedstep, the only thing Okik and I have to work together on is the kext. I didnt write the kext, it was written Neall Douglas a while ago, probably before c2d's existed...

My kernel will act the same as any other kernel without that folder.

Edited by paulicat

Share this post


Link to post
Share on other sites

The kernel's the same for me, I was worried I may lose sound but it's good. I had to use Kikos Okiks kext because the latest paulicat wouldn't install. I still have no sleep, but I do have speed step working. I don't know if I like it. My bus speed is cut down to 100MHz and my CPU stays at 1.33GHz. It may sound odd but my temps seem to have gone up instead of down, by about 10C. I haven't tested battery life but I guess it would be longer, being that the clock speed is lower. I was hoping for a dual core fix, unfortunately still cpus=1. I can boot with both cores but system will freeze with in a couple minutes.

Share this post


Link to post
Share on other sites

In my case the problem should be another issue because deleting the throttle StartupItem and booting from the speedstep modified kernel just does the same, a coreservicesd crash.

 

"Historically" I have always booted safely from any other kernel, 8.8.1, sf9 and DaemonES

 

launchd: Server 5a0f in bootstrap 1103 uid 0: "/System/Library/CoreServices/coreservicesd"[85]: exited abnormally: Illegal instruction

 

The crash is seen as no login windows appearing and the screen in blue eternally during booting.

 

I will reinstall everything from scratch to try to see if it really depends on the kernel, the bios or whatever other component.

 

thks for the fix.

 

j.

Share this post


Link to post
Share on other sites

Just Wondering, Have Paulicat and Okik disscussed the detail of their pkgs?

No pressure, I am just desperate to hear any progress on the issue and I am willing to do all kinds of testing.

 

 

 

 

ok guys, this: "kern.exec: unknown type returned" is an error returned by ALL osx boxes. Its not from or related to my kernel mods.

 

Once Okik and I get our changes together, we'll have a solid kext.

Share this post


Link to post
Share on other sites

After trying the packages I do gain 30 minutes more of battery time. That's running the laptop at 1GHz and 100Mhz Bus speed.

 

Dynamic CPU throttling is not working for me. The CPU stays at 1GHZ though It does seem CpuThrottle is trying to change the frequency of the CPU...it s failing though.

 

Sleep at least for me is not working or there is no change.

 

I believe to get sleep and SpeedStep fixed is extremely difficult. I have never gotten it to work trying 4 different computers. (All the way from version 10.4.3)

Edited by ppan76

Share this post


Link to post
Share on other sites

The kext in m ypkg is not complete, it keeps your bus speed at 100mhz, me and paulicat are working on one which should work for more people

Share this post


Link to post
Share on other sites

See Okiks post, his first kext had a problem in it which I fixed for mine, however c2d's dont like my kext.

Okiks and I are on the opposite sides of the planet, so its a little tough to co-ordinate, but we'll sort something out asap.

 

Paulicat.

Share this post


Link to post
Share on other sites

Just a quick note, in case it helps someone in the future. I installed the latest installer on a thinkpad X60T. In order for it to work on my system, I needed to enable Speedstep in my BIOS. ACPIThrottle reported that CPU0 was throttled to 1ghz, CPU1 had no log messages associated with it at all...

 

I noticed no difference in battery time, fan speed or temperature with the kernel and Throttle kext installed. Bigger though, my system randomly hung solid, for no particular reason. Removing the kernel and throttle was no problem.

 

In any case, Paulicat is tops for trying this, despite my machine's outcome! Thanks for the awesome effort!

-AN

---

Thinkpad X60T Tablet; JaS 10.4.8 with PPF2 diskutil patch; khashoggi tablet driver .031; 10.4.5 IO80211family.kext

Share this post


Link to post
Share on other sites

Hey Aeronick,

 

Can you post more log info with speedstep disabled in the bios?

Dont work about the error message about acpi not showing and cpu's to control, it doesnt use acpi at all now, it uses the IntelDirect drive...

 

Paulicat

Share this post


Link to post
Share on other sites

wow this is quite awesome. After installing okik's package on my core2duo 5600 lappie my xbench score went form 75 to 130 ! Haven't tested sleep jet because I'm to exited :thumbsup_anim:

looking forward tot some final version!

 

thx paulicat and okik !!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×