Jump to content
seaDonkey

The Complete Dell XPS m1210 Installation + Dual Boot Tutorial

572 posts in this topic

Recommended Posts

I hate to bump this thread again as many others have done but I was just wondering, is there any way to get the intel wifi card to work? I use it with Backtrack 3 for packet injection and testing WiFi security. Or does the older dell work for that as well?

 

Still no way to make the wireless work

 

Sleep/Shutdown works

Share this post


Link to post
Share on other sites
Advertisement

Does anybody have or have messed with EFI strings on the NVIDIA graphics for this laptop? I am trying to get the external display to work (which it does just fine), without the laptop screen being on, and I figured that would be the first thing to try. Anybody have any tips, or experience with this working? I've googled a little bit about it, but can't find anything concrete.

Share this post


Link to post
Share on other sites

I've added an updated set of procedures, applications and files for configuring osx86 on the Dell M1210. The procedures should enable M1210 users to utilize just about every piece of hardware in their system, with the exception of intel wireless and internal quickcam.

 

I've referenced this thread, as it was a great source of information for me. Thank you.

 

The thread is located here:

 

http://www.insanelymac.com/forum/index.php?showtopic=156261

Share this post


Link to post
Share on other sites
I've added an updated set of procedures, applications and files for configuring osx86 on the Dell M1210. The procedures should enable M1210 users to utilize just about every piece of hardware in their system, with the exception of intel wireless and internal quickcam.

 

I've referenced this thread, as it was a great source of information for me. Thank you.

 

The thread is located here:

 

http://www.insanelymac.com/forum/index.php?showtopic=156261

 

 

nice one! now i have everything working, it was tricky to get the gma 945 video card working with ideneb v 1.4. if you click on the link and scroll down, you can read how i did it if you have the intel video card in your 1210

Share this post


Link to post
Share on other sites

great work guys :D

 

i have m1210 . i did the install very well ....

 

every thing is working except Wi-Fi & Cam & Card reader ....

 

sleep very well ...

 

but i have 2 problems if any one can help :)

 

1. shut down : it turn off the system & turn of screen but the lights still working & the HDD to ...

so i have to press the power button for while until it's closed ...

 

2.the system doesn't mont any external HDD or flash memory ...

the usb is working . i tried another devises & it working ....

 

excuse my bad English :unsure:

Share this post


Link to post
Share on other sites
I guess I got most of all features on m1210 working now except for:

1. Webcam

2. Line-in or microphone jack from front panel

3. Card reader.

4. VGA output

 

Anyone know how to make microphone jack to work?

 

Thanks for all the help you guys have provided!!

 

I got everything working except for the Mic.. did u fix this??? got the same laptop.

Share this post


Link to post
Share on other sites

I installed SL on the M1210 yesterday. It works, but it's not as compatible as Leopard for the time being. I did a vanilla install using the myhack/flash drive install, and then got graphics working using the EFI String I found somewhere on the web.

Audio is not working. I tried using the AppleHDA/Targua installer, but no dice.

Also, I have to boot up with cpus=1, even though it's running the vanilla kernel. At first I thought Snow Leopard was just really slow on this machine, but it turned out it was just the cpus=1 trick that was needed. I tried installing the 9.6.0 kernel to fix it, but I think it killed my install. Not sure because I installed that and the VoodooHDA kext at the same time, but after that, the machine would not finish booting into SL.

Anybody else take the plunge yet? I'm guessing it will only be a matter or time before someone will have a solution for Sigmatel audio on Snow Leopard. I would like to learn more about EFI Audio, but I can't figure out how you get the hex code for your chipset.

Share this post


Link to post
Share on other sites

Hello all, I figured I'd post my same question on this thread as well they are both related and I'm unsure which one sees the most traffic.

 

I've never really had any problems with my OS after following the guide at the beginning. I have since then upgraded to 10.5.6 and now recently to 10.5.8. I never had a problem with the 10.5.6 upgrade nor did I have to enter any safe mode to reinstall drivers.

 

10.5.8 however is a different story. After making the upgrade, rebooted back into OS X to find my sound was not working working and the touchpad and keyboard do not work on the M1210. I didn't know that at the time as I was using a USB keyboard/mouse setup. I've re-patched the audio with AppleHDAPatcher and successfully brought my sound back. The keyboard and touchpad however, I have no clue what to do.

 

Also, does anyone know of a later video driver setup? I tried a dvd the other day and it caused all the menus to go a scratchy green; very difficult to find the restart button thereafter. I'm currently using the NVinjectGo setup provided at the beginning of this thread.

 

 

Thanks in advance and I'll chime it if I figure anything out on my end.

 

Cheers,

 

duff

Share this post


Link to post
Share on other sites
Dell XPS M1210: XP + JAS 10.4.8 Mifki

CPU: Intel Core 2 Duo T7200 2.0Ghz - (Only one core works) <---- both cores are working now =)

RAM: 2GB @ 667mhz DDR2

Video: Nvidia Geforce GO7400 - (QE/QE2D/CI supported w/Natit universal 1.0)

Audio: Sigmatel 9220 - (FULLY WORKING! speakers and all!!!)

Storage:100gb 7200RPM Seagate SATA

Optical: Dual layer DVD +/- RW - (Fully working)

Ethernet: Broadcom 440x - (Fully working)

Dell 1390 b/g - (Working as Airport Express)

Bluetooth: Dell 355 - (Working)

Touchpad/usb: works - (no 2 finger scrolling, tapping works)

Webcam: tried macam and Logitech osx drivers - (NOT working)

Interal card reader - (not working)

ACPI- DISPLAY WON'T RECOVER FROM SLEEP HELP!

Click here for my XPS m1210 Installation Tutorial

 

"Also, I have not tried the 10.4.9 update yet. I'm kinda scared that one of my apps will quit working properly, I use OSX for work alot. The apps I use the most are Photoshop CS2, garagesale, firefox, thunderbird and aperture."

 

 

I can see your point for not wanting to mess with a good thing, I haven't had any problems at all, but I don't use this for work, and I don't use photoshop. A good indicator for what would be affected is probably the official notes for the 10.4.9 install. I've installed ilife, iwork, office 2004, firefox all preupdate and no problems.

 

 

 

Jami,

 

The mifki kernal is only needed to get the speakers working. I'm sorry about your slow internet speeds, that's rough.

 

As for getting that card in India, I think your best bet is going through Dell directly

 

here are the product links for both the 1390 and 1490 cards, so you can get part/model numbers

 

http://accessories.us.dell.com/sna/product...mp;sku=430-1731

http://accessories.us.dell.com/sna/product...mp;sku=430-1733

 

here is the phone number for Dell in India, I'm not sure if the 1-800 number will work there.

 

Call1800- 425- 4026 Toll Free or Call 080-2506-8026 (standard charges apply)

 

 

as I've said before...

Good Luck

you definitely have a challange on your hands

 

I hope this isn't too far off topic, but since we are all m1210 owners, and OSx86 users, and macbooks have slot load drives...

 

I saw this, and now I'm getting tempted to get one just for the hell of it.

 

http://www.zipzoomfly.com/jsp/ProductDetai...ductCode=175305

 

How did you do for the core CPUs, it only shows one core!

thanks

Share this post


Link to post
Share on other sites

I used to have Leopard installed on my Dell XPS m1210. Everything (except USB) used to work perfectly, including wi-fi. I had to change the HD for a larger one (500gb) and I have bought an original copy of Snow Leopard that I’m using on my Desktop Hackintosh. For now I can only find tutorials about how to install “Leopard” on it, but I was willing to use my original copy of Snow Leopard instead of downloading those hacked distributions of Leopard. Anyone have already tried to install SL on a Dell XPS m1210?

Share this post


Link to post
Share on other sites
I used to have Leopard installed on my Dell XPS m1210. Everything (except USB) used to work perfectly, including wi-fi. I had to change the HD for a larger one (500gb) and I have bought an original copy of Snow Leopard that I’m using on my Desktop Hackintosh. For now I can only find tutorials about how to install “Leopard” on it, but I was willing to use my original copy of Snow Leopard instead of downloading those hacked distributions of Leopard. Anyone have already tried to install SL on a Dell XPS m1210?

 

 

Yes, 10.6.4 retail with EmpireEFI 1.0.85 R2

 

I will make a tuto these next days...

 

but it is easy, you need only three packages

VoodooHDA.kext

VoodooTSCSync.kext

NVEnabler.kext for geforce go 7400

Share this post


Link to post
Share on other sites
Yes, 10.6.4 retail with EmpireEFI 1.0.85 R2

 

I will make a tuto these next days...

 

but it is easy, you need only three packages

VoodooHDA.kext

VoodooTSCSync.kext

NVEnabler.kext for geforce go 7400

 

Hi ..

 

 

What's up with tuto?

Share this post


Link to post
Share on other sites

Hi all,

 

I've just gotten my m1210 set up with dual boot (Win 7 + OSX 10.6.4) with nearly everything working.

 

Is there still any interest in a tutorial for this?

Share this post


Link to post
Share on other sites
Hi all,

 

I've just gotten my m1210 set up with dual boot (Win 7 + OSX 10.6.4) with nearly everything working.

 

Is there still any interest in a tutorial for this?

 

 

Very much so. - at least from me

Share this post


Link to post
Share on other sites
Hi all,

 

I've just gotten my m1210 set up with dual boot (Win 7 + OSX 10.6.4) with nearly everything working.

 

Is there still any interest in a tutorial for this?

 

 

I would really love to see this tutorial. I have my m1210 running with mac os x 10.5.6 with everything working. But now I want to upgrade to snow leopard.

 

Please send me the tutorial or post asap.

 

Thanks.

Share this post


Link to post
Share on other sites

Foreword/disclaimer:

The following is a step by step tutorial for installing osx on a Dell XPS m1210 laptop. Note that it is illegal to download or obtain an x86 Intel OSX image from any source including torrent sites. It is also a breach of the EULA to make your own. The information presented here was collected from various online sources. Also note that I am not responsible for any problems with your computer that may occur because of this guide.

 

 

how'd you get the external display working?

Share this post


Link to post
Share on other sites

Anyone can help what is the best way! I got to boot but pc super laggy and keep loosing Internet connection please update guide thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×