Jump to content
Ferret-Simpson

Fujitsu T-421X TabletPC

135 posts in this topic

Recommended Posts

Guide to setting up the T4210 and T4215 model TabletPC's from Fujitsu(-Seimens)

 

Ok, you've all seen my posts for help, many of you have, now here's the running howto.

 

1: Set up the Drive

 

Because the Fujitsu disks for windows just ghost over the top of your HDD, you have to install Windows first, and then use the Gparted CD (google it) to resize the Windows partition. Back up first. After you've resized, you should make about a 20GB "unformatted" partition. This will be your Mac drive.

 

2: Install OS X

 

Several things I've found that are necessary, you'll be interested in I'm sure. Firstly: You need to install with Kernel 8.81. This means you'll be using a Jas Semtex 10.4.8 DVD, Beta 2 or higher. The earlier ports all used 10.4.4 kernels, which are too old for the "Macbook" Hardware of the T4210.

 

Make sure your wireless is on before you install, and plug in a couple of USB devices for good measure. Install the bare minimum you can, but include the X11, GMA950 and Intel packages. No other hardware is supported on the T4210 (Except for printers of course.)

 

Hopefully, you'll now have an OS X install that boots and runs OK. If you have any USB Audio devices, these will work under OS X, for now the sigmatel won't. Airport either, I'm working on it.

 

Install the modified Yukon drivers. These are attached to the post. It's only one or two changes to a plist, but I thought I'd save you the hassle.

 

Delete the /System/Library/Extensions/IONetworkingFamily.kext file

Copy the attached version over the top.

 

Then load up either the Apple Terminal or X11 Terminal and do:

 

rm -r /System/Library/Extensions.mkext

rm -r /System/Library/Extensions.kextcache

diskutil repairPermissions /

 

Reboot.

 

 

(Gracias Polargom)

 

To boot into windows you'll have to install a third party bootloader or Linux on another partition: the route I chose. PM me for assistance with that.

 

Will update as my install improves. Working on: Atheros Wifi, Wacom, Cardbus.

 

Edit: Kext too big to upload. Linked here instead:

http://www.freewebs.com/ferret-simpson/IONetworking.zip

Edited by Ferret-Simpson

Share this post


Link to post
Share on other sites
Advertisement

Update:

 

After having a look through the IO80211Family.kext and it's atheros plugin, I've peered into the depths of Dmesg and discovered that there's a mysterious device that the USB controller fails to Enumerate. What do you know, the only one not visible in the Profiler is our missing wifi card. As of yet unsure quite how I'm supposed to fix that.

 

More extensive research online shows that the Wacom Panel indeed works as a 16X50, and all it takes is a little configuration. To that effect I'm trying to install my Linux partition, but it just doesn't want to play today.

 

More issues: The internal display isn't recognised, so won't run with Quartz Extreme. ACPI is equally as mysterious, so no battery control etc. PCMCIA is another thing that looks most likely to be a plist hack. The fingerprint reader appears to be working out of the box although I've yet to find any security software to take adantage of it. SmartCard: Won't know until the PCMCIA bus is active, but I doubt there's a driver. Audio: I'm still working on it. SDHC: Also still working on it.

Share this post


Link to post
Share on other sites

Atheros AR5006EG is M-PCI-E and supposedly supported (ID's have been checked in the Atheros Plist)

 

So as to why it doesn't work I still don't know. I also don't know what that mystery USB device is. Possibly the Fujitsu button panel? I rather thought that the button panel and rotation sensor would be on GPIO lines, but still. . That's a hack for later. First, good news!

 

While hacking on the intel iMacs in the physics tower at Uni, I got bored and looked into the Kexts for their 0.4.8 install. Surprise surprise, there's a set of "Intel GMA950 GL" kexts. Copied them to my tablet, ran the usual

 

sudo rm /System/Library/Extensions.*

diskutil repairPermissions /

 

I've uploaded the rest of the extensions folder to ATLANTIS, and I'll have a play around. I've already tried the newer AppleHDA. . It doesn't break it, but it doesn't fix it either. I'll try patching the new AHDA with the Codec patcher.

 

When I've had a chance to see if the other codecs do anything for us, I'll upload all helpful codecs somewhere. How's that? :unsure:

 

Currently working-through-hacking 8)

 

Intel GMA950 with OpenGL support (No QE/CI. . . YET!)

Marvell Yukon 88E8055 Gigabit Ethernet

Share this post


Link to post
Share on other sites

Huzzah! The Audio and Graphics work ok.

 

Note, as of yet the Audio is internal-speakers only. . . The file is an AppleHDA.kext from a new iMac, patched with Taruga 1.09 - Hopefuly it'll get better with age, like any fine wine. Still, this enables you to use your Apple Hac a little more fruitfully.

 

Experimenting with this has cost me as OS install, so now I have twin 10.4.8 partitions, only one (Newton and not Darwin) working.

 

Will reformat Darwin and do a "File and settings transfer" from Newton.

 

The Serial subystem is starting to make a little more sense to me although I haven't quite worked out how to hack it to recognise our missing 16X50. Am currently working on the ACPI, since this is currently the next important thing for me: Battery control. Backlight would also be nice, but the code for it seems a little crazy to me.

 

Will Edit to add the packages when they've been uploaded.

 

:hysterical:

Share this post


Link to post
Share on other sites

I'm trying to get JAS 10.4.8 running on my Fujitsu 4215. I need the modified Yukon drivers from your first post but the link seems to be dead....

Share this post


Link to post
Share on other sites

Hi!

 

If you p2p me your email addrss I'll email you a zip of all four corrected kernel modules:

 

Audio out, Ethernet and OpenGL. :thumbsup_anim:

 

Still working on the rest, if you know how to hack kernel plists, have a look at a few. :whistle:

Share this post


Link to post
Share on other sites

Another thing works!

 

This one involved no hacking of my own, Rex: If you haven't already, install this now. I'll link everyone to the thread:

 

The revised PowerManagement bundle!!

 

DVD player doesn't work on my system so I see no worries about powermanagement breaking it. . . Hasn't worked since I moved to 10.4.8: Maybe our kernels are OOD?

 

I'll look into it, anyway.

 

Here's the thread of the bundle. Just download and follow the instructions. As always, wifi;wacom; and the other broken junk is still being worked on.:2cents:

 

http://forum.insanelymac.com/index.php?showtopic=14912

Edited by Ferret-Simpson

Share this post


Link to post
Share on other sites

Hi,

 

Good work on your progress with the sound.

 

I have a T4210 and before that a T4010 (blew up after 1 year warranty and not worth it to replace the motherboard).

 

When I had the T4010 I had up to around 10.4.5 working with graphics (no CI/QE), sound, ethernet, and wifi (using a Broadcom based PC card, the internel Intel wifi didn't have any drivers). I also wrote a driver for the tablet pen which worked. The tablet has a standard serial port 16x50 in it that just needs the device vendor id's updated in the kext to enable it then the Mac sees it as a standard serial port. I wrote a user space daemon which translated the Wacom serial port tablet information into mouse movements.

 

Now, forward to the T4210:

 

I have graphics working with CI and QE (no rotation), built-in bluetooth and ethernet. The tablet pen is sort of working, but I need to work on the driver a bit more. But the digitizer appears to be identical to the T4010. Has the same serial port vendor ID's etc.

 

What is not working yet is the sound, but I am going to try the kext's you supplied. I'm not using the 10.4.8 kernel yet, although that is my system version. I still have the older kernel.

 

Also, the wifi is not working. I've investigated it a bit, here is what I found:

I originally had the internal Intel 3945ABG card, so I swapped it out for a Dell Truemobile 1390 which is guaranteed to work according to others. It is based on the Broadcom 4311 chipset.

 

But, it doesn't work. From what I can tell the PCI bridge to that bus is not being powered up, so the computer never gets a chance to see the card. The PC Card port is also not being powered up, and as a result, not PC cards work either. It may be the IOPCICard kext that needs to be modified to see those particular PCI Express bridges. I haven't gotten enough time to really get into it. But, obviously I really want to get wireless working. Either through the mini-pci-E card or through the PC Card slot.

 

My T4210 is triple boot: Fedora Core 6, OS X, and Windoze XP. I also own a Macbook Pro 2.16ghz. I've compared the busses, and the Macbook has PCI Express in it so it is theoretically possible to get the T4210 to power up its busses if the the chipset driver can be figured out. The manufacturer of the T4210 PC card bridge is 02micro. Their is some support for 02micro bridges in OS X but something has to be done to get it recognize the T4210's variant.

 

I believe the USB unknown device are the bezel buttons on the T4210, and the fingerprint scanner also comes up and is recognized in system profiler. Just, no software to use it with.

 

If we could figure out the wireless or PC Card that would be great. I will try your sound fix, and I'm going to finish up my work on the pen driver to get it to be reliable with the T4210

 

Cheers

Share this post


Link to post
Share on other sites

Ok, the Power Management now works. Ethernet works! Still no go on graphics and sound though. Not sure why since the procedure that fixed the Ethernet is the same for the other two.

 

Just to confirm: If I go to About This Mac, Graphics/Displays I'm showing GMA 950 has my chipset and down below it says "Not Supported" for Quartz Extreme. And in System Preferences, Sounds I'm showing "No Output Devices Found".

 

 

So in short:

Works - Power Management, Ethernet, USB, Bluetooth, Fingerprint(detected at least)

 

Not working - Graphics(QE), Sound, Digitizer, WiFi

Share this post


Link to post
Share on other sites

The graphics work fine. If you connect your system to a new cinema display you'll get CI and QE on it. Rotation etc too. It's just that the Monitor has no driver. (This is all in my p2p, just making a public viewed comment.) - OpenGL is supported in those kexts on your display, which majorly improves system performance for lots of stuff, especially 3d. Try running the Flurry screensaver. Notice the difference since before the patch?

 

The sound is odd, the kext from my system should have worked, they're identical machines. At least the graphics and ethernet worked.

 

 

Khas:

 

I'm standing on the shoulders of giants here. The sound driver is Taruga's work. Can you give me the kexts for the serial port? It's been the one I haven't worked out.

 

 

Are you scratch building a driver? Or just using the serial port and another driver?

 

The (Open Source?) Freeware TabletMagic driver which I have installed should be able to cope fine with the input data from the digitiser: Penabled technology works identically to the old UD tablets, it's why I bought a UD1212 yesterday to go with my "new" Powermac G4" - My collection of drivers and pens will work fine. The TabletMagic just accesses any recognised serial port and uses the tablet on it. The important thing is it's designed to work with all the features of the standard Wacom drivers. . . Could save us alot of time and coding if I can get it working with your serial port driver.

 

But yeah again, if you can give me the kext that'd be lovely.

 

A guy has written a driver for the o2 Cardbus adaptor we use (Modified PCCardFamily) but it didn't work, which is rapidly leading me to the same conclusion as to you on the PCI-E bus. . . The included Atheros kext with OSX 10.4.5 onward is compatible with our cards, I checked the plist.

 

I was dual booting Win/Mac, but Windows died on me and I'm stuck on the mac.

 

How did you get QE/CI working? Preference or Xcode hacks? I'm unconvinced about those. I'm figuring it'd be better to make a new driver out of the AppleDisplay monitor driver. At least make it compatible through the OS realising it's compatible. That way a simple kext installer could be made and distributed. :hysterical:

 

My email is noFerret_spamSimpson@noHotmail.spamCom

 

remove the no's and spam's, obviously.

 

There are a few bugs in the 10.4.8 kernel currently which are causing issues for the T421X. . . You'll need to get the latest Semthex kernel installed with the full 10.4.8 system to get it running properly, the auto-installer is out of date and while the kernel on the jAS disk is good, it kernelpanics a few applications and won't resume from sleep mode properly. When you're on 10.4.8 I can send you my kextbundle that I'm working on, although it's still got a while to go. Your serial kext would be a big step. :hysterical:

 

With a bit of luck, there may be some better support for the T421X in Taruga's 1.10 patcher, but for now I have the basic audio.

 

From what I can see, OS X has drivers for the Fingerprint scanner and I think the Smart Card reader when PCI and Cardbus are running. The SCSI-based SD/MS reader should also work too. I'm getting "Cannot enumerate device" errors from the usb system on boot, I think these are the button panel on the screen. And I also haven't found any security software for the advanced devices yet, despite their driver support.

 

Well, if you mail me your kext, I think I can safely set myself a todo list:

 

Update to the latest kernel beta from Semthex

Port (If necessary) the Wacom Serial kext to 10.4.8 and test with TabletMagic. Fiddle.

Have a look into the PCI-E problem, I think it must be something obvious we're missing.

If PCI-E is fixed, test the o2 CB drivers, the SCSI, and the Atheros.

Find a way to fit more status indicators on my already very-full menubar.

Help Taruga with Audio bugs.

FujiDisplay Driver.

 

If we can get a fujidisplay driver working, I might see if I can apply it to my syncmaster too, rotation would be good on it, as it's designed as a rotating monitor.

 

But yeah. . Gimme Gimme Serial!!!!! :)

 

Oh yeah. The AppleHDA codec that I have working on my kernel is taken from the latest intel iMac release. . . Whether it works on a lower OS is unknown, and I'm not ready to risk data trying it. . .

 

Ok, well hope to here from you as soon as I can, I'm pretty irritated about losing windows because Linux wouldn't work right with my Pen, and so I'm feeling a little like the extra £500 of the T4210 over a MBP is being wasted. . .

 

Ferret

Share this post


Link to post
Share on other sites

Hmm. Haven't looked into the PCI drivers yet, wait no, I've got the Profiler open on my other screen and the PCI driver is loader and working. . . This is I presume why I can use the USB and Ethernet. . .

 

The Cardbus bugs me, I have an o2 chipset driver. . . And thinking about it, it seems crazy to me to put Cardbus on PCI-E. . . Same goes for the SCSI controller. *Sigh* A little more documentation from Fujitsu would be nice. . .

 

You say you have windows and linux, can you see if you can get any information about the PCI-E and Card buses?

 

The tabletmagic drivers also look like they'd support the Penabled tablet perfectly if you can make the 16X50 visible. . .

 

Apple Mac OS X - TabletPC Edition 2007

 

Cross brand marketing. . . I think it'd work nicely. . .

 

The Apple inkwell seems much better to me already than the Windows Tablet functions. . . I won't be able to test it fully without either your serial kext or my G4 and Ultrapad. (On their way.)

Share this post


Link to post
Share on other sites

I have Fedora Core 6 on the laptop fully configured for sound (which needed the latest development alsa libraries to work 1.0.14rc2) and the pen (which was easy, just added a few xorg.conf lines to configure the pen, the wacom driver is already included with Fedora)

 

I wrote my driver from scratch, and did look at Tablet Magic to see the tablet protocol. It works 95% of the time, but some times doesn't intialize right on boot. I also use an onscreen keyboard from assistiveware called KeyStrokes.

 

Because my tablet driver emulates a mouse, it does not appear to Inkwell as a tablet. So, you can't use the apple handwriting recognition features. But, with the onscreen keyboard and the mouse functionality you can control the Mac OS quite well.

 

I will check on the bus information from linux, but if you do a "ioreg -l" from the terminal you can clearly see what is on what bus and the powered-up state (or powered-down in this case) of each bus.

 

When I get a chance I will wrap up my tablet driver and send it to you.

 

I haven't had a chance yet to try your sound driver that you patched. I wise I could get wireless working, it was nice on my T4010 when I finally got that working. Having to be plugged into anything sucks on a tablet... as I'm sure you know.

Edited by Khashoggi

Share this post


Link to post
Share on other sites

Thanks! Don't bother with an installer, a text file of instructions will do, and I want to try out tabletmagic before I try your driver code, just to see if it works as it looks like it will.

 

For some reason my stylus never worked under linux. Slackware comes with the drivers, and once I changes the pen to Absolute mode it almost-worked. . .

 

Just for some reason was out of sync. The further you get from the top-left corner, the further the cursor gets ahead of the pen tip.

 

Going to use a Wacom UD1212 on my PowerMac G4, too. I'm about to go send the cheque's off. My connection method is entertaining: a PCI-PCMCIA card adaptor, a PCMCIA - CF adaptor, and a Socket Serial CF adaptor that I figure will work both on the Wacom and my Zaurus.

 

I just want to be the first person to set up X11 on my SL-5600 with an external digitiser. I could probably port a version of the gimp, too. .. Although it'd be slow as sin.

 

 

Anyway. . .

 

Looking forward to the serial driver. I understand what I'm supposed to do, but none of the 3 versions of my Serial kext have a UART port setup to base it on, only PCI cards.

 

It's 0x220 IRQ 4 if I remember correctly.

 

 

Incidentally, I saw a couple of posts about TabletPC's on OS X, and apart from the commercial and modified ModBook, I don't think it's been done yet, you're the first. :)

 

Congratulations! Looking forward to being the second.

 

I'm going to go post my cheques for the G4 and Wacom, then reboot into Ubuntu and try and get my own codec dump. Fingers crossed, I should be able to get support on a T421X apart from mine with it.

 

There is something very odd about this thing. . . The audio doesn't work with my Kext on Rex's. . .

Share this post


Link to post
Share on other sites

<key>AppleMacRiscPCIE</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleMacRiscPCI</string>

<key>IOClass</key>

<string>AppleMacRiscPCIE</string>

<key>IONameMatch</key>

<string>u4-pcie</string>

<key>IOProviderClass</key>

<string>IOPlatformDevice</string>

</dict>

 

That's the only code I seem to be able to find on PCI-E in a plist.

 

Fingers crossed our bugs in there, or thereabouts. I'm just glad the video controller in a T421X isn't PCI Express, if our Bus isn't active. . . I might try doing a verbose boot and then doing a dmesg to see if I can store a little more information on our PCI, cardbus and SCSI problems.

Share this post


Link to post
Share on other sites

I never was able to get Tabletmagic to work correctly (last spring 2006). That's why I wrote my own driver, which scales properly for the screen so the pen doesn't get ahead of the cursor on the edges.

 

I got CI/QE to work by using the 10.4.7 JAS installer with the GMA900 package options installed. I verified it does work by checking screen savers, and the iTunes visualizer.

 

DVD playback also works properly for me.

 

Fedora has the wacom driver already installed. I think it is an actual manufacturer blessed/created driver so it works flawlessly. But, if I screen rotate, then it messes up. I need to restart X to get it to scale properly. Kind of like what Windoze does.

Share this post


Link to post
Share on other sites

There is a way to support rotation properly in X but I can't remember how. The issue inherent with DVD playback is that you have an ancient kernel. (10.4.4) The OS versions between 10.4.4 and 10.4.7 all used the 10.4.4 kernel. We're using jAS 10.4.8 with the new Semthex kernel which is still a little buggy. He's working on it, but we're stuck for the moment with an old revision of Semthex.

 

The issue on linux/X was one of numbers, that I never had time to correct - Because of the way OS X works. Tablet magic can be updated on the fly, which will make calibrating it a little easier. TabletMagic seems highly configurable, so I should be able to get it working - even if I have to play with the source code a little. :(

Share this post


Link to post
Share on other sites

Yes, I undestood the kernel differences and problems with the Semthex kernel when I chose which one I would use. That's why I opted to stay with the older kernel. I wanted to have QE/CI and DVD player operational. I don't see the real world advantage of the new kenel untill all the bugs are worked out. Now, if the bus problems wer worked out in the new kernel to give wireless, that may make the difference for me.

Share this post


Link to post
Share on other sites

Aye. I take it you haven't had a chance to upload your kext? I'm still eagerly anticipating it. n.n As I said, I can live without your HID driver for now since I want to experiment with TabletMagic some more myself.

 

I figure it's best to use the newer kernel because most of the big developments are starting to happen primarily for it. Although the disadvantage is that I have the new serial driver which only has support for PCI cards in the plist.

Share this post


Link to post
Share on other sites

Ksashoggi,

 

having read that you could never get TabletMagic to work, get the debug version of it here:

http://thinkyhead.com/pub/TabletMagic2b7-logging.dmg

and post all your experiences in detail along with the log file from TabletMagic2b7-logging to:

http://sourceforge.net/forum/forum.php?thr...forum_id=368562

TabletMagic's developer Scottie Lahteine would be happy to assist you there.

 

Also, in regards to modifying Apple16X50Serial.kext:

You would make lives of many people easier if you copy and paste the contents of you plist file here.

Share this post


Link to post
Share on other sites

To enable the serial port on the T4010 or T4210 Tablets (Maybe others, but I have not tested) do the following modification to the Apple16X50ACPI.kext:

 

Edit info.plist:

/system/library/extensions/Apple16X50Serial.kext/Contents/PlugIns/Apple16X50ACPI.kext/Contents/Info.plist

change IONameMatch string:

PNP0501 to FUJ02E5

 

Clear kext caches by removing the following files:

/system/library/Extensions.kextcache

/system/library/Extensions.mkext

 

reboot

 

 

Cheers!

Share this post


Link to post
Share on other sites

Doesn't work on 10.4.8 because the plist only has a record for PCI serial. Will try to get hold of an older serial kext. I'm downloading the update package to 10.4.6 - Will try to nick it from there.

 

Ok, thst is irritating. It seems I can't unarchive packages from Apple. I don't have permission.

 

Gits.

Share this post


Link to post
Share on other sites

Works with HP TC4200

Need to replace it with WACF006

Now we need to play around with this logging version of TabletMagic and talk to Scottie to get things sorted and supported...

Khashoggi, submitted anything to that forum yet?

Share this post


Link to post
Share on other sites

Paringas, can you send me your kext? My kext doesn't support the alterations.

 

 

Right, ok I was being thick. What happens when you try and use tabletmagic? On my system, it asks for a pasword then the GSOD comes up. . .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×