Jump to content

I managed to get 915chipset GMA900 work with Quartz Extreme but .....


5 posts in this topic

Recommended Posts

I sucessfully get the video driver work on OSX with Quartz Extreme support.

No need to boot with external monitor.....

However, .... After I install some other application and localize package, the blue screen happened again.

...... Will try again with fresh install and see what happen.

Link to comment
Share on other sites

I fall into the problem again.. but I swear I did make it.

Here is my long run in installing and see if people here can figure out what happen.

(Sorry, I am trying to speak out the entire story so that some expert may help pointing out the solution)


My notebook is Fujitsu S6240 with 915 chipset of course and GMA900 Integrated chip

please search the details on the web


I install the OSX with a brand new harddrive and made a 15G partition with it.

I use the Generic OSX DVD to install which I can't really sure about the version (should be same as most of yours)

After I get the OSX installed, I didn't think that I need QE and therefore I just stick with VESA.

The first step I do is to get my ASUS wireless USB work with me because the internal GigaLAN didn't seems to work.

I download the Ralink driver and modifiy the config with my device / vendor ID.

with 3 hours trial & error I managed to get it work.

I also installed the new 10.4.2 patch with v0.5 SSE3 emulator

At this time I am happy with the OSX with nearly full hardware support until I get into the SNES emulator for gaming.

I downloaded SNES9x OSX universal binary and get into real trouble that it don't do any OpenGL.

I therefore get into the display property and check that the kext driver is not loaded.

After following the instruction of modifing the AppleIntelIntegratedGraphics.kext and AppleIntel915.kext, I got the BSOD ("blue screen after boot")

I don't have an external monitor port so that I cannot attach the external monitor as workaround.

I tried different setting including to delete the AppleIntel915.kext however with no luck.. still the BSOD.


Link to comment
Share on other sites



I was very disapointed at that time and try whatever means to get it to work, I know QE is a must for OpenGL and therefore I continue seeking ways to do it.

I tried to look at the driver from Darwin 8.01 but there are no 915kext avalible.

I tried repair the permissions and move and copy files from place to place (only the kext)

And finally I get it working by modifiy another file.

As you may know that the mobile GMA900 with an address different from the one in OSX 2582 vs 2592(mobile). There are actually one more file that MAY need to be modified. Which is AppleIntel915GA.plugin. Change all the string within this file from 2582 to 2592 (be reminded that the string format may not look similar to that of AppleIntel915.kext). Just replace all matched string (should be 2 in total).

Right after reboot, the QE are ready to go... I got the wave effect while adding widget..


There are something that I should notice.. I have also installed iTune 6.01 / flash plugin to the system.



I am not sure about the failing, it could be Real Player, it could be the Localizer patch, I installed Asian support plus a few asian languages interface. And the following boot showed the second desktop (extended desktop) that I can only see the edge of some widnows. While I try fix it, BSOD appear again.


I would say that the emulator SNES9x works perfectly while the QE was working.

Please someone post any idea after looking into my experience

Link to comment
Share on other sites


  • Create New...