Jump to content

Intel I225-V on Ventura


MacAbe
 Share

60 posts in this topic

Recommended Posts

Hace 1 hora, 5T33Z0 dijo:

Aquí hay una versión corregida de SSDT-I225V.aml: 

SSDT-I225V.aml.zip 996 B · 1 descarga

 

La versión original de MacAbe contiene algunos errores tipográficos ("I255" en lugar de "I225") y el Bloque de definición no se ajustaba al 100% a ACPI (idealmente, el ID de la tabla OEM no debería exceder los 4 caracteres).

 

@5T33Z0 Thank you, could you check my config.plist and confirm that the corrections are correct, it's a boot config.plist for macos ventura with z490 Aorus Master + i10900k but ethernet didn't work and froze after 5 minutes, I followed your instructions and added AppleIntelI210Ethernet.kext, added SSDT-I255Ethernet.aml and e1000=0 boot-arg Would it work with those modifications?

config.plist.zip

Edited by Fory360
Link to comment
Share on other sites

@Fory360

 

  • MinKernel was missing for the kext
  • boot-args e1000=0 and -v weren't seperated
  • DisableIOMapper needs to be disabled and Vt-de enabled in BIOS

The rest looks fine. If it keeps crashing I don't know how to fix it.

 

config.plist.zip

 

Configurtaion guide: https://github.com/5T33Z0/Gigabyte-Z490-Vision-G-Hackintosh-OpenCore/blob/main/I225_stock_vs_cstmfw.md#settings-combinations-stock-firmware

 

Fixes: https://github.com/5T33Z0/Gigabyte-Z490-Vision-G-Hackintosh-OpenCore/blob/main/I225-V_FIX.md

Edited by 5T33Z0
Link to comment
Share on other sites

Hace 4 minutos, 5T33Z0 dijo:

Faltaba MinKernel para el kext

 

Hace 6 minutos, 5T33Z0 dijo:

@Fory360

 

  • Faltaba MinKernel para el kext
  • boot-args e1000=0 y -v no estaban separados
  • DisableIOMapper debe estar deshabilitado y Vt-de habilitado en BIOS

El resto se ve bien. Si sigue fallando, no sé cómo solucionarlo.

 

config.plist.zip 5.41 kB · 0 descargas

 

Guía de configuración: https://github.com/5T33Z0/Gigabyte-Z490-Vision-G-Hackintosh-OpenCore/blob/main/I225_stock_vs_cstmfw.md#settings-combinations-stock-firmware

 

@5T33Z0 Great Thank you I will try and comment results!

Link to comment
Share on other sites

15 hours ago, Irish_Man said:

Ok, added AppleIntelI210Ethernet.kext,

Where is AppleIntelI210Ethernet.kext located? assuming is the vanilla kext I searched S/L/E but not there, (12.4 Monterey).

btw, I'm getting my Ethernet working with e1000=0 and set "Duplex" to "full duplex" in Settings/Ethernet/Advanced/Hardware.

Link to comment
Share on other sites

Hace 9 minutos, RandomTech dijo:

¿Dónde se encuentra AppleIntelI210Ethernet.kext? asumiendo que es el kext vainilla, busqué S/L/E pero no allí, (12.4 Monterey).

Por cierto, estoy haciendo que mi Ethernet funcione con e1000 = 0 y configuro "Dúplex" en "Dúplex completo" en Configuración/Ethernet/Avanzado/Hardware.

 

AppleIntelI210Ethernet.kext.zip

  • Thanks 1
Link to comment
Share on other sites

6 minutes ago, 5T33Z0 said:

@RandomTech Beginning of the thread

 

Or: /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleIntelI210Ethernet.kext (not in Ventura of course)

Thanks just found it, sorry for not giving attention to the beginning of thread.

I know is not in Ventura anymore, that's why I'm preparing for a working method.

Link to comment
Share on other sites

El 23/06/2022 a las 11:10, Fory360 dijo:

 

 

@ 5T33Z0 Genial Gracias voy a tratar y comentar los resultados!

@5T33Z0 Hello, install from 0 ventura, but at the time of welcome, ethernet configuration the machine restarts, I was able to install but selecting this mac does not connect to the internet, then in the ethernet configuration it does not let me add a service and I don't know what to do

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...