Jump to content

Intel Core i5-4570 (HD 4600 Haswell) - Display 8 MB (No Acceleration)


5 posts in this topic

Recommended Posts

So, I've been trying to get my iGPU to run with acceleration for two days in-a-row now but I still haven't got it working at all. I've faced several KPs in the process but whenever I can boot into the OS, everything still runs without QE/CI (acceleration) so it lags quite annoyingly so much.

 

I figured I'll start asking for help, if anyone can.

 

My PC build is on my signature so I'm not gonna write it down again in this thread. I will however explain things I've done so far. Keep in mind that I have the latest WhateverGreen and Lilu kext. Also, my display running through my GTX 1050Ti using DP but I've both disabled it from SSDT and set the primary display to "ONBOARD" from BIOS, I also set the shared memory to 64MB (cause I've seen other threads and they said the recommended size is 64MB). However, I also tried to set it higher to 512MB and even 1024MB, yet they all still gave me same results.

 

I also tried using device-id for HD4600 but that only ended up giving me KPs. Meanwhile, when I remove the device-id, it will boot as usual (I caught a glimpse of DRMStatus error but it will still boot without acceleration). I also tried to change the SMBIOS to iMac15,1 and iMac14,4 (tried iMac14,1 once but turned out it wasn't supported in Big Sur). I mixed a lot of settings from one another, hoping it would work like a miracle but unfortunately, I'm not that lucky. A few combinations work and will let me boot normally (still no acceleration), and others only gives me KPs.

 

Even when I already disabled dGPU from SSDT, I still tried to use -wegnoegpu bootarg but this only gives KPs (with all combinations I have, it won't let me boot into the OS). So, I ended up not using it anymore.

 

Attached Screenshots:

  1. About This Mac didn't show "Intel HD Graphics 4600" instead only Display 8 MB
    1420725135_ScreenShot2021-07-18at18_53_18.png.83a5280722187b804ba9b853bab70388.png
     
  2. Meanwhile the System Report only shows that much info
    1939307994_ScreenShot2021-07-18at18_09_30.png.e41f90ed1e59e0dfe9072f5ac4d1c6ea.png
     
  3. System Report > Graphics/Display still shows my dGPU and no iGPU (idk if this means my SSDT patch to disable it not working or what)
    1933999441_ScreenShot2021-07-18at19_00_28.png.64f3f5f19ca5fa4688c469b2c7623d05.png
     

 

I also attached my last configured EFI folder (which still let me boot into the OS without acceleration)

 

I would very much like to keep my dGPU attached in the motherboard and have just one cable connected to my one and only monitor because I still use the GPU for when I work from Windows. I'm fine with hackintosh only running through the iGPU because this is pure a hobby to me for years. It would be very helpful if anyone can give me their help with this...

EFI.zip

41 minutes ago, ellaosx said:

Unplug 1050Ti and fix your iGPU first.

Use deviceID 412 and try different framebuffer.

Alright, I 'll go ahead and try this then. Thanks for the input. I'll get back here once I see some progress (hopefully there will be).

Okay, it's been a couple days, that's cause I was waiting for a DVI-D to HDMI adapter to arrive since VGA isn't supported and my motherboard only has VGA and DVI-D outputs. But anyways, I made some progress! (Yay) I did what @ellaosx asked me and that is to take the GPU out and work the iGPU first. I did it and it works! I also used @chris1111's config of only putting both ig-platform-id and device-id in Device Properties. It's booting just fine and finally with actual working acceleration. So, I'd like to thank you guys for the help and suggestions :)

 

However, I'm not yet done. I will now try putting my dGPU back onto the motherboard. And I was thinking if I should keep using 0300220D as ig-platform-id or change it to 04001204 once I put the dGPU back on. Since, well, I'd like to keep only one cable running from the PC to my monitor, which means I will prefer the iGPU to run headless without losing acceleration.

 

1266482954_ScreenShot2021-07-20at13_27_31.png.433ff7ed6bfb17cff83aaf29ada03081.png

  • Like 1
×
×
  • Create New...