Jump to content

Random scramble screen with P6T Deluxe V2


1 post in this topic

Recommended Posts

Hi there,

 

I've been experimenting with Opencore (I've had a working Mojave setup with Clover for more than a year now ant it's been flawless), and managed to get Big Sur 11.4 running on my config.

 

It's working pretty well (I attached my Opencore 0.7.1 EFI folder for those interested) but I have random "scramble screens" during boot. I've always had, it happens when booting either from the Install USB or from the final Install with Opencore copied to the SSD.

 

Never had that issue with Opencore + Catalina which I initially toyed with before attacking Big Sur.

 

It's happening during the PCI devices/USB detection, either on:

  • ifnet_attach
  • ARPT
  • cryptoAlloc
  • AppleYukon2
  • AppleUSB20HubPort@...
  • IOUSBHostInterface...

 

When it happens on AppleYukon2, I get a series of: "waitForPowerState timed out waiting for power change"

 

I tried disconnecting all the USB devices, remove the Fenvi Wifi card, disabled the Yukon internal controller... Nothing changes.

 

Then I just reset, and it boots correctly. Sometimes it boots 5 times in a row, sometimes it doesn't 5 times in a row...

 

Tried native nvram (the P6T is supposed to support it), emulating (current EFI I attached) and I'm still not sure it's working OK. With emulated I have the nvram.plist file created in the EFI partition but I still can't set my default boot device (either via CTRL+ENTER when selecting the boot device, or via the System preferences).

 

So, I might be missing something here about NVRAM.

 

Still, I don't explain why it's random. One thing is for sure, it only happens with Big Sur.

 

Any help would be appreciated, although I know not a lot of people managed to get Big Sur running on an X58 motherboard.

 

Thanks!

 

PS: Bonus question, how do you get SMCProcessor to display frequencies and multipliers on a Xeon X5675? I have them with FakeSMC but VirtualSMC + SMCProcessor only displays the core temps. That would really help me choose between my different CPUPM setups (either via MacPro41-PowerProfile - which gives me the best results with Mojave - especially with C-States enabled in BIOS - or CPUFriend, or just nothing extra at all).

 

EFI.zip

Edited by Capsule
×
×
  • Create New...