Jump to content
59 posts in this topic

Recommended Posts

24 minutes ago, ellaosx said:

HIi @LAbyOne

I think it was the same version as @Matgen84 last reported.

   *** EDIT FROM YOUR PREVIOUS POST ***

suggestion:

put an option to go back from the previous menu rather than exiting the app.

ok, but your post doesn't give any infos about what was the function you were calling when it happened, and that line you posted does not help me since the script evolves and at that address there's totally another function (which in no way can cause a logout), i cannot fix something not knowing what to look for.

That's the reason why I asked

Posted (edited)

Hi @LAbyOne

It was option#2 (clover 5 builder). I accidentally pressed the #2 without downloading first clover (#1), then gave me the exit error.

Shouldnt be a prompt instead of an exit due to clover folder does not exist yet?

 

Edited by ellaosx
1 minute ago, ellaosx said:

Hi @LAbyOne

It was option#2 (clover 5 builder). I accidentally pressed the #2 without downloading first clover (#1), then gave me the exit error.

Shouldnt be a prompt instead of an exit due to clover folder does not exist yet?

 

In fact it does. since 2 pre-releases if i;m not mistaken

probably you still had an older one...

well good to know since its solved and if give a look at main thread explanations, you will find it. And also some more Infos i added since.

well thanks for the clarification, you saved me a good headache :)

  • Like 1

Fixed issues recently reported

on some environments

All current users are advised to update

latest Download is for

Release 1.3

this one can also be available as menuItem

if interested please leave comments.

 

 

  • Thanks 1

Just a suggestion for a minor GUI tweak for the next release: move the entry for point 6 further to the right, so it alligns with the rest of the entries in the right column:

 

1070096116_Bildschirmfoto2021-05-28um07_34_12.png.51476e7d8942f5dbf07adb1413a5a894.png

Posted (edited)

Hi @LAbyOne

Thanks for v1.3 Release :)

First test on existing src folder: 

  • I can update Clover (option 2 in menu)
  • I can build (option (option 1 in menu)
  • No return to main menu, only logout terminal windows
Spoiler

1799669491_Capturedcran2021-05-2807_40_41.png.ef024a7177dd50f318cbe513ab8424d3.png

 

I relaunch Clover Suite Builder, select makepkg. The sym folder opens with CloverPKG inside, this time. The app do not return to main menu.

 

Spoiler

1964338798_Capturedcran2021-05-2807_48_51.png.050d9e6673a85cb2d7172def90d53ab0.png

 

Edited by Matgen84
Posted (edited)
1 hour ago, 5T33Z0 said:

Just a suggestion for a minor GUI tweak for the next release: move the entry for point 6 further to the right, so it alligns with the rest of the entries in the right column:

 

1070096116_Bildschirmfoto2021-05-28um07_34_12.png.51476e7d8942f5dbf07adb1413a5a894.png

well that's difficult to make it equally balanced, because of many reasons.

one being anyone personal Terminal settings, that i cannot control

as you can see by the pics I  posted, all come from 1.013.6 10.14.6 and big sur

none of them has any glitch.

 

RE-EDIT

now just noticed one strange thing. which could eventually cause that 

as default values, any window is forced to 84x24 to keep the balance of the design

yours is a bit over that, maybe that is cause.. even the diffrent fonts could cause that..

could you just try Monaco and see if persists?

Edited by LAbyOne
Posted (edited)
1 hour ago, Matgen84 said:

Hi @LAbyOne

Thanks for v1.3 Release :)

First test on existing src folder: 

  • I can update Clover (option 2 in menu)
  • I can build (option (option 1 in menu)
  • No return to main menu, only logout terminal windows
  Reveal hidden contents

1799669491_Capturedcran2021-05-2807_40_41.png.ef024a7177dd50f318cbe513ab8424d3.png

 

I relaunch Clover Suite Builder, select makepkg. The sym folder opens with CloverPKG inside, this time. The app do not return to main menu.

 

  Reveal hidden contents

1964338798_Capturedcran2021-05-2807_48_51.png.050d9e6673a85cb2d7172def90d53ab0.png

 

Mat, can you please re-download the dmg, modified something..

but anyway no such error here is produced, can you please verify into toolchain/tools if a output folder is created?

it seems like a permissions issue,

 

BTW you should have the build logs inside output (if it has been created) so you can check put what's causing that.

Frankly this time i really don't know what to say, as i've tested on every possible condition since yesterday, and no anomalies found,

hope the logs are there so we can try to figure out what went wrong..

Edited by LAbyOne

@LAbyOne I resized the window to check if this causes the entry to move but it has no effect on it. The default size when starting the app is 86x26 for me. But that changes too, depending on font and the style/theme of the terminal window. I am using "Homebrew" now. Anyway, don't worry about it, it's totally unimportant anyway.

Posted (edited)
5 minutes ago, 5T33Z0 said:

@LAbyOne I resized the window to check if this causes the entry to move but it has no effect on it. The default size when starting the app is 86x26 for me. But that changes too, depending on font and the style/theme of the terminal window. I am using "Homebrew" now. Anyway, don't worry about it, it's totally unimportant anyway.

 

Anyway

2075059425_ScreenShot.png.2f3adbf0da5da2e79d23af4f7f9109cf.png271240352_ScreenShot1.png.74ceb8234efade1868fc81195af15faa.png1552839888_ScreenShot2.png.2d314a71190194237b0077a434286a73.png

 

these are my defaults into terminal probably setting them this way may solve that..

if you want to give a try..

 

Fonts, window size, declare terminal, are the parameters, then antialiased can give better font rendering

Edited by LAbyOne
5 hours ago, LAbyOne said:

Mat, can you please re-download the dmg, modified something..

but anyway no such error here is produced, can you please verify into toolchain/tools if a output folder is created?

it seems like a permissions issue,

 

BTW you should have the build logs inside output (if it has been created) so you can check put what's causing that.

Frankly this time i really don't know what to say, as i've tested on every possible condition since yesterday, and no anomalies found,

hope the logs are there so we can try to figure out what went wrong..

 

@LAbyOne There is no a output folder into toolchain/tools.

 

I redownload v1.3 Release.

When I mistaken, by selection option 1. The windows "Clover is missing appears" because directory not found. I can' return to main menu after cancel, only exit app. But the clover directory exists. 

 

Spoiler

1671235629_Capturedcran2021-05-2814_01_23.png.2301a242ca6e730c8ed999e2a2ea6418.png

 

Sorry for my bad English

3 hours ago, LAbyOne said:

 

2075059425_ScreenShot.png.2f3adbf0da5da2e79d23af4f7f9109cf.png271240352_ScreenShot1.png.74ceb8234efade1868fc81195af15faa.png1552839888_ScreenShot2.png.2d314a71190194237b0077a434286a73.png

 

 

By curiosity, @LAbyOne what's the name of this app, into the screenshot. Please.

30 minutes ago, Matgen84 said:

 

By curiosity, @LAbyOne what's the name of this app, into the screenshot. Please.

Mac-os built-in Terminal app preferences.

  • Thanks 1
Posted (edited)
3 hours ago, Matgen84 said:

 

@LAbyOne There is no a output folder into toolchain/tools.

 

I redownload v1.3 Release.

When I mistaken, by selection option 1. The windows "Clover is missing appears" because directory not found. I can' return to main menu after cancel, only exit app. But the clover directory exists. 

 

  Hide contents

1671235629_Capturedcran2021-05-2814_01_23.png.2301a242ca6e730c8ed999e2a2ea6418.png

 

Sorry for my bad English

you can't return to main menu because, if you do not agree to download and install Clover, there's no point to proceed...

the fact you already have a Clover folder present into src is strange it shouldn't be, as if its found obviously the process will exit, since cloning from git do not overwrite existing directories.

then please re-download v.1.3, as in very first there was a string i forgot to remove, maybe you didn't notice this and still having some issues..

 

About the output folder not created that is the big problem for your installation failure.

it normally is created as soon the download/build process initiate so no wonder it fails, but i've no valid explanation abut it, seems as some kind of privileges issue, which anyway being on User directory should not be possible.

Edited by LAbyOne
8 minutes ago, LAbyOne said:

you can't return to main menu because, if you do not agree to download and install Clover, there's no point to proceed...

the fact you already have a Clover folder present into src is strange it shouldn't be, as if its found obviously the process will exit, since cloning from git do not overwrite existing directories.

then please re-download v.1.3, as in very first there was a string i forgot to remove, maybe you didn't notice this and still having some issues..

 

About the output folder not created that is the big problem for your installation failure.

it normally is created as soon the download/build process initiate so no wonder it fails, but i've no valid explanation abut it, seems as some kind of privileges issue, which anyway being on User directory should not be possible.


@LAbyOne I re-download v.1.3. In the menu, I force download again Clover git In the existing src folder. Then I build again, the output folder is created. So I can create CloverPKG :)

  • Like 1
1 minute ago, Matgen84 said:


@LAbyOne I re-download v.1.3. In the menu, I force download again Clover git In the existing src folder. Then I build again, the output folder is created. So I can create CloverPKG :)

Glad it finally worked, still can't understand why you were having that issue with output not created...

  • Like 1
  • Thanks 1
Posted (edited)

UPDATE  its now Menulet

Some infos about this version.

Its advised to delete any old release before testing.

as this one and app versions have been updated

How it works:
Once launched it will just sit on top your menubar 

to activate just click on the Icon and main Window will show up

Quit Options.

By pressing quit from any window other then Main Window the menu will stay operational so you can recall the app whenever you need

To completely exit the application you have to choose to Quit From Main window.

 

Please let me know  what do you think about 

 

 

 

 

Edited by LAbyOne
  • Like 2
  • Thanks 1
Posted (edited)

Hi @LAbyOne

I uninstall completely Clover Suite Builder v1.3 with App Cleaner & Uninstaller app. Then I install v1.3.rc2

 

  • Installation in menu Bar : OK
  • Can't test build, and Update because there is no new commit
  • MakePKG works as usual
  • When I close the app from menu, I can relaunch from menubar: OK

Works fine here :)

 

EDIT: When I quit Clover Suite Builder, it seems that Terminal is always open (launched) in the Dock.

Edited by Matgen84
  • Like 2
Posted (edited)
12 hours ago, Matgen84 said:

Hi @LAbyOne

I uninstall completely Clover Suite Builder v1.3 with App Cleaner & Uninstaller app. Then I install v1.3.rc2

 

  • Installation in menu Bar : OK
  • Can't test build, and Update because there is no new commit
  • MakePKG works as usual
  • When I close the app from menu, I can relaunch from menubar: OK

Works fine here :)

 

Well we'r at final steps it seems.

 

12 hours ago, Matgen84 said:

EDIT: When I quit Clover Suite Builder, it seems that Terminal is always open (launched) in the Dock.

 

Done!

Edited by LAbyOne
  • Like 1

Updated exit function

as per @Matgen84 remark

 

Clover Suite Builder 1.3r3 available in Main

my Only warning about it IS:

be aware as you'r running Terminal, when quitting last window, will also kill the process.

in other words, its strongly advised to not do parallel jobs when using this application.

 

P.S.

very silly i know,

i also updated PlistEDplus and QTiasl icons, if you want to try the new look simply download them via Tools...

icons created by me ofc 

PP.SS

@ic005k if you happen to like them, feel free to use them for your project.

  • Like 2
Posted (edited)

Hi @LAbyOne

I migrate my IvyBridge config from Mojave (Xcode 11.3.1) to Catalina (Xcode 12.4). When I launch (click) v1.3r3: the menu let is activated, but the app don't launch automatically.  I must right click on menu let icon, to open terminal windows. Is it normal  :cry:

Sorry for my very bad english

Edited by Matgen84
2 hours ago, Matgen84 said:

Hi @LAbyOne

I migrate my IvyBridge config from Mojave (Xcode 11.3.1) to Catalina (Xcode 12.4). When I launch (click) v1.3r3: the menu let is activated, but the app don't launch automatically.  I must right click on menu let icon, to open terminal windows. Is it normal  :cry:

Sorry for my very bad english

 

@Matgen84

 

On 5/28/2021 at 10:02 PM, LAbyOne said:

UPDATE  its now Menulet

Some infos about this version.

How it works:
Once launched it will just sit on top your menubar 

to activate just click on the Icon and main Window will show up

 

i thought it was already clear, since you already tested and agreed on the terminal will activate if the menu is clicked.

that's the way it is.

  • Thanks 1

Hello little update,

found a typo into Cloverplistvalidator function which caused an error during checks,

in the mean time....

I reverted back the Quit behaviour to exit, I'm sorry probably some of you will not like

this but the logic why i did so reside in practical reasons.

I don't know how many among you, use the terminal in daily basis, and having such a kind of 

behaviour, becomes very unpractical for those who do use it very often.

So here we go latest release

in main thread, is now Clover Suite Builder 1.3r4

 

×
×
  • Create New...