Jump to content

Hackintosh Catalina on Asus K56CM cannot boot without usb


8 posts in this topic

Recommended Posts

Hi guys, I'm having a lot of trouble with my mackintosh boot settings. I have correctly installed Catalina on my SSD Adata 128GB using UEFI mode but when I remove the usb used for the installation I cannot boot Catalina. Looking ad the boot table inside bios I can not find a UEFI:Adata booting option, on the contrary I can find two "Mac OS X" booting options, I tried to select it but it doesn't work. The only way to boot Catalina is from clover on the USB and selecting form clover boot option "Boot macOS from data".

I tried also to install clover inside the EFI partition on Adata drive but no luck, Tried to copy the EFI folder from the USB EFI partition to the ADATA EFI partition but anyway no luck!

How can I solve this insidious problem??

 

HARDWARE:

Motherboard K56CM Asus

Intel core i3 3227U 1,8GHz

8 GB 1600 MHz DDR3

Intel HD Graphics 4000

Nvidia 635M 2GB  (Not used)

 

 

What is happen?

You copied EFI folder from the USB stick to ADATA EFI partition then reboot and choose a boot option. What did you see? Is there any option to see UEFI boot?

What your BIOS told you?

Yes, I copied the entire EFI folder from the USB stick to the ADATA EFI Partition (I used clover configurator to mount the partition) then at reboot I tried to chose a different boot option instead of USB stick (attached my boot options). As you can see in the picture just the hp x750w (my USB stick) have UEFI boot mode. 

I did some tests:

- Tried to install clover Uefi mode without copying the efi folder from the stick, my intent was to see if I can boot clover from adata without the stick but no luck.

- Tried to enable CSM boot mode and override boot from "Mac OS X", no luck, it just comes back to bios.

- Tried to install clover legacy mode on ADATA, enabled CSM boot mode and boot from "Mac OS X",no luck.

- Tried o add manually a boot option (I added adata as you can see, path: FS0:\EFI\BOOT\BOOTX64.EFI) no luck again.

 

I simply cannot boot clover from the ADATA, where is my fault? 

I would prefer to boot via UEFI but also legacy mode doesn't work.

 

IMG_5914.jpg

Well. Some BIOSes have some restriction what to boot.

Create a folders in your adata/EFI partition

/EFI/Microsoft/boot/

and place here the file bootmgfw.efi which will be CloverX64.efi renamed.

May be your BIOS will find this file.

Nothing to do... I created the folder, copied and renamed the file but stil nothing. 

My bios can see the usb efi that doesn't contain a microsoft folder. I really don't understand why I cannot boot clover from the adata since the efi folders on te stick and the adata disk are the same.

 

Btw, I disabled secure boot mode, Adata and the stick are both Guid partition map

I can add manually a boot option, there the photo:

IMG_5917.thumb.jpg.cc23dd5619d10204c714a305fb6dfb6b.jpg

 

I tried to add a manual boot option with the following path: FS0:\EFI\BOOT\BOOTX64.EFI

 

I have another question, why if I open clover under the mount efi section I can find "clover boot option" near the efi partition of the stick? How can I set the efi partition of the adata as clover boot option? Is there a way?

IMG_5916.thumb.jpg.cb3e7494fc5c68c53a67163328d2dcc2.jpg

You shown me what you want.

EFI partition on the ADATA drive is not on the APFS volume.

GPT formatted drive contains, for example

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI ⁨EFI⁩                     209.7 MB   disk0s1
   2:                 Apple_APFS ⁨Container disk1⁩         399.0 GB   disk0s2
   3:                 Apple_APFS ⁨Container disk2⁩         171.8 GB   disk0s3
   4:       Microsoft Basic Data ⁨Change⁩                  29.6 GB    disk0s4
   5:       Microsoft Basic Data ⁨Windows10⁩               199.5 GB   disk0s5
   6:           Windows Recovery ⁨⁩                        554.7 MB   disk0s6
   7:         Microsoft Reserved ⁨⁩                        16.8 MB    disk0s7
   8:                  Apple_HFS ⁨DataHD⁩                  199.2 GB   disk0s8

See EFI partition and other partitions.

In the BIOS you have to choose EFI partition and find here CLOVER.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...