Jump to content

efi_inject_get_devprop_string NULL trying stringdata ?.


2 posts in this topic

Recommended Posts

Hello,

 

 

After successful installation using boot flags "-v -x -f cpus=1 busratio=25", I haven't been able to boot Snow Leopard afterward as the computer restarts itself after about 2 minutes of loading kexts. These are the last lines seen on the bootloader screen before the restart:

Loaded HFS+ file...................

Loaded HFS+ file......................

nVidia Unknown 0MB NVc0 [10de:06ca] :: PciRoot(0x0)/Pci(0x7,0x0)/Pci(0x0,0x0)

No SMBIOS replacement found.

Patched DMI Table.

No DSDT replacement found. Leaving ACPI data as is

Starting Darwin x86

 

I've since gotten rid of "nVidia Unknown" message after deleting "TMSafetyNet" in System\Library\Extensions\TMSafetyNet.kext\Contents\MacOS, but now it's been replaced by:

efi_inject_get_devprop_string NULL trying stringdata

No SMBIOS replacement found.

Patched DMI Table.

 

...and then system reboot.

 

 

 

thanks

jackyjoy

  • 2 weeks later...

@jackyjoy123 Your Snow Leopard bootpack/settings/installation arrangements are obviously incorrect.

  1. -x flag boots OS X in safe mode, i.e. a reduced mode that excludes many things including graphics support and several other things. It's only suitable for troubleshooting, not for installation and normal operation.
  2. 10de:06ca is NVIDIA GeForce GTX 480M, a mobile GPU for laptops. It's a Fermi dGPU and those are only supported from Lion 10.7 to El Capitan 10.11 (very buggy support in Sierra/High Sierra, unsupported afterwards). Therefore, it's not suitable for Snow Leopard in which it's totally unsupported due to lack of drivers.
  3. if you've had to use cpus=1 and busratio=25 boot args, there's a good chance your current setup does not properly support the CPU natively and lacks CPU power management.

Please provide:

  • your full computer specs (type, exact CPU model, chipset, graphics card, audio codec, LAN, Wifi, etc.) to assess suitability as a Hackintosh and best compatibility with Mac OS X/OS X/macOS.
  • the nature and version of bootloader you've used (Chameleon/Enoch/Clover/other)
  • a zipped copy of the bootpack you've used (Extra folder for Chameleon/Enoch, EFI folder for Clover)
  • the exact version of SL you're trying to install (can only be SL retail versions (i.e. 10.6(.0), 10.6.3 or 10.6.8), all the others being recovery versions that lack some of the files required for full installation)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...