Jump to content

HD not being shown on Catalina installation screen


14 posts in this topic

Recommended Posts

Hello Guys, how are you?

 

I am trying to install macOS Catalina on a Dell Inspiron 7559. When reaching the instalation screen, my HD is not listed. I have already used Gparted on Ubuntu to format it into HFS+ and have already added AHCIPortinjector.kext and the SATA-unsupported.kext to my Clover Kexts file. My BIOS is already in AHCI, secure boot off and everything as required on the tutorials.

 

Do you have any idea of what I can do to proceed?

 

 

Thank you for your time

Ok, so I booted my Ubuntu using a Flash Drive and tried to convert my HD to HFS+ using Gparted, which is the corresponding format for APFS (at least that's what I found on the internet), and then I used the command sudo mkfs.hfsplus -J / dev / sdaX to make it Journaled. I changed the flag to Raidpow as well. It did not work. Do you have any suggestions of how I can convert my HD?

Just tried it, did not work. I did not know how to create the Partition table, actually, so I thought maybe this was gonna solve it. Just one question, do I have to convert it to HFS+ after creating the Table? Or this second step is gonna make me lose the first one? I'll Try it any way, but who knows

theoretically, you didn't have to do anything with GParted, especially if you want to allocate the hard disk entirely to MacOs.
Disk Utility should do everything during installation. I can't understand how it can't see the disc.

Good morning guys. I remade my usb drive with an Olarila Mojave img. I reset my BIOS and tried to install it again. It worked and I was able to install the macOS. I had one problem with the Clover installation but I'll manage it now. I'll let you know if I can get it completely right. I still needed Gparted to create the Partition table and format the hd to hfs+, but once it was done, it was recognized.

All right, so, I was not able to make it work. I can install it but if I want to reboot it, I get a BIZARRE error. If I just try to reboot, it gets stuck with a single "-" on the screen and does nothing. I have to do this: I installed it in Legacy mode, so when I reboot, I have to go into BIOS configs, change to UEFI, save and reboot, go into BIOS configs again, change it back to Legacy, save and reboot and then I get to access the system. Yesterday I reset my BIOS completely by removing the coin batery to get everything completely clean because this was already happening and I had some Boot options that weren't even on my pc anymore, such as Windows and Manjaro. Once reinstalled, I tried booting whitout the usb drive as well to check if my Clover was correctly installed but it gives me a boot error right away.

 

I am trully lost. I don't wanna give up and I'll try more images and clover instalations again. If you guys have any idea of why this is happening to my bios, I'll be trully gratefull.

I actually tried once. Followed step by step and couldn't achieve it. I'll try again, now that I have some more knowledge, maybe I'll see some steps that could have missed (which is actually pretty hard to happen, their tutorial is really thorough, but who knows).

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...