Jump to content
5 posts in this topic

Recommended Posts

So I read the Opencore guide, and I Googled for anything I could find. This SHOULD be a simple fix. But it's not working for me. Here's what I've done. I never had the issue with it not coming up as en0, it did from my 1st boot.

 

removed the NetworkInterfaces.plist & preference.plist and rebooted

downloaded Hackintool and exported the PCIE list, found the one for my NIC, copy and pasted it into my config with the data field "built-in" and 01. When I reboot and go into Hackintool there's still no check next to Builtin.  Now I'm new to Hackintosh so I'm not 100% sure how other things tie in, or if something else matters here. But I checked my NVram and it's emulated properly, and my system as a whole seems to be working normally.

 

This is what's in my Config under DeviceProperties/Add

PciRoot(0x0)/Pci(0x1C,0x3)/Pci(0x0,0x0)

built-in <data> 01

 

This is what Hackintool's telling me for my NIC

 

PciRoot(0x0)/Pci(0x1C,0x3)/Pci(0x0,0x0)

 

I've tried just Pci(0x1C,0x3) in my Config (shot in the dark)

 

There was one other entry in the DeviceProperties/Add section, but nothing's coming up in the exported Hackintool list of PCIE devices. So I have no idea what it could be. I do have a USB Bluetooth dongle, but I'm not sure how to find the Pci location of it, if it even has one. I want to identify what the device. I did try removing it and rebooting to see, and nothing seemed to change.

 

The only thing I can possibly come up with is I'm still booting from my USB stick, and OSX needs to be fully booting with the EFI partition on the HD and not a Flash drive.  The HD boot guide didn't work for me, apparently because I have an ASRock MB and you have to do some work around stuff to get it working. And the only 2 guides I've found both require a formatted flash drive. And ATM I only have the 1 and it has my Opencore booter on it so I don't want to mess with it and potentially make my system unbootable. I will be getting another stick in a few days. But like I said, I don't even know if that could be the problem, just all I was able to come up with in my head.  Because the guide to fixing this isn't complex at all.  I use ProperTree whenever I edit the plist files so I don't mess up the formatting.

 

 

 

 

 

 

 

Edited by quebert

You're really not good at all this: no mention whatsoever of the LAN card model, no saved IOReg output. Injecting "built-in" property is unnecessary.

 

Anyway, what's the problem and impact here?

Sorry, I'm very exhausted from troubleshooting so my brain's only half working. No excuse though, in the future I'll be mindful of adding the relevant information and attaching files.  NIC's Broadcom BCM57781, and I'm trying to get it enabled so I can use iMessage, the guides to fixing iMessage I've read all say it's a requirement.  I have followed the guides for everything minus that and am unable to connect so I can use imessage.

Heres my IOReg file.

 

IOReg.zip

A good night sleep should do indeed: posted IOReg shows Broadcom LAN card registered as en0...

LAN_en0.jpg

 

No working wireless on the other hand and I don't believe that Realtek RTL8191 (10ec:8172) is supported. Replace it with a supported wireless card or supported USB dongle.

Wireless.jpg

I don't even use Wifi, so I'm not worried about it not being supported. It's there and I don't think it's something I can disable in my BIOS.  Since my NIC's en0, and the change I made should fix the builtin. I guess I just need to chalk it up to iMessage might not work for me, not without a stupid amount of effort. oh well.

 

Thank you for the reply. At least I know now I was doing it right when I tried to fix it, it just is something unusual for me - my luck.

×
×
  • Create New...