Jump to content

GUI Custom Entry for Big Sur Preboot - how to?


BuXb
 Share

11 posts in this topic

Recommended Posts

Anybody here managed to

  1. create a GUI custom entry for Big Sur Preboot labeled "Big Sur" or alike so it does not always appear as "Mac OS X from Big Sur via Preboot" in Clover boot screen?
  2. hide the Big Sur system entry?

Still not working here neither with Clover 5128 nor with latest Clover nightly...

 

My system info: macOS installs and volume labels: Big Sur, Catalina, Mojave

 

Big Sur Preboot:
APFS volume name/ label: Preboot

 

Volume: PciRoot(0x0)\Pci(0x17,0x0)\Sata(0x1,0xFFFF,0x0)\HD(6,GPT,233EA3E0-9DBD-49F2-8F51-DA57BCC54B87,0x8CF0000,0xDACB000)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,7BE84A7CA39E5F4C8755EACFB18751E5)

 

UUID: 233EA3E0-9DBD-49F2-8F51-DA57BCC54B87

 

APFS File System UUID: 7C4AE87B-9EA3-4C5F-8755-EACFB18751E5

 

APFS Container UUID: 2466E13F-E4BB-4B37-BD4D-DCD0E74E83CE, ApfsRole=0x10

 

APFS target UUID: BA2910E1-CEA3-4140-88E3-89C70BCF433E

 

Could you please share your GUI section from Clover config.plist if you have a working custom entry? Thanks.

Link to comment
Share on other sites

Reply to your comment on GitHub here, just to not bother that issue (not related to Custom GUI entry): https://github.com/CloverHackyColor/CloverBootloader/issues/300#issuecomment-768551661

 

So yes, of course here are the logs and the screenshot. That is on Clover v5129, entry is working as before, Recovery (finally) also working.

EDIT: A note: I have FileVault enabled, so I don't have the "main" partition, just a Preboot, therefore I didn't hide anything inside my config.plist

 

Spoiler

screenshot1.thumb.png.cadb799bd1eb5bdd58ec8efcf8120205.png

 

2021-1-27_20-25-39_CLOVERX64.efi.log

Edited by kushwavez
Link to comment
Share on other sites

Great, thank you @kushwavez !

 

What's different is that your output for Preboot is missing the APFSTargetUUID=7434A65C-9925-47BB-A6FE-95753DA18597

 

Also your UUID for the path is 7434A65C-9925-47BB-A6FE-95753DA18597 which is the apfsFileSystemUUID of your Volume with Big Sur DATA, Macintosh SSD - adatok.

 

Your hint with Filevault might be it because I don't see any other difference to my setup, apart from that I also have Mojave installed in the same APFS container - but that install has it's own UUID folder inside Preboot.

 

Not sure what to make of this issue, though. I might just need to let it slip for now until Clover allows to simply boot Big Sur by its volume label as custom entry. The OC code is open source so I honestly don't get anyway why they have not been able to implement OC's slick way of displaying Big Sur, and booting Big Sur (automatically via Preboot in the background by itself w/o any user side need for GUI hacking).

 

Oh well.

 

I'd let you know in case I can report any progress. Again kudos for your collaboration B)

 

Link to comment
Share on other sites

@kushwavez I just figured it out - it's a BUG in Clover!!

 

For this custom entry, Clover 5129/ 5128 and probably older ONLY look in OTHER for kexts to be injected and totally disregard my 11 folder, which is working fine when booting via the default Preboot icon.

 

For testing I also created a 11.2 folder with kexts, but that did not help, either.

 

I'll file an issue over at github tomorrow nite, have to catch some sleep now urgently (have to get up early).

 

(who woul've thought that's it, geez..)

 

  • Sad 1
Link to comment
Share on other sites

yep, just tried it and as you said, with Custom entry our kexts are won't load from CLOVER/kexts/11

From log I can see that seems like kexts are being searched and added to the array, but won't load after that.

0:826  0:000  === [ InitKextList ] ============================
0:831  0:005  Added Kext=11\VoodooRMI.kext
0:832  0:001  Added Kext=11\VoodooSMBus.kext
0:833  0:000  Added Kext=11\AirportBrcmFixup.kext
0:833  0:000  Added Kext=11\AppleBacklightSmoother.kext
0:834  0:000  Added Kext=11\BrightnessKeys.kext
0:834  0:000  Added Kext=11\HibernationFixup.kext
0:835  0:000  Added Kext=11\IntelMausi.kext
0:835  0:000  Added Kext=11\NVMeFix.kext
0:836  0:000  Added Kext=11\Sinetek-rtsx.kext
0:836  0:000  Added Kext=11\SMCBatteryManager.kext
0:836  0:000  Added Kext=11\SMCLightSensor.kext
0:837  0:000  Added Kext=11\SMCProcessor.kext
0:838  0:000  Added Kext=11\SMCSuperIO.kext
0:838  0:000  Added Kext=11\USBPorts.kext
0:839  0:000  Added Kext=11\VirtualSMC.kext
0:839  0:000  Added Kext=11\YogaSMC.kext
0:840  0:000  Added Kext=11\VoodooPS2Controller.kext
0:841  0:001  Added Kext=11\WhateverGreen.kext
0:842  0:000  Added Kext=11\Lilu.kext
0:851  0:009  Added Kext=11\AppleALC.kext
0:856  0:005  Added Kext=11\BrcmBluetoothInjector.kext
0:993  0:000  AddKextsInArray from Other
0:993  0:000  AddKextsInArray from Off
0:993  0:000  AddKextsInArray from Unknown

There is no "AddKextsInArray from 11" so the kexts won't load.

 

I think the reason is because of the "config.plist/GUI/Custom/Big Sur/Type=OSX" -> I think this can't determine what is the OS version, while if I boot for example from Recovery it's working because no Type is specified, and the OS version is determined by Clover automatically.

 

2021-1-28_8-21-27_CLOVERX64.efi.log

Edited by kushwavez
Link to comment
Share on other sites

Oh yes tried that too.

The entry is being showed, but Clover won't detect the entry type automatically so it doesn't even start loading.

For Custom entries Type is needed.

Edited by kushwavez
  • Sad 1
Link to comment
Share on other sites

  • 3 months later...
 Share

×
×
  • Create New...