Jump to content

[GUIDE] How to update Clover for BigSur compatibility (and beyond) using OpenRuntime and Quirks (r5123+)


5T33Z0
81 posts in this topic

Recommended Posts

4 hours ago, 5T33Z0 said:

@BuXb So concluding from this the bug report if you put and leave your kexts in "other", there won't be any problems with  Big Sur, right?

the bug has been solved. With the fixed Clover boot efi provided by Jeff towards the bottom of that issue thread, Clover now also injects kexts from the 11 folder as supposed if Big Sur is booted. The fix is committed so will be in Clover next stable release.

Quote

Also, it seems that the guy who reported the issue just created a subfolder in kexts called "11" and expects Clover to recognize it. I think that path has to be hardcoded into Clover's code to be found. So it's not really a bug it's more like an error on the user's end I think.

sorry but that's wrong, 11 is the appropriate general folder for Big Sur kexts (and so is 11.1 for Big Sur 11.1, 11.2 for Big Sur 11.2 etc.). So if needed in cases of incompatibilities with other macOS one boots parallel, one can have kexts in Other, 11, 11.2, 10, 10.15 etc. :)

Link to comment
Share on other sites

Hi

I am trying to install Catalina on an HP EliteBoot 840 G2 (i5-5300U Graphics HD5500 2c4Gb RAM bios M71 1.31)

 

Once I select Install Catalina from the menu, I am stuck with a line os "+" at the top of the screen, and the log ends with the following 2 lines :

50:825  0:111  OC: Prelinked status - Success
50:945  0:120  OCSMC: SmcReadValue Key 4D535463 Size 1
51:048  0:102  OCSMC: SmcReadValue Key 4D534163 Size 2

 

Any idea ?

 

I put my config.plist, preboot and log files

 

Thanks for your help

config.plist 2021-2-3_22-39-13_Bootx64.efi.log preboot.log

Link to comment
Share on other sites

  • 2 weeks later...

Thanks, got it work Clover v5129

Edit:  I hided macoOS (disk3s5) and it works. 

 

Since Preboot is now used, which once below (blue) show I hide so it's not showing in Clover Menu? Thanks!

1:                APFS Volume ⁨macOS - Data⁩            238.5 GB   disk3s1

   2:                APFS Volume ⁨Preboot⁩                 325.2 MB   disk3s2

   3:                APFS Volume ⁨Recovery⁩                613.7 MB   disk3s3. (hidden)

   4:                APFS Volume ⁨VM⁩                      2.1 GB     disk3s4. (hidden)

   5:                APFS Volume ⁨macOS⁩                   15.1 GB    disk3s5

   6:              APFS Snapshot ⁨com.apple.os.update-...⁩ 15.1 GB   

Screen Shot 2021-02-13 at 11.49.41 AM.png

IMG_0473.jpg

Edited by loganMac
Link to comment
Share on other sites

config5114.plist

 

i have running sandy bridge with catalina boot clover 5114, and after upgrade clover (fresh install to usb), big sur installer finish, and i got preboot volume shown in clover, but doesnt work when boot to the preboot big sur and catalina too. stuck on "++++++" mark before booting mac os

config5129.plist

Link to comment
Share on other sites

Sorry for highjacking but probably this is good for those who follow your guide and cannot connect to server when signing to iCloud.  OC had a different name from Clover.  

I wasn't able to connect to my iCloud even thought I can surf the net.  It kept showing cannot connect to server.  I follow Dortania Fixing en0.

 

First:

In your Setting,--->  Network -->If your Does Not say "Ethernet" (I'm Wired) then you're likely en01 "built-in" is not checked under  HackinTool info.

For me, I felt confused because Dortania explain based on OC not Clover.

 

2nd:  In Terminal:

sudo rm /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist
sudo rm /Library/Preferences/SystemConfiguration/preferences.plist

Then Reboot.

 

Finally: See screenshot

Note: In step #5, you type in built-in under Properties Key and 01 under Properties Value and Value Type as Data then Save and finally Reboot.   After reboot, your Network should show "Ethernet".   I

Successfully connected to iCloud.  

217746583_ScreenShot2021-02-20at7_55_22AM.thumb.jpg.71b8636397a22f4641a075a95c807077.jpg

 

Again sorry @5T33Z0 for highjacking.

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

On 11/22/2020 at 11:39 PM, 5T33Z0 said:

On the weekend I tried to build clover for my current desktop as well with all the necessary settings taken over from my working OpenCore config and I got stuck as well. The "[EB LOG:EXITBS:START]" error seems to be an issue with the 5126 release: https://github.com/CloverHackyColor/CloverBootloader/issues/309

any advancement on that EXITBS:START error?

Link to comment
Share on other sites

52 minutes ago, Vampirexx said:

Привет всем, я устанавливаю bigsur на старую машину с процессором Intel и Intel hd2000 gpu, наконец, я достиг установки с последней версией клевера, но я не могу установить big sur на отформатированном apfs macintosh hd или даже на файловой системе macos jurnal, кажется, ssd только для чтения быть? Какие-то настройки причуд? Smbios imac13,2 для работы gpu

HD2000 does not work in macOS as a full-fledged video card, but it can (and should) be used with an empty frame (0 connectors) for IQSV. Only the HD3000 can work with the monitor.

Installation is possible on the following mac models:
MacBook 8.1 or later
MacBook Air 6.1 or later
MacBook Pro 11.1 or later
Mac mini 7.1 or later
iMac14. 4 or later
macpro1. 1
MacPro6, 1 or later

Edited by Антико
  • Thanks 1
Link to comment
Share on other sites

On 2/28/2021 at 11:49 AM, Vampirexx said:

Hi all im installing bigsur on an old machine with intel cpu and intel hd2000 gpu finally i reached installstion with clover last version but i cannot install big sur on formatted apfs macintosh hd or even on macos jurnal file system it seems a read only ssd what might be? Some quirks settings? Smbios imac13,2 to make gpu works

If you have problems with GPUs, you can search in the Graphics Cards section.

 

This topic has nothing to do about GPUs...

Link to comment
Share on other sites

I finally get the Clover 5130 to work with my HP EliteBook 820 G3 Skylake i7 6600U HD520 perfectly because I couldn't get OpenCore 0.6.6 to dual boot Windows 10. Clover if you get it working, to me it's much more stable and better with HP laptops. OpenCore and Clover have their + and -, just have to find the best one for my hackintosh. Yes, Big Sur is harder to load and perform perfectly than Catalina.

Cheers,

Louis

 

 

configpro132_clover_sample.plist.zip

  • Like 2
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

I think something is still wrong with Clover, it doesn't seem to load the graphics UHD 620 frame buffer as OpenCore 6.4 or 6.6. Use the same iGPU properties for both boot loaders and OpenCore loaded but Clover doesn't. The same clover 5130 loaded fine with 591b on my Envy 13 i7-7500u using macbookpro14,2, but not on Dell i7-8650u 591e.

Screen Shot 2021-04-05 at 3.38.28 PM.png

Screen Shot 2021-04-05 at 3.53.40 PM.png

Screen Shot 2021-04-05 at 3.54.32 PM.png

Link to comment
Share on other sites

Posted (edited)

@ltooz_audis

 

That's because you entered the data in the wrong location. I've told you and shown you in an earlier post where the framebuffer patch belongs in Clover. It belongs in Devices > Properties > PciRoot(0x0)/Pci(0x2,0x0) and not in Devices > PciRoot(0x0)/Pci(0x2,0x0)…

 

 

702010356_CloverFramepufferPatch.png.8b297d456fb986db4bed458038a78100.png

Edited by 5T33Z0
  • Like 2
  • Thanks 1
Link to comment
Share on other sites

  • 5T33Z0 changed the title to [GUIDE] How to update Clover for BigSur compatibility (and beyond) using OpenRuntime and Quirks (r5123+)
  • Slice locked and unlocked this topic
×
×
  • Create New...