Jump to content

(SOLVED!) Asus tp412u OpenCore, no touchpad and battery indicator


9 posts in this topic

Recommended Posts

EFI.ziphi all,

I had a rather smooth installation of Big Sur on my ASUS VivoBook Flip TP412U (i7 8550u) with OpenCore.

Many things work fine (or almost fine), I have wifi and sound, USB ports work etc.

But I cannot get the battery indicator to show up and my touchpad isn' t working at all.

I tried various ssdts and kexts (like ssdt-batt.aml for battery and Voodoops2controller for touchpad) but nothing worked. The keyboard works fine though...

 

My efi folder contains the following:

(I did not include AirportItlwm.kext in the Kexts folder because the .zip was over 10MB and I could not upload it)

 

Any ideas?

thank

 

 

EFI.zip

DSDT.aml

Edited by makisf4

My laptop is the same model as yours and I would really appreciate it if you would patch the working DSDT for the trackpad! Thanks

My laptop is the same model as yours and I would really appreciate it if you would post the final working EFI! Thanks.

Edited by giampietro
  • 2 months later...

Hello, my laptop is not Asus, but the touchscreen is USB-HID also,... and I can't make it work. Can you tell us the Vendor ID and Product ID of your touchscreen?

You can get it from the System Information app, in the USB section. In my Yoga 460, it is 056A/504a (Wacom pen and multitouch sensor).

Thank you!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...