Jump to content

[SOLVED] XPS 9550 Slightly dim the display.


12 posts in this topic

Recommended Posts

Hi everyone.

I´m happy with my XPS 9550 with Catalina, kinda old but yet a great laptop. Everything works as it should with the exception of the "Well Know" incompatibilities which at the end of the day doesn´t make any difference for me.

But there´s one thing which I can survive without it but it would be really nice to have: Dim the display when the power source is disconnected although brightness control works at the keyboard and the brightness is remembered between reboots.

I have searched the forum and I couldn´t find any mention about it. I know there´s something somewhere but I just wasn´t able to find it.

So I wonder, what could it be? Someone can point me in the right direction?

Any help will be really appreciated.

Thanks in advance.

 

 

Edited by Sutil
solved

I’ve been struggling with this on my laptop as well. No matter what I try I cannot get it work and have to do it manually every time. I know for a fact it used to work (cannot remember when) but now it does not with both Catalina and Big Sur.

 

 

Sent from my iPhone using Tapatalk

I got some results using Power Manager https://www.dssw.co.uk/powermanager/ to watch for the event when the power cord is disconnected and then call a shell script. At the shell script I used the brightness utility to set the display brightness at 50%.

It worked everytime and when the power is connected again automatically the display goes back to previous setting. It seems that Power Management is doing its job when the power is connected which is great. We don't need a script to manage the opposite way.

But hold your horses...when you wake up the laptop by touching the keyboard/trackpad or opening the lid you get a reboot :(.

Removing the Power Manager "scheduler"  solves the problem but since we don' t have anything listening for the events it won't work.

The problem IMO is the way Power Manager is handling or hooking up the events so if we get something different to do that...we' re gold.

Anyway I was happy for 2 hours...

If you anyone are willing to try I can give the directions if needed.

Cheers.

 

 

 

EDIT:

Doing a little more research I just found that everything described above can be made using Applescript, so I will give a shot since it's cleaner and there's no third party software involved.

Edited by Sutil
Completeness
7 hours ago, SavageAUS said:

To fix this issue for me i just used the SMCLightSensor.kext.

I first checked my DSDT for a device ALS0.

I am using clover 5124 so i just placed kext in EFI/Clover/Kexts/10.15 & 11/ folders and its working.

I have no idea how to do that and I'm using opencore. Can you share your DSDT? I already have SMCLightSensor.kext on my EFI partition.

23 hours ago, SavageAUS said:

Do you have a device in your dsdt named ALS0?


Sent from my iPhone using Tapatalk

I do not.

 

But I used Hackintool to dump the dsdt and I found the dsl file for the ALS0

 

Edited by Sutil
+ info
1 minute ago, SavageAUS said:

Can you post your EFI ?


Sent from my iPhone using Tapatalk

 

 

@SavageAUS, you're great!

I just copied the ALS0 aml file dumped by Hackintool to my /EFI/OC/ACPI and rebooted with my config.plist updated and it worked.

Thanks for your help. I hope this thread can help other people in the future.

 

 

×
×
  • Create New...