Jump to content
About Just Joined group Read more... ×
rvilbert

Help for Catalina 10.15.6 installation on Asus X99 Deluxe

3 posts in this topic

Recommended Posts

Good evening,

 

I apologies for the broadcast message but i have decided to reinstall my Hackintosh machine using Catalina 10.15.6 and .... I'm stuck at "PCI configuration begin".. :wallbash:

 

My configuration is:

  • Asus X99 Deluxe
  • Core i7 5960x
  • 32 Gb memory
  • GTX 980

 

Knowing that my graphic card would not be fully recognised in Catalina i have also tried to install High Sierra but I managed to get exactly to the same point :wallbash: and i have therefore decided to give another try to Catalina and .... I'm still stuck.

 

(FYI I had managed to install 10.8 on my machine a while ago but a few things have changed since then and I may be missing a trick).

 

In a nutshell I believe my issue is linked to this message that i'm getting:

 

Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourcesMatch</key><string ID="2">boot-uuid-media</string></dict> 

 

I tried all options (with/without flags and with/without kext) but i think that my issue is between my DSDT, SSDT and config.plist files.

 

Any help would be much appreciated!

 

I have attached my EFI folder and the print screen with the error message.

 

Let me know if you need any further information.

 

Thanks a lot

 

 

 

 

IMG-5585.jpg

EFI.zip

Share this post


Link to post
Share on other sites
Advertisement

add npci=0x2000 or npci=0x3000 to your boot flag and then it should work.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/y6avuxsv
       
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/y6avuxsv
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
      USB INTEL SERIE 400.zip
       
      Use these kexts, enable XHCI port limit patch and follow this tutorial for remap USB ports
       
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By tapochek2004
      Hello. I am experiencing a problem with my Catalina vanilla installation.
      My Dell 7567's screen is constantly blinking. This started in the installer and persisted after successful installation. Apart from the mentioned, the system is working perfectly fine.
      I am able to disable the backlight completely by pressing F11/brightness down button. I am barely able to see the on-screen text using a desk lamp afterwards.
      I have tried installing AppleBacklightFixup.kext, Lilu.kext and WhateverGreen.kext and setting my SMBIOS to iMac18,1 but none of those proposed solutions have helped me so far.
      To illustrate the problem, I have recorded a video (link) of my laptop booting into the installer and then shutting down. I have also included my CLOVER folder.
       
      I would appreciate any help or advice.
       
      Best regards, Luka
      CLOVER.zip
    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi.  A possible solution is here, but I am NOT offering any support for this.  
      macOS Installation 
      Important: You MUST BE LOGGED-IN to download attachments from this forum
      See macOS installation steps here See Known Issues here for additional installation steps that may not yet be included in my attached config files See CLOVER (UEFI) installation later in this first post
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Microphone port  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the USBPorts.kext in the attached EliteDesk800.zip archive) Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card). A possible solution is here, but I am not offering any support for this.
       
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A or 02.12.00 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers OcQuirks (replaces AptioMemoryFix) Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here and here to understand my graphics properties for use with WhateverGreen.kext Read this to see my attempt at graphics patching without WhateverGreen.kext (WEG) to get a better understanding of what WEG is doing
       
      Current Versions
      Catalina 10.15.7 Clover (UEFI) r5122 Lilu.kext 1.4.8 WhateverGreen.kext 1.4.3 AppleALC.kext 1.5.3 IntelMausi.kext 1.0.4 (acidanthera version) NVMeFix.kext 1.0.4 EFIChecikDisabler.kext 0.5  
      Credits To be provided
       
      ScreenShots
       
       
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
      EliteDesk 800 G4 Mini - Rev 1.3.zip
    • By adobasy9
      Hello everybody
      After 3 months of reading , troubleshooting , and trying different OS versions which all failed on just getting a bootable USB installer , I finally gave up and decided to ask for help , I would appreciated any advice or help you can give me .
      HP Laptop 15 da-nxxx , with a built-in battery
      CPU : i7-7500U
      GPU : HD 620 ,MX 130 " disabled with -wegnoegpu "
      RAM : 16 GB
       
      EFI Folder + DSDT.aml from SysReport
    • By amirali mahmoudi
      hi
      i have a problem since updated my opencore to 0.6.2
      My audio output is set to headphones, and every time i turn on the pc , i need set this on internal speakers
      and the other problem is that sometimes my hackintosh wake up from sleep after 2 second and sometimes its work fine
      i've checked my config.plist in sanity checker and dortania and its all good but these problems still exist 
      Can you help me out please ?
       
      asus z390 p 
      i7 9700k
      rx 590 8gb
      wifi/bt/handoff works fine
      catalina 10.15.7
      opencore 0.6.2
×