Jump to content
About Just Joined group Read more... ×
KellyK

Latest VMWare Workstation 16 - Anyone Got Catalina to Run?

26 posts in this topic

Recommended Posts

VMWare just released it's latest v16. Anyone Got Catalina to Run on it? My previous snapshot that runs fine on VMWare 15.1 no longer works.

Share this post


Link to post
Share on other sites
Advertisement

Where did you find an unlocker for Workstation 16 ?

 

Or did you use the 15.5 unlocker?  Or is no unlocker required?

 

Edited by Spera Mentor

Share this post


Link to post
Share on other sites

Old, latest Unlocker, please. Very much required - if your Host OS is Windows then any macOS VMs will NOT run without it.

 

NOTE: As a rule of thumb, always a good idea to create a snapshot, as well as power off ALL your macOS VMs prior to updating VMware Workstation from any older to any newer version (and prior to reapplying the macOS Unlocker). :)  

Edited by Naki

Share this post


Link to post
Share on other sites

Sorry confused - are you saying use the OLD unlocker?  or use the LATEST unlocker?  When you say please are you asking for someone to post it, or are you saying please use that one.

Share this post


Link to post
Share on other sites

@Spera Mentor -- please note I mean the old version i.e. there is NO new one for Workstation 16. :)

Latest one you can find! There is no need to post the exact link here, as you can find it quoted in several other threads.

Edited by Naki

Share this post


Link to post
Share on other sites

I ran the latest unlocker v3.03. What am I supposed to pick? Doesn't even start. Just says "Failed to start virtual machine".

I'm running on an AMD Threadripper.

Share this post


Link to post
Share on other sites

@KellyK -- please note this works best on older Intel CPUs mostly, I am afraid.

I am using Ivy Bridge & Haswell here for VMware Workstation (2 desktop PCs here - one with Ivy Bridge Core i5, 2nd ond with i7, and a laptop with Intel Haswell).

 

I know AMD/Ryzen is usually a problem, so likely AMD Threadripper is too. Likewise, older Intel CPUs are fine, but some newer/newest ones may not be.

Edited by Naki

Share this post


Link to post
Share on other sites
On 9/21/2020 at 11:22 AM, Spera Mentor said:

Sorry confused - are you saying use the OLD unlocker?  or use the LATEST unlocker?  When you say please are you asking for someone to post it, or are you saying please use that one.

15.5 unlocker works.  You must re-run the unlocker every single time that you upgrade VMware.

Share this post


Link to post
Share on other sites
On 9/25/2020 at 10:44 AM, Aaron44126 said:

15.5 unlocker works.  You must re-run the unlocker every single time that you upgrade VMware.

 

Ran the 15.5 unlocker, still doesn't work on AMD. Think Aaron is right, something special needs to be done for AMD chips. I had to specify the cpuids to get it to work in VMWare v15.1. That hack doesn't work anymore in VMWare v16!

 

 

Share this post


Link to post
Share on other sites

Please note I use both Intel CPUs+AMD Radeon GPUs on most of my PCs. :)

So, without using any AMD CPUs for many years now, I am still using lots of AMD products all the time. ;) I have an AMD Radeon R9 290 on 1 PC, RX 480 on 2nd one, and R9 390 on 3rd PC.

(And I have some leftover older AMD cards in a drawer too - AMD Radeon R7 260 2 GB, HD7770 1 GB. :D )

 

I have 1 fairly recent Nvidia GPU too - a 1050 Ti, but that one is in a very old PC I almost never use/turn on. 

And my old Acer Aspire laptop (now mostly dead) was also Intel CPU+AMD GPU -- had an older Intel Core dual-core/4-thread CPU, combined with an AMD Mobility HD 5650 GPU. :)

Edited by Naki

Share this post


Link to post
Share on other sites

Guys, I am using VMware Workstation 15.5.6, latest macOS Unlocker on Windows 10 Pro 64-bit OS. This is a desktop PC with an old Intel Core i5 Ivy Bridge CPU (4 cores/4 threads), 32 GB RAM with lots of it free.

Trying to update from older DP6 Beta to latest DP8/PB4 Beta of mcOS Big Sur, but VMware Workstation is currently stuck at Apple logo with progress done to around maybe 1/5th, 1/6th of the progress bar/100%, and won't move any further.

I assume/presume this is due to missing pre-linked Kernel issues?

 

Can somebody here give the pre-linked kernel files for Big Sur DP8/PB4 Beta, please? :|

Along with steps on how to use an older/working Rescue VM to rescue the failing VM running the Big Sur Beta update? 

Edited by Naki

Share this post


Link to post
Share on other sites
3 hours ago, alexnt said:

I run catalina on vmware workstation 16(works on 15.5.6 too) on ryzen 3600

Follow this guide

 

screenshot? any proof? Catalina never worked with 15.5.6 on Ryzen.

Share this post


Link to post
Share on other sites
4 hours ago, alexnt said:

I run catalina on vmware workstation 16(works on 15.5.6 too) on ryzen 3600

Follow this guide

 

Tried the guide, does not work for AMD CPU.

Share this post


Link to post
Share on other sites
7 hours ago, KellyK said:

 

screenshot? any proof? Catalina never worked with 15.5.6 on Ryzen.

That was what I thought until yesterday.

 

5 hours ago, KellyK said:

 

Tried the guide, does not work for AMD CPU.

Did you follow the guide step by step?

proof.PNG

Share this post


Link to post
Share on other sites
16 hours ago, alexnt said:

That was what I thought until yesterday.

 

Did you follow the guide step by step?

proof.PNG


thanks, would you mind sharing your VMX file pls?

Share this post


Link to post
Share on other sites
Posted (edited)
15 hours ago, KellyK said:


thanks, would you mind sharing your VMX file pls?

It won't work for you as it didn't for me on another pc. I think this happens due to information I entered from clover.

Try again and do not miss any step from the guide or do not do anything your way(the way you used until mojave) or use another unlocker.

Everything is in the guide(vmdk, unlocker) even the errors you might face during the procedure.

Also you MUST uninstall the unlocker before uninstall or update/upgrade vmware workstation.

Edited by alexnt

Share this post


Link to post
Share on other sites
4 hours ago, alexnt said:

It won't work for you as it didn't for me on another pc. I think this happens due to information I entered from clover.

Try again and do not miss any step from the guide or do not do anything your way(the way you used until mojave) or use another unlocker.

Everything is in the guide(vmdk, unlocker) even the errors you might face during the procedure.

Also you MUST uninstall the unlocker before uninstall or update/upgrade vmware workstation.

 

I'm trying to install the Mac from a vanilla ISO directly from the Mac App Store. Don't trust the hacked images, they might contain a hidden trojan.

 

Share this post


Link to post
Share on other sites
On 10/6/2020 at 1:50 AM, KellyK said:

 

I'm trying to install the Mac from a vanilla ISO directly from the Mac App Store. Don't trust the hacked images, they might contain a hidden trojan.

 

I was trying to reply to your post but due to the restrictions announced about spammers I couldn't. So I just wanted to tell you I run a scan with malwarebytes and eset on the vmdk and only malwarebytes inside the vm and everything was totally clean.

I'm afraid there is no other way to have catalina in vmware(v15.5 and above) with a ryzen cpu.

Share this post


Link to post
Share on other sites
On 10/8/2020 at 11:56 AM, alexnt said:

I'm afraid there is no other way to have catalina in vmware(v15.5 and above) with a ryzen cpu.

 

If the steps taken to create the VMDK in the first place were documented, then we wouldn't need to download someone else's disk image.  And there are plenty of potential hacks that Malwarebytes (or any other anti-malware program) won't catch, so it's not much comfort knowing that the image passed that one test.

Edited by omf

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

×