Jump to content

Kernel panic on shutdown (Clover + Mojave)


8 posts in this topic

Recommended Posts

Hi there,

 

I managed to install Mojave on my MSI GP62-6QE laptop with somewhat success. The only annoying thing left is that everytime I shut it down it seemingly kernel panics and I get the "Your computer has restarted because of a problem" at startup.

 

I tried many different things such as removing emuvariablesuefi64, checking FixShutdown in CloverConfig but it seems the NVRAM is causing this issue.

 

I have deleted the nvram file from the EFI partition but it seems stuck somewhere else, I can't clear out the nvram from the terminal or in single user mode as it returns a "Not permitted" error.

Clearing out the nvram by pressing F11 at the boot menu screen works however.

crashlog.rtf

My bad, I forgot to post the specs. Here they are:

 

CPU: Intel i5-6300HQ 

RAM: 12Gb DDR4

GPU: Nvidia GeForce 950M (Not used in macOS) + Intel HD 530

Wifi/Bluetooth: TP-Link USB Dongle/Integrated Intel Bluetooth thing

Ethernet: Killer Ethernet (Atheros E2200)

Motherboard: Proprietary MSI Intel-based laptop mainboard

 

EFI folder available here

A few comments on the kexts side:

  • You have kexts in E/C/k/10.14 and E/C/k/O; you should only used one or the other, not both, especially as you've effectively duplicated some of those kexts.
  • I question the relevance of some of the kexts you inject from E/C/k/10.14 folder on your Skylake HD530 platform, I'd get rid of them all.:
    • FakePCIIDxxxxx
    • GenericUSBXHCI
    • NullCPUPowerManagement
    • VoodooTSCSync
    • XHCI-unsupported
    • AppleIntelKBLGraphicsFramebufferInjector_3e9x
  • You should have native USB3.0 support and if you don't, 1st check that you inject Darwin for the correct OSYS value in DSDT (target Win Vista/Win7 values) or add FixDarwin7 ACPI fix in Clover. From memory Skylake platforms don't have USB2.0/USB3.0 controllers, just USB3.0.
  • You should have native CPU power management with the well-known PluginType parameter, in Clover nothing more.
  • You should have full graphics acceleration with the usual SKL properties injection in Clover.

 

On the Clover config side:

  • You can get rid of that list of disabled tables in the ACPI section; no such tables in your E/C/ACPI/Patched folder.
  • I don't think you need the -lilubeta boot parameter; Mojave has been fully supported by Lilu for some time...
  • you inject several properties for nVidia and ATI(AMD) graphics. I'm pretty sure you could/should clean that out.
  • in the same respect, I see lots of commented out property injections for your iGPU and HDEF devices; these don't do any harm but you may want to clean this out too.

 

Clearing NVRam with F11 is indeed the recommended method.

 

Can confirm, I do have native USB 3.0 support, which worked out of the box I'd say, graphics acceleration works like a charm and detects my HD 530 properly.

 

I cleared out the config.plist and the duplicate kexts. Cleared out the NVRAM, however it continues crashing.

 

After running nvram -p in the terminal, I can see that the aapl,panic-info line is really full, which makes me think the nvram is at fault and not clearing out properly.

 

 

config.plist

crashlog.rtf

Crashlog mentions several kexts in the backtrace, including the SKL framebuffer so you should concentrate on that 1st. 3 x comments:

  1. you've kept the nVidia + ATI property injections in your Clover config (Devices section). Remove them.
  2. you inject SKL ig-platform-id 0x191b for iGPU in the Devices section (properties injected for PciRoot(0)/Pci(0x02,0)) but, in the Graphics section, you subsequently inject ig-platform-id 0x1916. This is contradictory! Decide which platform-id you want to inject and only do it in the Devices section. The recommended value used to be 0x1916 for HD520/530/540 but you may experiment with the various values if required. Remove "Inject Intel" + ig-platform-id 0x19160000 in the Graphics section and stick with 0x191b to begin with.
  3. I also noticed your crashlog reports loaded kexts from a previous nVidia Web driver. Clearly your Maxwell dGPU cannot be supported in Mojave so remove/uninstall the nVidia Web Driver (no such driver for Mojave anyway) and disable your dGPU.
Use Clover Configurator app to modify your config.

 

You may try this test config. Copy it to EFI/CLOVER folder and call it from Options->Configs menu when Clover main screen appears.

config_test.plist

I think I found out another thing that was wrong with it! It seems that the nvram had somehow wrote itself into the BIOS of my laptop and was being used on each boot. After clearing out the CMOS, I don't appear to experience kernel panics at startup and the NVRAM is free of kernel panics!

 

Merci beaucoup de l'aide! :happymac:

×
×
  • Create New...