Jump to content
rgb

Marvell Yukon PCI-E 8056 works?

91 posts in this topic

Recommended Posts

to whoever said you need to edit the Info.plist file in SAFE MODE was definentally right. I've been struggling to get my integrated 8056 working. It has worked in ALL of my past installs, up until now. I've reinstalled mac many of times so it was no new game to me. But when I edited the plist file and come to see it still wasn't working, I was a little skeptical. I renamed the AppleYukon2.kext to AppleYukon.kext, deleted all the other networking kexts inside of IONetworkingFamily.kext and everything, and still no dice.

 

But I saw the suggestion for people that have EFI installed to boot into Safe Mode and edit the file there, then reboot. So I did exactly that, booted into Safe Mode, just opened the file like u normally would (That guide that uses terminal, like sudo nano stuff) and i followed that word for word, even though i've done it so many times i practially could recite it haha. But I did that, rebooted, and voila, it works!!!

 

But before you do that, make sure its working when you boot with ((((-f)))) before you go into safe mode. otherwise, you may be wasting your time. If it doesn't work in -f, then you HAVE typed something wrong or forgot to repair permissions or something that will make the kext invalid. Other than that, you should be good to go after doing this :) hope that helped

 

and thanks to whoever said that booting to Safe Mode and editing will fix it :)

Share this post


Link to post
Share on other sites
Advertisement

Hello everyone. I've just installed Kalyway 10.5.6 on my Gigabyte GA-965P-S3 (rev. 1). All works fine exept of Network. I have Marvel Yukon 88E8056 integrated in motherboard.  During installation i've marked this driver in "Custumize" menu. When Leopard starts for the first time i can't select any type of Network connection exept of "Telephone modem" ( i don't have one)  and "My computer does't have an Internet connection". All other other option are grey and can not be selected.

 

 

Tryed ediding Info.plist in AppleYukon2.kext but no result. After reboot nothing appears in Network selection menu and Leo still doesn't recognize my Network card. It says that i have no driver installed.

 

I would be glad of any help, that you could provide.

Share this post


Link to post
Share on other sites
Hello everyone. I've just installed Kalyway 10.5.6 on my Gigabyte GA-965P-S3 (rev. 1). All works fine exept of Network. I have Marvel Yukon 88E8056 integrated in motherboard. During installation i've marked this driver in "Custumize" menu. When Leopard starts for the first time i can't select any type of Network connection exept of "Telephone modem" ( i don't have one) and "My computer does't have an Internet connection". All other other option are grey and can not be selected.

 

 

Tryed ediding Info.plist in AppleYukon2.kext but no result. After reboot nothing appears in Network selection menu and Leo still doesn't recognize my Network card. It says that i have no driver installed.

 

I would be glad of any help, that you could provide.

 

Open Terminal

 

sudo -s

it will prompt for password, put your password here

 

cp Desktop/AppleYukon2.kext/Contents/Info.plist /System/Library/Extensions/AppleYukon2.kext/Contents

 

chown -R root:wheel /System/Library/Extensions/AppleYukon2.kext/

 

touch /System/Library/Extensions

exit

 

AppleYukon2.kext.zip

Share this post


Link to post
Share on other sites

Success - but it took me two hours before I read the post about "safe mode".

 

It is mentioned that you first have to check with the -f option. That did not work for me, but I tried the -x option anyhow. Still the LED's did not flicker, but when I went into System Preferences and Network my system showed a new Ethernet connection was found. I just had to activate it. Then I rebooted into normal mode and everything worked fine. Now I'm back in business.

 

The system is a Shuttle K45 (where the Marvell chip had worked with a 10.5.4 installation by iAtkos).

 

Thanks, JL

Share this post


Link to post
Share on other sites

hallelula!!!!

my internet finaly works!!!!!!!!!! thankyouthankyouthankyou.

 

after performing over 10 reinstalls due to various issues, i have finally fixed my last issue (network connections) thanks to this thread.

Share this post


Link to post
Share on other sites

:( I don`t now because my variant was ending similar... only Apple modem and ethernet device is not available.

I`ll try to do all methods

Share this post


Link to post
Share on other sites
That's the exact same problem I've been having with my SP35P2. Kalyway 10.5.2 works, JAS 10.5.4 doesn't. Editing doesn't do it, copying from Kalyway doesn't work. Maybe there's additional files that IONetworkingFamily depends on that need edits or have changed since?

 

Havent tried Kalaway 10.5.2 couldn't burn ISO in ubuntu downloading latest iPC which has suppost for marvell Yukon 88e8056 tried various kext editing and other "driver" pkgs nothting has worked I am hoping that I can open up the iso and pull off the "driver" if I can I will posy oy online somewhere!

 

--Jim

Share this post


Link to post
Share on other sites

i have the Shuttle K45 on board 8056 lan port.

the kext seems install correctly, but only work about 5-10 mins at the 1st boot. then no response from internet.

when i checked at the network options it showed self assigned IP.

so i must shut it down totally.... and turn it back on again, then it will work without any problems.

everyday i need to do the same process when i need to use my hackintosh online.

 

i installed Leopard retail 10.5.6 direct updated to 10.5.7 from apple with Chameleon 2.0.

 

can anyone help please!!!!!

Share this post


Link to post
Share on other sites
To get your Yukon 88E8056 Ethernet to work, you need to add your device id to the AppleYukon.kext. Go to Terminal and type:
cd /System/Library/Extensions											 <-- changes directory
sudo nano IONetworking.kext/Contents/PlugIns/AppleYukon.kext/Info.plist   <-- edits file

 (find and change: <key>Yukon-88E8053</key>)
 (to:			  <key>Yukon-88E8056</key>)	   <-- change "53" to "56"

 (find and change: <string>Yukon Gigabit Adapter 88E8053</string>)
 (to:			  <string>Yukon Gigabit Adapter 88E8056</string>)	   <-- change "53" to "56"

 (find and change: <string>0x436211AB</string>)
 (to:			  <string>0x436411AB</string>)	<-- change "62" to "64"

(press Control-O)								   <-- saves changes
(press Y and Enter)								 <-- accepts saving to existing file
(press Control-X)								   <-- exits nano

sudo chown -R root:wheel IONetworkingFamily.kext	<-- repairs permissions
cd /System/Library								  <-- changes directories
sudo rm -rf Extensions.mkext Extensions.kextcache   <-- rebuilds kextcache on reboot

Then reboot.

 

It worked like a champ, thank-you! I never thought I'd have to go back to Tiger. . .

Share this post


Link to post
Share on other sites

Might sound rather daft of me, noob... but i am doing this in terminal...

 

sudo nano ionetworkingfamily.kext/Contents/PlugIns/AppleYukon.kext/Info.plist

 

it asks for a password (i dont have 1) so i press enter, and nothing else happens! how am i suppose to find a string if nothing happens? Cheers

Share this post


Link to post
Share on other sites

Hi, i have installed ideneb 10.5.5 on my Quanta TW3M(advent 8315) and its working fine but i have no network options available.

 

I have a Marvel Yukon ethernet card built in although i dont know what model it is, how can i find out easily?

 

I dont have windows on my pc anymore, just 10.5.5 and the system profiler doesnt give me any pointers as to the model of the card! Is there a easily installable generic Marvel Yukon driver that i can download from somewhere?

 

I attach a screenshot of a very empty looking network control panel! Not sure if i should have any options here at all!

 

Thanks!

Smuudge

post-579057-1267047168_thumb.png

Share this post


Link to post
Share on other sites
cd /System/Library/Extensions   <-- changes directory</P><P>sudo nano IONetworking.kext/Contents/PlugIns/AppleYukon.kext/Info.plist  <-- edits file</P><P>find and change: </P><P><key>Yukon-88E8053</key> </P><P>to: <key>Yukon-88E8056</key> <-- change "53" to "56"</P><P>find and change: <string>Yukon Gigabit Adapter 88E8053</string></P><P>to: <string>Yukon Gigabit Adapter 88E8056</string> <-- change "53" to "56"</P><P>find and change: </P><P><string>0x436211AB</string> </P><P>to: <string>0x436411AB</string> <-- change "62" to "64" </P><P>(press Control-O) <-- saves changes</P><P>(press Y and Enter) <-- accepts saving to existing file</P><P>(press Control-X) <-- exits nano</P><P>sudo chown -R root:wheel IONetworkingFamily.kext <-- repairs permissions</P><P>cd /System/Library <-- changes directories</P><P>sudo rm -rf Extensions.mkext Extensions.kextcache <-- rebuilds kextcache on reboot

 

 

  1. add device id to the AppleYukon.kext
  2. exit "Terminal" end "repair permission" in "Disk Utility"
  3. reboot...
  4. And Yukon 88E8056 Ethernet not work!   :(:P:((P5E3 WS Professional) MAC Snow 10.6.3

Please, help me!!!

Share this post


Link to post
Share on other sites
  1. add device id to the AppleYukon.kext
  2. exit "Terminal" end "repair permission" in "Disk Utility"
  3. reboot...
  4. And Yukon 88E8056 Ethernet to work!  :):D:D(P5E3 WS Professional) MAC Snow 10.6.3

Please, help me!!!

 

A driver from kexts.com

 

try that one.

Share this post


Link to post
Share on other sites

I tried this tutorial with the board 88E8059, but the only thing I got was the OSX recognizes the card, but when I go to connect it says "Cable unplugged" ...

 

Can someone help me please?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×