Jump to content
Prasys

ATI Radeon Easy-Installer - BETA

56 posts in this topic

Recommended Posts

Everyone - thank you for your good work. I have a dell latitude d600 with radeon 9000, if anyone need info from the 9000 mobility card just ask me. I am not sure what i can do to help this process. Again thank you very much.

Share this post


Link to post
Share on other sites
Advertisement

siddharth - Unfortunately the x200 is ridiculously far away from any supported graphics card, I've tried in vain to get QE/CI working on a friend's X200. You may want to try Katana installer to get OpenGL acceleration working, at this point in time I think it's as close as you're going to get.

 

You can get Katana here --> http://forum.insanelymac.com/index.php?sho...=35345&st=0

Share this post


Link to post
Share on other sites

That doesn't really matter unfortunately :/. It's not that the hardware is incapable of displaying the graphics (or that it is used by motherboards made by intel), it's just that OS X just doesn't fully support that card. It doesn't have any computers (or vendors offering a x200/x300 card) which use a comparable card so there's no reason to add x200/x300 functionality. OS X uses VESA (a low-level failsafe method to send understandable data to your graphics card (in essence)) if it can't find a compatible graphics card - which is what you're likely using now. For this reason, you may want to try using Katana to see if it will get you somewhere.

Share this post


Link to post
Share on other sites

I took a look at the ATIRadeon8500.kext from Darwin 8.0.1 x86. This kext is Intel only. Not Universal or PPC.

These are the matching id's i found in the info.plist:

 

0x514C1002 
CHIP_R200 "ATI Radeon QL R200 8500 LE"

0x516C1002
Chip Number: 	R200
Chip Description: 	Radeon 8500 / 8500LE

0x4C661002
CHIP_R250|CHIP_IS_MOBILITY "ATI Radeon Lf R250 Mobility 9000 M9"

0x49661002
CHIP_R250 "ATI Radeon If R250 9000"

0x59601002
CHIP_RV280 "ATI Radeon RV280 9200"

0x59611002
CHIP_RV280 "ATI Radeon RV280 9200 SE"

0x5C631002
CHIP_RV280|CHIP_IS_MOBILITY "ATI Radeon RV280 Mobility"(Mobility Radeon 9200)

0x49671002
CHIP_R250 "ATI Radeon Ig R250 9000"

0x59621002
CHIP_RV280 "ATI Radeon RV280 9200"

0x59631002
CHIP_RV280 "ATI Radeon RV280 9200"

 

I added the corresponding names for the cards.

Share this post


Link to post
Share on other sites

9700 pro - should work

 

x700 -should work

 

8500 series - Only Software OpenGL acceleration !

Share this post


Link to post
Share on other sites

when installed, rebooted, no change in QE/CI on Radeon X600SE (PCIE) 0x5462. Callisto 6 installed for resolution adjustment. 10.4.8/8.8.1 install.

Edited by DC2BAR

Share this post


Link to post
Share on other sites

@ prasys

i've downloading u'r patch, but nothing change anything

my gpu pcie atiradeon x550 CI&QC not supported on core2duo x6400

gigabyte ds4

Share this post


Link to post
Share on other sites

I tried with x700pro here's the result:

 

Type: Display

Bus: PCIe

VRAM (Total): 128 MB

Vendor: ATI (0x1002)

Device ID: 0x5e4b

Revision ID: 0x0000

Kernel Extension Info: No Kext Loaded

Displays:

Display:

Resolution: 1024 x 768

Depth: 32-bit Color

Core Image: Not Supported

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported

 

 

Does the installer use some kexts from extention folder? I've removed some.

 

I tried clysto patch also - it works, but there are problems with mouse artifacts and there's no complete solution.

Edited by hryamzik

Share this post


Link to post
Share on other sites

I have a Mobility 7000 IGP here (R200 family, i guess). I was using Katana (callisto+AGPGart), but they load the CPU too much, without any significant performance improvement. So Im back to the VESA drivers. I'll been researching about flashing the card rom, since there's a mac version of the 7000, but it seems to work only with PCI-AGP cards. I've been trying to backup the rom before trying anything else, and rom dumpers (Flashrom, ATITool, Graphiccelerator, etc) doesnt seems to work with IGP cards.... Not to tell that flashing the rom succesfuly would render the card unusable in windows.

here there is a link in case someone wants to wonder about it.....

 

http://www.cubeowner.com/forums//index.php?showtopic=8798

 

A driver for the R200 family would be great!

Share this post


Link to post
Share on other sites

Hi

 

Can you tell me if this should/might work for the Radeon 9600?

 

Also, what exactly does this do... I'm fairly new to Mac OS X and I'm just getting my head round kexts and stuff... as far as I know I'm currently using the stuff in ATIRadeon9700.kext for my card, because the way I got the GUI to work was to remove all other ATI/NVidia/GeForce files from my System/Libraries/Extensions directory

 

does this update ATIRadeon9700.kext or something?

 

A quick overview would be great :star_smile:

Share this post


Link to post
Share on other sites

Great to have the good news. I display card is 9550, and I have been searching the driver for a long long time. You are really god-like. TQ!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×