Jump to content

(HS, GTX 1060) Unable to get GPU acceleration, frozen login screen when booted with webdriver enabled


3 posts in this topic

Recommended Posts


Below are the specs of the system:

  • Gigabyte H61M-s
  • 16 GB DDR3 RAM
  • EVO 860 500 GB (APFS formatted)
  • i3-3220
  • Zotac GTX 1060 6 GB GDDR5X (currently using HDMI)
  • Dual booted with Windows 10 on a different drive

Config.plist and EFI are at the bottom.

I have been struggling with a very specific problem since months ago that I still haven't been able to find a working solution for. Before this, I had my hack running on High Sierra that was installed using the tonymac tools. Recently, I reinstalled the OS using the vanilla guide, and the problem is still there after installing the web driver (which I have done using this guide from Hackintosher). I have also tried different builds of macOS 10.13.6 and their corresponding webdriver, and the problem has been the same.

I have the correct version of Nvidia web driver installed for my version of macOS. The installation was smooth and the Nvidia icon shows up in the status bar. Below, I have explained what happens with different settings.

  • 1. When the webdriver is disabled in clover, the system works, but obviously with tearing animations, stretched screen resolution and no GPU acceleration. The about section shows the graphics as "Display 5MB". The login screen consists of a plain grey background. Just how it is when you freshly install the OS with non AMD GPUs.
Post image
Post image


  • 2. Now, when the webdriver is enabled in clover and the system is booted, after the apple logo, the screen turns off for a second (to switch resolution), turns back on with the login screen at correct resolution and blurred HS background (like it is supposed to), then shows the shut down screen, then a black screen with cursor in corner, then back to login screen...this goes on and on while the keyboard and mouse are unresponsive. Here's one of the threads I was able to find on similar problem. YouTube link for the video that I have recorded of my screen. The weird part is that this exact thing happens even when the macOS is setup to login automatically, i.e. it displays the frozen login screen with the password field.
  • 3. When the webdriver is enabled along with safe mode in clover, the screen resolution gets fixed and the monitor name is also detected. The about section shows the graphics as "Nvidia Chip Model 6143 MB". But there's still no GPU acceleration and this time, the Nvidia icon is missing from the status bar. This is the closest that I have been able reach to success.
Post image
Post image
Post image
  • 4. When the webdriver along with "Set Nvidia to VESA" is enabled in clover, the system boots up, Nvidia icon is visible in the status bar and when clicked, shows that the webdriver is enabled. But everything else is the same as when the web driver is disabled, as shown in the 1st point above, except that the about section now displays graphics as "Nvidia chip model 5 MB".
Post image
Post image
Post image

Could anyone please help me out? It has been many months and I am now tired of trying and failing. I am completely lost at this point. I have seen so many posts from people with a fully working GTX 1060 on their hacks, yet I am unable to get mine to work. I am guessing it's just an incompatibility problem with my specific version of GTX 1060. Or may be it is just a problem on the software side? Maybe it's just a missing kext, or a single line of code needs to be changed in config.plist? I am also taking into consideration that it could be a problem with HDMI because I haven't yet been able to test out any of the 3 DisplayPorts that the GPU has, due to lack of a DP cable.

I would be really grateful if anyone is able to help me out with this.


Full EFI folder


Contents of EFI\Clover below:

Post image
Edited by manav20
added tags
Link to comment
Share on other sites

10 hours ago, Hervé said:

Your Clover config appears incorrect in several areas such CPU power management (mix of settings for different platforms), SMBIOS (none specified), or SIP (disabling absent). Most important is SMBIOS (lack of it could explain black screen). Try the attached. Place it alongside your current config file and select it at Clover main menu through Options->Configs.



You'll also need to generate your own CPU-specific power management SSDT through Pike R Alpha's well-known generator script.

Hi @Hervé

Thanks a lot for taking your time to go through my post and giving such a quick response. I tried the config file provided by you and I seem to have taken a step forward. Here's what I did.


After booting with your config file, I used the SSDT generator script that you mentioned and here's the log from the terminal window:


Last login: Wed Apr 22 03:26:14 on console

Manavs-iMac:~ manav$ curl -o ~/ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/master/ssdtPRGen.sh

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                 Dload  Upload   Total   Spent    Left  Speed

100  126k  100  126k    0     0   356k      0 --:--:-- --:--:-- --:--:--  355k

Manavs-iMac:~ manav$ chmod +x ~/ssdtPRGen.sh

Manavs-iMac:~ manav$ sudo ~/ssdtPRGen.sh


















ssdtPRGen.sh v0.9 Copyright (c) 2011-2012 by † RevoGirl

             v6.6 Copyright (c) 2013 by † Jeroen

             v15.6 Copyright (c) 2013-2020 by Pike R. Alpha


Bugs > https://github.com/Piker-Alpha/ssdtPRGen.sh/issues <


gDataPath: /Users/manav/Library/ssdtPRGen/Data

System information: Mac OS X 10.13.6 (17G12034)

Brandstring 'Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz'


Scope (_PR_) {220 bytes} with ACPI Processor declarations found in the DSDT (ACPI 1.0 compliant)

Generating ssdt.dsl for a 'iMac13,2' with board-id [Mac-FC02E91DDD3FA6A4]

Ivy Bridge Core i3-3220 processor [0x306A9] setup [0x0903]

With a maximum TDP of 55 Watt, as specified by Intel

Number logical CPU's: 4 (Core Frequency: 3300 MHz)

Number of Turbo States: 0

Number of P-States: 18 (1600-3300 MHz)

Injected C-States for CPU0 (C1,C3,C6)

Injected C-States for CPU1 (C1,C2,C3)

Warning: 'cpu-type' may be set improperly (0x0903 instead of 0x0703)


Intel ACPI Component Architecture

ASL Optimizing Compiler version 20140926-64 [Nov  6 2014]

Copyright (c) 2000 - 2014 Intel Corporation


ASL Input:     /Users/manav/Library/ssdtPRGen/ssdt.dsl - 255 lines, 7951 bytes, 48 keywords

AML Output:    /Users/manav/Library/ssdtPRGen/ssdt.aml - 1682 bytes, 16 named objects, 32 executable opcodes


Compilation complete. 0 Errors, 0 Warnings, 0 Remarks, 0 Optimizations


Do you want to copy /Users/manav/Library/ssdtPRGen/ssdt.aml to /Extra/ssdt.aml? (y/n)? n

Do you want to open ssdt.dsl (y/n)? n

Manavs-iMac:~ manav$



I then went to ~/Library/ssdtPRGen/ and copied the SSDT.aml to /Volumes/EFI/EFI/CLOVER/ACPI/patched/. 

Now, with your config file, I am still able to boot only with nvda_drv=1 disabled, but, the OS is now at least detecting the name of the GPU. The about section is showing the graphics as "Zotac GeForce GTX 1060 256 MB".



And when I boot with nvda_drv=1 enabled, the monitor stops receiving any signal after the boot screen. I have even setup a Remote Desktop application to start up as soon as the system boots up, thinking that the GPU is failing to output through the HDMI port and that I might be able to check everything out using that Remote Desktop application, but even that fails to connect, indicating that the system isn't starting up fully.

The Remote Desktop app connects immediately after the system boots up with nvda_drv=1 disabled.

If they are of any use, here are the 2 videos that I have recorded, including the verbose screen, when the system is booted up:

With nvda_drv=1

Without nvda_drv=1


Also, I tried unchecking the "Inject Nvidia" setting in clover settings and then booting up with nvda_drv=1 enabled, and I started to have the same problem of blinking frozen login screen and black screen like before, except this time, the black screen shows some sort of error code.


Thanks for your time.

Link to comment
Share on other sites

On 4/22/2020 at 4:06 AM, manav20 said:

Also, I tried unchecking the "Inject Nvidia" setting in clover settings and then booting up with nvda_drv=1 enabled, and I started to have the same problem of blinking frozen login screen and black screen like before, except this time, the black screen shows some sort of error code.



Just wanted to post an elaboration of the above statement. So, when I boot up with the following settings:

  • config-test.plist (provided by @Hervé)
  • Under "Graphics Injector" in Clover settings, disable "InjectNvidia" and leave "Use Nvidia web drivers" enabled
  • Under boot drive options, enable "-v" and "nvda_drv=1"

The OS boots up with that frozen login screen and a blinking black screen in between which shows a few lines of error codes, which you can see in the below images (Imgur link for the same):












Each time the black screen appears, it shows any of the above error code lines. In all of them, the last two lines (starting with "IOConsoleUsers") are common. 

Maybe this can help in finding out where exactly the problem is. Here's a recording of the screen.

Could anyone please look into this and help me?



Link to comment
Share on other sites


  • Create New...