Jump to content
ainsleyclark

Opencore - Set Default Disk, Startup Disk not working

4 posts in this topic

Recommended Posts

Hi there.

 

I’m a bit of a beginner at opencore. I have it booting successfully but I can’t change my default drive. I’m dual booting windows and mac.
 

In startup disk I select macOS restart but it goes straight into Windows. 
 

Is there any way to change the default startup disk manually using opencore?

NVRAM is working fine it seems.

 

Many thanks in advance.

Share this post


Link to post
Share on other sites
Advertisement

I'm no expert at all but recall reading this in the guide...

 

Quote
  • RequestBootVarRouting: YES
    • Redirects AptioMemeoryFix from EFI_GLOBAL_VARIABLE_GUID to OC\_VENDOR\_VARIABLE\_GUID. Needed for when firmware tries to delete boot entries and is recommended to be enabled on all systems for correct update installation, Startup Disk control panel functioning, etc.

 

Share this post


Link to post
Share on other sites

this works like a real mac in system preferences for me. (Startup Disk)

 

select your drive and that seems to do it.

Share this post


Link to post
Share on other sites

set default boot drive : in the Boot Picker screen, select the boot drive that you want, use the hot-key (Control + Enter)

 

 

config.plist setting

----------------------

 

Misc/Security Properties ::

 

AllowSetDefault
Type: plist boolean
Failsafe: false
Description: Allow CTRL+Enter and CTRL+Index handling to set the default boot option in boot picker.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×